aboutsummaryrefslogtreecommitdiffstats
path: root/devel/gnomebuild/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'devel/gnomebuild/Makefile')
-rw-r--r--devel/gnomebuild/Makefile10
1 files changed, 9 insertions, 1 deletions
diff --git a/devel/gnomebuild/Makefile b/devel/gnomebuild/Makefile
index 8928fe49763..64121dfa33f 100644
--- a/devel/gnomebuild/Makefile
+++ b/devel/gnomebuild/Makefile
@@ -27,4 +27,12 @@ INSTALLS_SHLIB= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LIBS="-L${LOCALBASE}/lib -lgnuregex"
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 500000
+EXTRA_PATCHES+= ${FILESDIR}/current-src_backends_libgbf_am_gbf-am-project.c
+.else
+EXTRA_PATCHES+= ${FILESDIR}/stable-src_backends_libgbf_am_gbf-am-project.c
+.endif
+
+.include <bsd.port.post.mk>