aboutsummaryrefslogtreecommitdiffstats
path: root/devel/haddock/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'devel/haddock/Makefile')
-rw-r--r--devel/haddock/Makefile6
1 files changed, 5 insertions, 1 deletions
diff --git a/devel/haddock/Makefile b/devel/haddock/Makefile
index 2053359596a..8c0abee4e66 100644
--- a/devel/haddock/Makefile
+++ b/devel/haddock/Makefile
@@ -5,7 +5,7 @@
# $FreeBSD$
PORTNAME= haddock
-PORTVERSION= 0.3
+PORTVERSION= 0.4
CATEGORIES= devel
MASTER_SITES= http://www.haskell.org/haddock/
DISTNAME= ${PORTNAME}-${PORTVERSION}-src
@@ -23,9 +23,13 @@ BUILD_DEPENDS+= ${LOCALBASE}/share/sgml/docbook/dsssl/modular:${PORTSDIR}/textpr
.endif
WRKSRC= ${WRKDIR}/${DISTNAME:S/-src//g}
+USE_REINPLACE= yes
USE_GMAKE= yes
GNU_CONFIGURE= yes
+post-patch:
+ @${REINPLACE_CMD} -e 's|/usr/local/share/sgml/catalog||' ${WRKSRC}/configure
+
post-build:
.if !defined(NOPORTDOCS)
@(cd ${WRKSRC}/haddock/doc && \