aboutsummaryrefslogtreecommitdiffstats
path: root/devel/hs-pcre-light-ghc/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'devel/hs-pcre-light-ghc/Makefile')
-rw-r--r--devel/hs-pcre-light-ghc/Makefile52
1 files changed, 52 insertions, 0 deletions
diff --git a/devel/hs-pcre-light-ghc/Makefile b/devel/hs-pcre-light-ghc/Makefile
new file mode 100644
index 00000000000..b10281176df
--- /dev/null
+++ b/devel/hs-pcre-light-ghc/Makefile
@@ -0,0 +1,52 @@
+# New ports collection makefile for: pcre-light
+# Date created: December 16, 2008
+# Whom: Gabor Pali <pgj@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= pcre-light
+PORTVERSION= 0.3.1
+CATEGORIES= devel haskell
+MASTER_SITES= http://hackage.haskell.org/packages/archive/${PORTNAME}/${PORTVERSION}/
+PKGNAMEPREFIX= hs-
+PKGNAMESUFFIX= -ghc
+
+MAINTAINER= haskell@FreeBSD.org
+COMMENT= A lightweight Haskell regex library compatible with Perl 5
+
+BUILD_DEPENDS= ghc>=6.8:${PORTSDIR}/lang/ghc
+LIB_DEPENDS= pcre:${PORTSDIR}/devel/pcre
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+GHC_VERSION= 6.8.3
+CABALCMD= ${LOCALBASE}/bin/runghc Setup.lhs
+CABALDIR= lib/ghc-${GHC_VERSION}/cabal
+
+SUBDIR= lib/${PORTNAME}-${PORTVERSION}
+PLIST_SUB= GHC_VERSION=${GHC_VERSION} \
+ PORTNAME=${PORTNAME} \
+ PORTVERSION=${PORTVERSION} \
+ SUBDIR=${CABALDIR}
+DOCSDIR= share/doc/${PORTNAME}-${PORTVERSION}
+
+CONFIGURE_ARGS= --ghc --prefix=${PREFIX} --libdir=${PREFIX}/${CABALDIR} --libsubdir='' --datasubdir=''
+
+.ifndef (NOPORTDOCS)
+BUILD_DEPENDS+= haddock:${PORTSDIR}/devel/hs-haddock
+.endif
+
+do-configure:
+ cd ${WRKSRC} && ${CABALCMD} configure ${CONFIGURE_ARGS}
+
+do-build:
+ cd ${WRKSRC} && ${CABALCMD} build && ${CABALCMD} --gen-script register
+.ifndef (NOPORTDOCS)
+ cd ${WRKSRC} && ${CABALCMD} haddock
+.endif
+
+do-install:
+ cd ${WRKSRC} && ${CABALCMD} install
+ ${INSTALL_SCRIPT} ${WRKSRC}/register.sh ${PREFIX}/${CABALDIR}/${PORTNAME}-register.sh
+
+.include <bsd.port.mk>