aboutsummaryrefslogtreecommitdiffstats
path: root/devel/icu/files
diff options
context:
space:
mode:
Diffstat (limited to 'devel/icu/files')
-rw-r--r--devel/icu/files/patch-common_Makefile.in11
-rw-r--r--devel/icu/files/patch-common_umutex.cpp25
-rw-r--r--devel/icu/files/patch-common_unicode_platform.h13
-rw-r--r--devel/icu/files/patch-common_unicode_uconfig.h11
-rw-r--r--devel/icu/files/patch-config__mh-bsd-gcc12
-rw-r--r--devel/icu/files/patch-config_mh-bsd-gcc82
-rw-r--r--devel/icu/files/patch-i18n_Makefile.in11
-rw-r--r--devel/icu/files/patch-install8
-rw-r--r--devel/icu/files/patch-io_Makefile.in11
-rw-r--r--devel/icu/files/patch-layout_Makefile.in11
-rw-r--r--devel/icu/files/patch-layoutex_Makefile.in11
-rw-r--r--devel/icu/files/patch-stubdata_Makefile.in11
-rw-r--r--devel/icu/files/patch-tools_ctestfw_Makefile.in11
-rw-r--r--devel/icu/files/patch-tools_toolutil_Makefile.in11
14 files changed, 219 insertions, 20 deletions
diff --git a/devel/icu/files/patch-common_Makefile.in b/devel/icu/files/patch-common_Makefile.in
new file mode 100644
index 00000000000..501313e5372
--- /dev/null
+++ b/devel/icu/files/patch-common_Makefile.in
@@ -0,0 +1,11 @@
+--- common/Makefile.in.orig 2016-03-23 20:50:12 UTC
++++ common/Makefile.in
+@@ -146,7 +146,7 @@ install-local: install-headers install-l
+ install-library: all-local
+ $(MKINSTALLDIRS) $(DESTDIR)$(libdir)
+ ifneq ($(ENABLE_STATIC),)
+- $(INSTALL-L) $(TARGET) $(DESTDIR)$(libdir)
++ $(INSTALL_DATA) $(TARGET) $(DESTDIR)$(libdir)
+ endif
+ ifneq ($(ENABLE_SHARED),)
+ $(INSTALL-L) $(FINAL_SO_TARGET) $(DESTDIR)$(libdir)
diff --git a/devel/icu/files/patch-common_umutex.cpp b/devel/icu/files/patch-common_umutex.cpp
new file mode 100644
index 00000000000..024225bff10
--- /dev/null
+++ b/devel/icu/files/patch-common_umutex.cpp
@@ -0,0 +1,25 @@
+--- common/umutex.cpp.orig 2016-03-23 20:50:10 UTC
++++ common/umutex.cpp
+@@ -264,19 +264,19 @@ static pthread_cond_t initCondition = PT
+ U_COMMON_API UBool U_EXPORT2
+ umtx_initImplPreInit(UInitOnce &uio) {
+ pthread_mutex_lock(&initMutex);
+- int32_t state = uio.fState;
++ int32_t state = umtx_loadAcquire(uio.fState);
+ if (state == 0) {
+ umtx_storeRelease(uio.fState, 1);
+ pthread_mutex_unlock(&initMutex);
+ return TRUE; // Caller will next call the init function.
+ } else {
+- while (uio.fState == 1) {
++ while (umtx_loadAcquire(uio.fState) == 1) {
+ // Another thread is currently running the initialization.
+ // Wait until it completes.
+ pthread_cond_wait(&initCondition, &initMutex);
+ }
+ pthread_mutex_unlock(&initMutex);
+- U_ASSERT(uio.fState == 2);
++ U_ASSERT(umtx_loadAcquire(uio.fState) == 2);
+ return FALSE;
+ }
+ }
diff --git a/devel/icu/files/patch-common_unicode_platform.h b/devel/icu/files/patch-common_unicode_platform.h
new file mode 100644
index 00000000000..895bb50e3de
--- /dev/null
+++ b/devel/icu/files/patch-common_unicode_platform.h
@@ -0,0 +1,13 @@
+--- common/unicode/platform.h.orig 2016-03-23 20:49:58 UTC
++++ common/unicode/platform.h
+@@ -379,8 +379,8 @@
+ */
+ #ifdef U_IS_BIG_ENDIAN
+ /* Use the predefined value. */
+-#elif defined(BYTE_ORDER) && defined(BIG_ENDIAN)
+-# define U_IS_BIG_ENDIAN (BYTE_ORDER == BIG_ENDIAN)
++#elif defined(_BYTE_ORDER) && defined(_BIG_ENDIAN)
++# define U_IS_BIG_ENDIAN (_BYTE_ORDER == _BIG_ENDIAN)
+ #elif defined(__BYTE_ORDER__) && defined(__ORDER_BIG_ENDIAN__)
+ /* gcc */
+ # define U_IS_BIG_ENDIAN (__BYTE_ORDER__ == __ORDER_BIG_ENDIAN__)
diff --git a/devel/icu/files/patch-common_unicode_uconfig.h b/devel/icu/files/patch-common_unicode_uconfig.h
new file mode 100644
index 00000000000..523ae7cf27a
--- /dev/null
+++ b/devel/icu/files/patch-common_unicode_uconfig.h
@@ -0,0 +1,11 @@
+--- common/unicode/uconfig.h.orig 2016-03-23 20:49:54 UTC
++++ common/unicode/uconfig.h
+@@ -87,7 +87,7 @@
+ * @internal
+ */
+ #ifndef U_DISABLE_RENAMING
+-#define U_DISABLE_RENAMING 0
++#define U_DISABLE_RENAMING 1
+ #endif
+
+ /**
diff --git a/devel/icu/files/patch-config__mh-bsd-gcc b/devel/icu/files/patch-config__mh-bsd-gcc
deleted file mode 100644
index d5576fd7511..00000000000
--- a/devel/icu/files/patch-config__mh-bsd-gcc
+++ /dev/null
@@ -1,12 +0,0 @@
---- ./config/mh-bsd-gcc.orig 2011-10-19 01:13:00.000000000 +0200
-+++ ./config/mh-bsd-gcc 2012-01-14 21:01:17.083384507 +0100
-@@ -23,9 +23,6 @@
- ## Compiler switch to embed a library name
- LD_SONAME = -Wl,-soname -Wl,$(notdir $(MIDDLE_SO_TARGET))
-
--## Shared library options
--LD_SOOPTIONS= -Wl,-Bsymbolic
--
- ## Shared object suffix
- SO = so
- ## Non-shared intermediate object suffix
diff --git a/devel/icu/files/patch-config_mh-bsd-gcc b/devel/icu/files/patch-config_mh-bsd-gcc
new file mode 100644
index 00000000000..b4583b6ec1d
--- /dev/null
+++ b/devel/icu/files/patch-config_mh-bsd-gcc
@@ -0,0 +1,82 @@
+--- config/mh-bsd-gcc.orig 2016-03-23 20:50:50 UTC
++++ config/mh-bsd-gcc
+@@ -4,8 +4,8 @@
+ ## others. All Rights Reserved.
+
+ ## Commands to generate dependency files
+-GEN_DEPS.c= $(CC) -E -MM $(DEFS) $(CPPFLAGS)
+-GEN_DEPS.cc= $(CXX) -E -MM $(DEFS) $(CPPFLAGS)
++GEN_DEPS.c= $(CC) -E -MM $(DEFS) $(CPPFLAGS)
++GEN_DEPS.cc= $(CXX) -E -MM $(DEFS) $(CPPFLAGS) $(CXXFLAGS)
+
+ ## Flags for position independent code
+ SHAREDLIBCFLAGS = -fPIC
+@@ -18,10 +18,16 @@ LIBCPPFLAGS =
+
+ ## Compiler switch to embed a runtime search path
+ LD_RPATH=
+-LD_RPATH_PRE= -Wl,-rpath,
++LD_RPATH_PRE = -Wl,-rpath,
++
++## These are the library specific LDFLAGS
++LDFLAGSICUDT=-nodefaultlibs -nostdlib
+
+ ## Compiler switch to embed a library name
+-LD_SONAME = -Wl,-soname -Wl,$(notdir $(MIDDLE_SO_TARGET))
++# The initial tab in the next line is to prevent icu-config from reading it.
++ LD_SONAME = -Wl,-soname -Wl,$(notdir $(MIDDLE_SO_TARGET))
++#SH# # We can't depend on MIDDLE_SO_TARGET being set.
++#SH# LD_SONAME=
+
+ ## Shared library options
+ LD_SOOPTIONS= -Wl,-Bsymbolic
+@@ -33,27 +39,27 @@ STATIC_O = ao
+
+ ## Compilation rules
+ %.$(STATIC_O): $(srcdir)/%.c
+- $(COMPILE.c) $(STATICCPPFLAGS) $(STATICCFLAGS) -o $@ $<
++ $(call SILENT_COMPILE,$(strip $(COMPILE.c) $(STATICCPPFLAGS) $(STATICCFLAGS)) -o $@ $<)
+ %.o: $(srcdir)/%.c
+- $(COMPILE.c) $(DYNAMICCPPFLAGS) $(DYNAMICCFLAGS) -o $@ $<
++ $(call SILENT_COMPILE,$(strip $(COMPILE.c) $(DYNAMICCPPFLAGS) $(DYNAMICCFLAGS)) -o $@ $<)
+
+ %.$(STATIC_O): $(srcdir)/%.cpp
+- $(COMPILE.cc) $(STATICCPPFLAGS) $(STATICCXXFLAGS) -o $@ $<
++ $(call SILENT_COMPILE,$(strip $(COMPILE.cc) $(STATICCPPFLAGS) $(STATICCXXFLAGS)) -o $@ $<)
+ %.o: $(srcdir)/%.cpp
+- $(COMPILE.cc) $(DYNAMICCPPFLAGS) $(DYNAMICCXXFLAGS) -o $@ $<
++ $(call SILENT_COMPILE,$(strip $(COMPILE.cc) $(DYNAMICCPPFLAGS) $(DYNAMICCXXFLAGS)) -o $@ $<)
+
+
+ ## Dependency rules
+ %.d: $(srcdir)/%.c
+- @echo "generating dependency information for $<"
++ $(call ICU_MSG,(deps)) $<
+ @$(SHELL) -ec '$(GEN_DEPS.c) $< \
+- | sed '\''s/\($*\)\.o[ :]*/\1.o $@ : /g'\'' > $@; \
++ | sed '\''s%\($*\)\.o[ :]*%\1.o $@ : %g'\'' > $@; \
+ [ -s $@ ] || rm -f $@'
+
+ %.d: $(srcdir)/%.cpp
+- @echo "generating dependency information for $<"
++ $(call ICU_MSG,(deps)) $<
+ @$(SHELL) -ec '$(GEN_DEPS.cc) $< \
+- | sed '\''s/\($*\)\.o[ :]*/\1.o $@ : /g'\'' > $@; \
++ | sed '\''s%\($*\)\.o[ :]*%\1.o $@ : %g'\'' > $@; \
+ [ -s $@ ] || rm -f $@'
+
+ ## Versioned libraries rules
+@@ -64,7 +70,7 @@ STATIC_O = ao
+ $(RM) $@ && ln -s ${*F}.$(SO).$(SO_TARGET_VERSION) $@
+
+ ## Bind internal references
+-
++
+ # LDflags that pkgdata will use
+ BIR_LDFLAGS= -Wl,-Bsymbolic
+
+@@ -77,4 +83,3 @@ STATIC_PREFIX =
+
+ ## End BSD-specific setup
+
+-
diff --git a/devel/icu/files/patch-i18n_Makefile.in b/devel/icu/files/patch-i18n_Makefile.in
new file mode 100644
index 00000000000..ea934c0f4cb
--- /dev/null
+++ b/devel/icu/files/patch-i18n_Makefile.in
@@ -0,0 +1,11 @@
+--- i18n/Makefile.in.orig 2016-03-23 20:49:38 UTC
++++ i18n/Makefile.in
+@@ -135,7 +135,7 @@ install-local: install-headers install-l
+ install-library: all-local
+ $(MKINSTALLDIRS) $(DESTDIR)$(libdir)
+ ifneq ($(ENABLE_STATIC),)
+- $(INSTALL-L) $(TARGET) $(DESTDIR)$(libdir)
++ $(INSTALL_DATA) $(TARGET) $(DESTDIR)$(libdir)
+ endif
+ ifneq ($(ENABLE_SHARED),)
+ $(INSTALL-L) $(FINAL_SO_TARGET) $(DESTDIR)$(libdir)
diff --git a/devel/icu/files/patch-install b/devel/icu/files/patch-install
deleted file mode 100644
index 9af0afc8059..00000000000
--- a/devel/icu/files/patch-install
+++ /dev/null
@@ -1,8 +0,0 @@
---- Makefile.in 2007-12-12 13:58:06.000000000 -0500
-+++ Makefile.in 2008-01-28 15:20:56.000000000 -0500
-@@ -126,5 +126,4 @@
- $(INSTALL_DATA) @platform_make_fragment@ $(DESTDIR)$(pkgdatadir)/config/@platform_make_fragment_name@
- $(INSTALL_SCRIPT) $(top_srcdir)/mkinstalldirs $(DESTDIR)$(pkgdatadir)/mkinstalldirs
-- $(INSTALL_SCRIPT) $(top_srcdir)/install-sh $(DESTDIR)$(pkgdatadir)/install-sh
- $(INSTALL_DATA) $(top_srcdir)/../license.html $(DESTDIR)$(pkgdatadir)/license.html
- $(INSTALL_SCRIPT) $(top_builddir)/config/icu-config $(DESTDIR)$(bindir)/icu-config
diff --git a/devel/icu/files/patch-io_Makefile.in b/devel/icu/files/patch-io_Makefile.in
new file mode 100644
index 00000000000..9d44a6211a0
--- /dev/null
+++ b/devel/icu/files/patch-io_Makefile.in
@@ -0,0 +1,11 @@
+--- io/Makefile.in.orig 2016-03-23 20:50:52 UTC
++++ io/Makefile.in
+@@ -96,7 +96,7 @@ install-local: install-headers install-l
+ install-library: all-local
+ $(MKINSTALLDIRS) $(DESTDIR)$(libdir)
+ ifneq ($(ENABLE_STATIC),)
+- $(INSTALL-L) $(TARGET) $(DESTDIR)$(libdir)
++ $(INSTALL_DATA) $(TARGET) $(DESTDIR)$(libdir)
+ endif
+ ifneq ($(ENABLE_SHARED),)
+ $(INSTALL-L) $(FINAL_SO_TARGET) $(DESTDIR)$(libdir)
diff --git a/devel/icu/files/patch-layout_Makefile.in b/devel/icu/files/patch-layout_Makefile.in
new file mode 100644
index 00000000000..d5c881287eb
--- /dev/null
+++ b/devel/icu/files/patch-layout_Makefile.in
@@ -0,0 +1,11 @@
+--- layout/Makefile.in.orig 2016-03-23 20:56:48 UTC
++++ layout/Makefile.in
+@@ -180,7 +180,7 @@ install-local: install-headers install-l
+ install-library: all-local
+ $(MKINSTALLDIRS) $(DESTDIR)$(libdir)
+ ifneq ($(ENABLE_STATIC),)
+- $(INSTALL-L) $(TARGET) $(DESTDIR)$(libdir)
++ $(INSTALL_DATA) $(TARGET) $(DESTDIR)$(libdir)
+ endif
+ ifneq ($(ENABLE_SHARED),)
+ $(INSTALL-L) $(FINAL_SO_TARGET) $(DESTDIR)$(libdir)
diff --git a/devel/icu/files/patch-layoutex_Makefile.in b/devel/icu/files/patch-layoutex_Makefile.in
new file mode 100644
index 00000000000..2b6dc2076b1
--- /dev/null
+++ b/devel/icu/files/patch-layoutex_Makefile.in
@@ -0,0 +1,11 @@
+--- layoutex/Makefile.in.orig 2016-03-23 20:56:38 UTC
++++ layoutex/Makefile.in
+@@ -109,7 +109,7 @@ endif
+ install-library: all-local
+ $(MKINSTALLDIRS) $(DESTDIR)$(libdir)
+ ifneq ($(ENABLE_STATIC),)
+- $(INSTALL-L) $(TARGET) $(DESTDIR)$(libdir)
++ $(INSTALL_DATA) $(TARGET) $(DESTDIR)$(libdir)
+ endif
+ ifneq ($(ENABLE_SHARED),)
+ $(INSTALL-L) $(FINAL_SO_TARGET) $(DESTDIR)$(libdir)
diff --git a/devel/icu/files/patch-stubdata_Makefile.in b/devel/icu/files/patch-stubdata_Makefile.in
new file mode 100644
index 00000000000..64496fc4eec
--- /dev/null
+++ b/devel/icu/files/patch-stubdata_Makefile.in
@@ -0,0 +1,11 @@
+--- stubdata/Makefile.in.orig 2016-03-23 20:50:52 UTC
++++ stubdata/Makefile.in
+@@ -82,7 +82,7 @@ install-local: install-library
+ install-library: all-local
+ $(MKINSTALLDIRS) $(DESTDIR)$(libdir)
+ ifneq ($(ENABLE_STATIC),)
+- $(INSTALL-L) $(TARGET) $(DESTDIR)$(libdir)
++ $(INSTALL_DATA) $(TARGET) $(DESTDIR)$(libdir)
+ endif
+ ifneq ($(ENABLE_SHARED),)
+ $(INSTALL-L) $(FINAL_SO_TARGET) $(DESTDIR)$(libdir)
diff --git a/devel/icu/files/patch-tools_ctestfw_Makefile.in b/devel/icu/files/patch-tools_ctestfw_Makefile.in
new file mode 100644
index 00000000000..23d88a42587
--- /dev/null
+++ b/devel/icu/files/patch-tools_ctestfw_Makefile.in
@@ -0,0 +1,11 @@
+--- tools/ctestfw/Makefile.in.orig 2016-03-23 20:50:16 UTC
++++ tools/ctestfw/Makefile.in
+@@ -78,7 +78,7 @@ install-local: install-library
+ install-library: all-local
+ $(MKINSTALLDIRS) $(DESTDIR)$(libdir)
+ ifneq ($(ENABLE_STATIC),)
+- $(INSTALL-L) $(TARGET) $(DESTDIR)$(libdir)
++ $(INSTALL_DATA) $(TARGET) $(DESTDIR)$(libdir)
+ endif
+ ifneq ($(ENABLE_SHARED),)
+ $(INSTALL-L) $(FINAL_SO_TARGET) $(DESTDIR)$(libdir)
diff --git a/devel/icu/files/patch-tools_toolutil_Makefile.in b/devel/icu/files/patch-tools_toolutil_Makefile.in
new file mode 100644
index 00000000000..cbf12cd8444
--- /dev/null
+++ b/devel/icu/files/patch-tools_toolutil_Makefile.in
@@ -0,0 +1,11 @@
+--- tools/toolutil/Makefile.in.orig 2016-03-23 20:50:26 UTC
++++ tools/toolutil/Makefile.in
+@@ -89,7 +89,7 @@ install-local: install-library
+ install-library: all-local
+ $(MKINSTALLDIRS) $(DESTDIR)$(libdir)
+ ifneq ($(ENABLE_STATIC),)
+- $(INSTALL-L) $(TARGET) $(DESTDIR)$(libdir)
++ $(INSTALL_DATA) $(TARGET) $(DESTDIR)$(libdir)
+ endif
+ ifneq ($(ENABLE_SHARED),)
+ $(INSTALL-L) $(FINAL_SO_TARGET) $(DESTDIR)$(libdir)