aboutsummaryrefslogtreecommitdiffstats
path: root/devel/nspr/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'devel/nspr/Makefile')
-rw-r--r--devel/nspr/Makefile12
1 files changed, 11 insertions, 1 deletions
diff --git a/devel/nspr/Makefile b/devel/nspr/Makefile
index 8be1e447276..0a306869cec 100644
--- a/devel/nspr/Makefile
+++ b/devel/nspr/Makefile
@@ -7,6 +7,7 @@
PORTNAME= nspr
PORTVERSION= 4.6.3
+PORTREVISION= 1
CATEGORIES= devel
MASTER_SITES= ${MASTER_SITE_MOZILLA}
MASTER_SITE_SUBDIR= nspr/releases/v${PORTVERSION}/src
@@ -28,6 +29,15 @@ MAKE_ENV= DIST=${WRKSRC}/dist
LIBS= libnspr4.so.1 libplc4.so.1 libplds4.so.1
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 601104
+post-patch:
+ @${REINPLACE_CMD} -e 's|pthread_cond_wait|_pthread_cond_wait|g' \
+ ${WRKSRC}/../pr/src/md/unix/pthreads_user.c \
+ ${WRKSRC}/../pr/src/pthreads/ptsynch.c
+.endif
+
do-install:
${MKDIR} ${PREFIX}/include/nspr
${TAR} -C ${WRKSRC}/dist/include --dereference -cf - . | \
@@ -68,4 +78,4 @@ post-build:
#
#.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>