aboutsummaryrefslogtreecommitdiffstats
path: root/devel/p5-FSA-Rules/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'devel/p5-FSA-Rules/Makefile')
-rw-r--r--devel/p5-FSA-Rules/Makefile32
1 files changed, 32 insertions, 0 deletions
diff --git a/devel/p5-FSA-Rules/Makefile b/devel/p5-FSA-Rules/Makefile
new file mode 100644
index 00000000000..7457736d64f
--- /dev/null
+++ b/devel/p5-FSA-Rules/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: FSA-Rules
+# Date created: 11 Feb 2006
+# Whom: Aaron Dalton <aaron@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= FSA-Rules
+PORTVERSION= 0.23
+CATEGORIES= devel perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= ../../authors/id/D/DW/DWHEELER
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= aaron@FreeBSD.org
+COMMENT= Build simple rules-based state machines in Perl
+
+BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Clone.pm:${PORTSDIR}/devel/p5-Clone \
+ ${SITE_PERL}/Text/Wrap.pm:${PORTSDIR}/textproc/p5-Text-Tabs+Wrap
+RUN_DEPENDS+= ${BUILD_DEPENDS}
+
+MAN3= FSA::Rules.3
+
+PERL_MODBUILD= yes
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500600
+IGNORE= requires at least Perl5.6 due to dependencies
+.endif
+
+.include <bsd.port.post.mk>