aboutsummaryrefslogtreecommitdiffstats
path: root/devel/p5-File-Pid/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'devel/p5-File-Pid/Makefile')
-rw-r--r--devel/p5-File-Pid/Makefile25
1 files changed, 25 insertions, 0 deletions
diff --git a/devel/p5-File-Pid/Makefile b/devel/p5-File-Pid/Makefile
new file mode 100644
index 00000000000..63f1180a059
--- /dev/null
+++ b/devel/p5-File-Pid/Makefile
@@ -0,0 +1,25 @@
+# New ports collection makefile for: p5-File-Pid
+# Date created: 2006-09-05
+# Whom: Gea-Suan Lin <gslin@gslin.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= File-Pid
+PORTVERSION= 1.01
+CATEGORIES= devel perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= File
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= gslin@gslin.org
+COMMENT= Pid File Manipulation
+
+RUN_DEPENDS= ${SITE_PERL}/Class/Accessor/Fast.pm:${PORTSDIR}/devel/p5-Class-Accessor
+BUILD_DEPENDS= ${RUN_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= File::Pid.3
+
+.include <bsd.port.mk>