aboutsummaryrefslogtreecommitdiffstats
path: root/devel/p5-MooX-StrictConstructor/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'devel/p5-MooX-StrictConstructor/Makefile')
-rw-r--r--devel/p5-MooX-StrictConstructor/Makefile28
1 files changed, 28 insertions, 0 deletions
diff --git a/devel/p5-MooX-StrictConstructor/Makefile b/devel/p5-MooX-StrictConstructor/Makefile
new file mode 100644
index 00000000000..3f3708f90bb
--- /dev/null
+++ b/devel/p5-MooX-StrictConstructor/Makefile
@@ -0,0 +1,28 @@
+# Created by: Sunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= MooX-StrictConstructor
+PORTVERSION= 0.006
+CATEGORIES= devel perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= Make your Moo-based object constructors blow up on unknown attributes
+
+LICENSE= ART10 GPLv1
+LICENSE_COMB= dual
+
+BUILD_DEPENDS= p5-Class-Method-Modifiers>=0:${PORTSDIR}/devel/p5-Class-Method-Modifiers \
+ p5-Moo>=1.001000:${PORTSDIR}/devel/p5-Moo \
+ p5-strictures>=1:${PORTSDIR}/devel/p5-strictures
+RUN_DEPENDS:= ${BUILD_DEPENDS}
+TEST_DEPENDS= p5-Test-Fatal>=0:${PORTSDIR}/devel/p5-Test-Fatal \
+ p5-bareword-filehandles>=0:${PORTSDIR}/devel/p5-bareword-filehandles \
+ p5-indirect>=0:${PORTSDIR}/devel/p5-indirect \
+ p5-multidimensional>=0:${PORTSDIR}/devel/p5-multidimensional
+
+USE_PERL5= modbuild
+USES= perl5
+
+.include <bsd.port.mk>