aboutsummaryrefslogtreecommitdiffstats
path: root/devel/p5-PCSC-Card/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'devel/p5-PCSC-Card/Makefile')
-rw-r--r--devel/p5-PCSC-Card/Makefile27
1 files changed, 27 insertions, 0 deletions
diff --git a/devel/p5-PCSC-Card/Makefile b/devel/p5-PCSC-Card/Makefile
new file mode 100644
index 00000000000..8039dad97d5
--- /dev/null
+++ b/devel/p5-PCSC-Card/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: p5-PCSC-Card
+# Date created: 12 September 2002
+# Whom: Bruce M Simpson
+#
+# $FreeBSD$
+#
+
+PORTNAME= PCSC-Card
+PORTVERSION= 1.2.2
+CATEGORIES= devel perl5
+MASTER_SITES= http://ludovic.rousseau.free.fr/softwares/pcsc-perl/
+PKGNAMEPREFIX= p5-
+DISTNAME= pcsc-perl-${PORTVERSION}
+
+MAINTAINER= bms@FreeBSD.org
+COMMENT= Perl bindings for the PC/SC Lite Framework
+
+LIB_DEPENDS= pcsclite.0:${PORTSDIR}/devel/pcsc-lite
+
+PERL_CONFIGURE= yes
+CONFIGURE_ARGS= INSTALLDIRS=site
+MAKE_ENV= "LOCALBASE=$(LOCALBASE)"
+
+MAN3= Chipcard::PCSC::Card.3 Chipcard::PCSC.3
+MAN3PREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+
+.include <bsd.port.mk>