aboutsummaryrefslogtreecommitdiffstats
path: root/devel/py-logging/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'devel/py-logging/Makefile')
-rw-r--r--devel/py-logging/Makefile31
1 files changed, 31 insertions, 0 deletions
diff --git a/devel/py-logging/Makefile b/devel/py-logging/Makefile
new file mode 100644
index 00000000000..723fd03c257
--- /dev/null
+++ b/devel/py-logging/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: py-logging
+# Date created: 6 April 2002
+# Whom: Hye-Shik Chang
+#
+# $FreeBSD$
+#
+
+PORTNAME= logging
+PORTVERSION= 0.4.6
+CATEGORIES= devel python
+MASTER_SITES= http://www.red-dove.com/
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= perky@FreeBSD.org
+
+USE_PYTHON= yes
+USE_PYDISTUTILS= yes
+USE_PYTHON_PREFIX= yes
+
+EXAMPLESDIR= ${PREFIX}/share/examples/py-logging
+EXAMPLEFILES= README.txt app.py default.css events.xml log_*.py \
+ logconf.ini logconf.py logging.dtd logging.xml logrecv.py \
+ myapp.py mymodule.py
+
+post-install:
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${EXAMPLESDIR}
+ @cd ${WRKSRC} && ${INSTALL_DATA} ${EXAMPLEFILES} ${EXAMPLESDIR}
+.endif
+
+.include <bsd.port.mk>