aboutsummaryrefslogtreecommitdiffstats
path: root/devel/qtcreator/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'devel/qtcreator/Makefile')
-rw-r--r--devel/qtcreator/Makefile22
1 files changed, 18 insertions, 4 deletions
diff --git a/devel/qtcreator/Makefile b/devel/qtcreator/Makefile
index 66ca3f4e8d1..f4ba06772cc 100644
--- a/devel/qtcreator/Makefile
+++ b/devel/qtcreator/Makefile
@@ -2,21 +2,35 @@
# $FreeBSD$
PORTNAME= qtcreator
-DISTVERSION= 3.6.0
+DISTVERSION= 3.6.1
CATEGORIES= devel
MASTER_SITES= QT/official_releases/qtcreator/${DISTVERSION:R}/${DISTVERSION}
DISTNAME= qt-creator-opensource-src-${DISTVERSION}
-DIST_SUBDIR= KDE
+DIST_SUBDIR= KDE/Qt/qtcreator
MAINTAINER= kde@FreeBSD.org
COMMENT= C++ and QML IDE for Qt development
+LICENSE= GPLv3 LGPL21 LGPL3
+LICENSE_COMB= dual
+
+# depend on the split out qbs
+BUILD_DEPENDS= qbs:devel/qbs
+RUN_DEPENDS= qbs:devel/qbs
+
USE_LDCONFIG= ${LOCALBASE}/lib/${PORTNAME}
-USES= qmake:outsource compiler:c++11-lib
+USES= qmake compiler:c++11-lib
+INSTALLS_ICONS= yes
USE_QT5= buildtools concurrent core declarative designer gui linguist network\
qml quick quickcontrols script script sql svg webkit widgets xml\
xmlpatterns
+# be paranoid and do not extract qbs (devel/qbs) copy from source tree
+EXTRACT_AFTER_ARGS+= --exclude '${DISTNAME}/src/shared/qbs'
+# Set QBS_INSTALL_DIR for QBS plugin build and set config parameter to build
+# the qbsprojectmanager plugin without compile error
+QMAKE_ARGS+= QBS_INSTALL_DIR=${PREFIX} CONFIG+=qbs_enable_project_file_updates
+
# Enforce installation to ${PREFIX}.
QMAKE_ARGS+= QTC_PREFIX=${PREFIX}
@@ -33,7 +47,7 @@ post-patch:
${WRKSRC}/share/qtcreator/debugger/dumper.py
${REINPLACE_CMD} -e 's|/usr/bin/ant|${LOCALBASE}/bin/ant|' \
${WRKSRC}/src/plugins/android/androidsettingswidget.cpp
- ${REINPLACE_CMD} -e '/unix:LIBS += -ldl/d' \
+ ${REINPLACE_CMD} -e '/unix:!openbsd: LIBS += -ldl/d' \
${WRKSRC}/src/libs/sqlite/sqlite-lib.pri
.include <bsd.port.mk>