aboutsummaryrefslogtreecommitdiffstats
path: root/devel/tcl-trf/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'devel/tcl-trf/Makefile')
-rw-r--r--devel/tcl-trf/Makefile8
1 files changed, 7 insertions, 1 deletions
diff --git a/devel/tcl-trf/Makefile b/devel/tcl-trf/Makefile
index f8b06a5aaad..bdb2a931d84 100644
--- a/devel/tcl-trf/Makefile
+++ b/devel/tcl-trf/Makefile
@@ -62,10 +62,16 @@ post-install:
${INSTALL_DATA} ${WRKSRC}/doc/painless-guide-to-crc.txt ${DOCSDIR}
.endif
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 500113
+BROKEN= "Does not install on FreeBSD ${OSVERSION}"
+.endif
SHLIB_NAME= libTrf2.so.1
SHLIB_LINK= ${SHLIB_NAME:C/\.so\..*/.so/}
PLIST_SUB+= SHLIB_NAME=${SHLIB_NAME} SHLIB_LINK=${SHLIB_LINK} \
TCL_DVER=${TCL_VER:C/\.//}
+
+.include <bsd.port.post.mk>