aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/pecl-bbcode/Makefile29
-rw-r--r--devel/pecl-bbcode/distinfo3
-rw-r--r--devel/pecl-bbcode/pkg-descr5
4 files changed, 38 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index b0703818dd0..f54279fca24 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -1750,6 +1750,7 @@
SUBDIR += pear-XML_Util
SUBDIR += pear-XML_XPath
SUBDIR += pear-apd
+ SUBDIR += pecl-bbcode
SUBDIR += pecl-bcompiler
SUBDIR += pecl-expect
SUBDIR += pecl-hidef
diff --git a/devel/pecl-bbcode/Makefile b/devel/pecl-bbcode/Makefile
new file mode 100644
index 00000000000..cc9f93a91a4
--- /dev/null
+++ b/devel/pecl-bbcode/Makefile
@@ -0,0 +1,29 @@
+# New ports collection makefile for: pecl-bbcode
+# Date created: 6 Aug 2007
+# Whom: Ditesh Shashikant Gathani <ditesh@gathani.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= bbcode
+PORTVERSION= 0.9.1
+CATEGORIES= devel pear
+MASTER_SITES= http://pecl.php.net/get/
+PKGNAMEPREFIX= pecl-
+EXTRACT_SUFX= .tgz
+DIST_SUBDIR= PECL
+
+MAINTAINER= ditesh@gathani.org
+COMMENT= A PECL extension which allows quick and efficient BBCode Parsing
+
+USE_PHP= yes
+USE_PHP_BUILD= yes
+USE_PHPEXT= yes
+
+CONFIGURE_ARGS= --enable-bbcode
+
+post-patch:
+ @${REINPLACE_CMD} -e 's/#include <malloc.h>/\/\/#include <malloc.h>/g' ${WRKSRC}/lib/stacklib.c
+ @${REINPLACE_CMD} -e 's/#include <malloc.h>/\/\/#include <malloc.h>/g' ${WRKSRC}/lib/bbcode.c
+
+.include <bsd.port.mk>
diff --git a/devel/pecl-bbcode/distinfo b/devel/pecl-bbcode/distinfo
new file mode 100644
index 00000000000..5126da75705
--- /dev/null
+++ b/devel/pecl-bbcode/distinfo
@@ -0,0 +1,3 @@
+MD5 (PECL/bbcode-0.9.1.tgz) = d9cf9501c8682724d806a5234ee2112e
+SHA256 (PECL/bbcode-0.9.1.tgz) = e04459901962899999dc72953a73c1829ae77454a3c3d4c94727373d3e2bd4d0
+SIZE (PECL/bbcode-0.9.1.tgz) = 32586
diff --git a/devel/pecl-bbcode/pkg-descr b/devel/pecl-bbcode/pkg-descr
new file mode 100644
index 00000000000..b58414152b2
--- /dev/null
+++ b/devel/pecl-bbcode/pkg-descr
@@ -0,0 +1,5 @@
+The bbcode extension is a quick and efficient BBCode Parsing Library.
+It provides various tag types, high speed one pass parsing, callback
+system and tag position restriction.
+
+WWW: http://pecl.php.net/package/bbcode/