aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
Diffstat (limited to 'devel')
-rw-r--r--devel/dmake/Makefile29
-rw-r--r--devel/dmake/distinfo6
-rw-r--r--devel/dmake/files/patch-aa103
-rw-r--r--devel/dmake/files/patch-ab12
-rw-r--r--devel/dmake/files/patch-ac10
-rw-r--r--devel/dmake/files/patch-ad8
-rw-r--r--devel/dmake/files/patch-warnings143
-rw-r--r--devel/dmake/pkg-descr13
-rw-r--r--devel/dmake/pkg-plist161
9 files changed, 167 insertions, 318 deletions
diff --git a/devel/dmake/Makefile b/devel/dmake/Makefile
index 0df1a1f00b2..34327fe9ca7 100644
--- a/devel/dmake/Makefile
+++ b/devel/dmake/Makefile
@@ -6,35 +6,20 @@
#
PORTNAME= dmake
-PORTVERSION= 4.1
-PORTREVISION= 1
+PORTVERSION= 4.3
CATEGORIES= devel
-MASTER_SITES= ftp://ftp.internat.freebsd.org/pub/FreeBSD/distfiles/
-DISTNAME= ${PORTNAME}-v${PORTVERSION}-src-export.all-unknown-all
+MASTER_SITES= http://people.debian.org/~rene/pkgs/dmake/
+DISTFILES= ${PORTNAME}_${PORTVERSION}.orig.tar.gz
MAINTAINER= ports@FreeBSD.org
COMMENT= Another hyper make utility
-WRKSRC= ${WRKDIR}/${PORTNAME}
-USE_REINPLACE= yes
-USE_GMAKE= yes
-MAKE_ENV= CC=${CC}
-MAKEFILE= makefile
-ALL_TARGET= bsd43
+GNU_CONFIGURE= yes
+#CONFIGURE_ENV+= CFLAGS="${CFLAGS} -Wall -Werror"
+CONFIGURE_ARGS+=--datadir=${PREFIX}/share/${PORTNAME}
MAN1= dmake.1
-post-extract:
-.for f in limits.h string.h dirent.h
- @${RM} -f ${WRKSRC}/unix/bsd43/${f}
-.endfor
-
-post-patch:
- @${REINPLACE_CMD} -e 's|%%PREFIX%%|${PREFIX}|g' ${WRKSRC}/unix/startup.h
-
-do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/dmake ${PREFIX}/bin
+post-install:
${INSTALL_MAN} ${WRKSRC}/man/dmake.tf ${PREFIX}/man/man1/dmake.1
- @${MKDIR} ${PREFIX}/share/dmake/startup
- ${CP} -R ${WRKSRC}/startup/* ${PREFIX}/share/dmake/startup
.include <bsd.port.mk>
diff --git a/devel/dmake/distinfo b/devel/dmake/distinfo
index 32394105cab..b303400cb8c 100644
--- a/devel/dmake/distinfo
+++ b/devel/dmake/distinfo
@@ -1,2 +1,4 @@
-MD5 (dmake-v4.1-src-export.all-unknown-all.tar.gz) = 5841be5f11b8294e95edc1f28cc11c5b
-SIZE (dmake-v4.1-src-export.all-unknown-all.tar.gz) = 473427
+MD5 (dmake_4.3.orig.tar.gz) = 58edb202a08835ce28820c3fed9590db
+SIZE (dmake_4.3.orig.tar.gz) = 615190
+MD5 (dmake_4.3-0.1pre.diff.gz) = fb9b476a2cdfd80db1c1bfc4fd5e277f
+SIZE (dmake_4.3-0.1pre.diff.gz) = 54473
diff --git a/devel/dmake/files/patch-aa b/devel/dmake/files/patch-aa
deleted file mode 100644
index 0fcf7fc588f..00000000000
--- a/devel/dmake/files/patch-aa
+++ /dev/null
@@ -1,103 +0,0 @@
---- unix/bsd43/make.sh.orig Wed Jul 16 01:02:35 1997
-+++ unix/bsd43/make.sh Fri Dec 17 05:27:21 1999
-@@ -1,69 +1,64 @@
-+if [ ! -x dmake ]
-+then
- mkdir objects
--cc -c -I. -Iunix -Iunix/bsd43 -O infer.c
-+${CC} ${CFLAGS} -c -I. -Iunix -Iunix/bsd43 infer.c
- mv infer.o objects
--cc -c -I. -Iunix -Iunix/bsd43 -O make.c
-+${CC} ${CFLAGS} -c -I. -Iunix -Iunix/bsd43 make.c
- mv make.o objects
--cc -c -I. -Iunix -Iunix/bsd43 -O stat.c
-+${CC} ${CFLAGS} -c -I. -Iunix -Iunix/bsd43 stat.c
- mv stat.o objects
--cc -c -I. -Iunix -Iunix/bsd43 -O expand.c
-+${CC} ${CFLAGS} -c -I. -Iunix -Iunix/bsd43 expand.c
- mv expand.o objects
--cc -c -I. -Iunix -Iunix/bsd43 -O dmstring.c
-+${CC} ${CFLAGS} -c -I. -Iunix -Iunix/bsd43 dmstring.c
- mv dmstring.o objects
--cc -c -I. -Iunix -Iunix/bsd43 -O hash.c
-+${CC} ${CFLAGS} -c -I. -Iunix -Iunix/bsd43 hash.c
- mv hash.o objects
--cc -c -I. -Iunix -Iunix/bsd43 -O dag.c
-+${CC} ${CFLAGS} -c -I. -Iunix -Iunix/bsd43 dag.c
- mv dag.o objects
--cc -c -I. -Iunix -Iunix/bsd43 -O dmake.c
-+${CC} ${CFLAGS} -c -I. -Iunix -Iunix/bsd43 dmake.c
- mv dmake.o objects
--cc -c -I. -Iunix -Iunix/bsd43 -O path.c
-+${CC} ${CFLAGS} -c -I. -Iunix -Iunix/bsd43 path.c
- mv path.o objects
--cc -c -I. -Iunix -Iunix/bsd43 -O imacs.c
-+${CC} ${CFLAGS} -c -I. -Iunix -Iunix/bsd43 imacs.c
- mv imacs.o objects
--cc -c -I. -Iunix -Iunix/bsd43 -O sysintf.c
-+${CC} ${CFLAGS} -c -I. -Iunix -Iunix/bsd43 sysintf.c
- mv sysintf.o objects
--cc -c -I. -Iunix -Iunix/bsd43 -O parse.c
-+${CC} ${CFLAGS} -c -I. -Iunix -Iunix/bsd43 parse.c
- mv parse.o objects
--cc -c -I. -Iunix -Iunix/bsd43 -O getinp.c
-+${CC} ${CFLAGS} -c -I. -Iunix -Iunix/bsd43 getinp.c
- mv getinp.o objects
--cc -c -I. -Iunix -Iunix/bsd43 -O quit.c
-+${CC} ${CFLAGS} -c -I. -Iunix -Iunix/bsd43 quit.c
- mv quit.o objects
--cc -c -I. -Iunix -Iunix/bsd43 -O state.c
-+${CC} ${CFLAGS} -c -I. -Iunix -Iunix/bsd43 state.c
- mv state.o objects
--cc -c -I. -Iunix -Iunix/bsd43 -O dmdump.c
-+${CC} ${CFLAGS} -c -I. -Iunix -Iunix/bsd43 dmdump.c
- mv dmdump.o objects
--cc -c -I. -Iunix -Iunix/bsd43 -O macparse.c
-+${CC} ${CFLAGS} -c -I. -Iunix -Iunix/bsd43 macparse.c
- mv macparse.o objects
--cc -c -I. -Iunix -Iunix/bsd43 -O rulparse.c
-+${CC} ${CFLAGS} -c -I. -Iunix -Iunix/bsd43 rulparse.c
- mv rulparse.o objects
--cc -c -I. -Iunix -Iunix/bsd43 -O percent.c
-+${CC} ${CFLAGS} -c -I. -Iunix -Iunix/bsd43 percent.c
- mv percent.o objects
--cc -c -I. -Iunix -Iunix/bsd43 -O function.c
-+${CC} ${CFLAGS} -c -I. -Iunix -Iunix/bsd43 function.c
- mv function.o objects
--cc -c -I. -Iunix -Iunix/bsd43 -O unix/arlib.c
-+${CC} ${CFLAGS} -c -I. -Iunix -Iunix/bsd43 unix/arlib.c
- mv arlib.o objects
--cc -c -I. -Iunix -Iunix/bsd43 -O unix/dirbrk.c
-+${CC} ${CFLAGS} -c -I. -Iunix -Iunix/bsd43 unix/dirbrk.c
- mv dirbrk.o objects
--cc -c -I. -Iunix -Iunix/bsd43 -O unix/rmprq.c
-+${CC} ${CFLAGS} -c -I. -Iunix -Iunix/bsd43 unix/rmprq.c
- mv rmprq.o objects
--cc -c -I. -Iunix -Iunix/bsd43 -O unix/ruletab.c
-+${CC} ${CFLAGS} -c -I. -Iunix -Iunix/bsd43 unix/ruletab.c
- mv ruletab.o objects
--cc -c -I. -Iunix -Iunix/bsd43 -O unix/runargv.c
-+${CC} ${CFLAGS} -c -I. -Iunix -Iunix/bsd43 unix/runargv.c
- mv runargv.o objects
--cc -c -I. -Iunix -Iunix/bsd43 -O unix/dcache.c
-+${CC} ${CFLAGS} -c -I. -Iunix -Iunix/bsd43 unix/dcache.c
- mv dcache.o objects
--cc -c -I. -Iunix -Iunix/bsd43 -O unix/bsd43/putenv.c
--mv putenv.o objects
--cc -c -I. -Iunix -Iunix/bsd43 -O unix/bsd43/tempnam.c
--mv tempnam.o objects
--cc -c -I. -Iunix -Iunix/bsd43 -O unix/bsd43/utime.c
--mv utime.o objects
--cc -c -I. -Iunix -Iunix/bsd43 -O unix/bsd43/setvbuf.c
--mv setvbuf.o objects
--cc -O -o dmake objects/infer.o objects/make.o objects/stat.o objects/expand.o \
-+${CC} ${CFLAGS} -o dmake objects/infer.o objects/make.o objects/stat.o objects/expand.o \
- objects/dmstring.o objects/hash.o objects/dag.o objects/dmake.o objects/path.o \
- objects/imacs.o objects/sysintf.o objects/parse.o objects/getinp.o \
- objects/quit.o objects/state.o objects/dmdump.o objects/macparse.o \
- objects/rulparse.o objects/percent.o objects/function.o objects/arlib.o \
- objects/dirbrk.o objects/rmprq.o objects/ruletab.o objects/runargv.o \
--objects/dcache.o objects/putenv.o objects/tempnam.o objects/utime.o objects/setvbuf.o
-+objects/dcache.o
- cp unix/bsd43/template.mk startup/config.mk
-+fi
diff --git a/devel/dmake/files/patch-ab b/devel/dmake/files/patch-ab
deleted file mode 100644
index 5c67bcfbe6b..00000000000
--- a/devel/dmake/files/patch-ab
+++ /dev/null
@@ -1,12 +0,0 @@
---- unix/runargv.c.orig Wed Jul 16 01:02:34 1997
-+++ unix/runargv.c Mon Sep 8 03:01:42 1997
-@@ -68,7 +68,9 @@
- char *cmd;
- {
- extern int errno;
-+#ifndef __FreeBSD__
- extern char *sys_errlist[];
-+#endif
- int pid;
- char **argv;
-
diff --git a/devel/dmake/files/patch-ac b/devel/dmake/files/patch-ac
deleted file mode 100644
index ed21d6ae45e..00000000000
--- a/devel/dmake/files/patch-ac
+++ /dev/null
@@ -1,10 +0,0 @@
---- unix/dcache.c.orig Wed Jul 16 01:02:34 1997
-+++ unix/dcache.c Mon Sep 8 03:20:56 1997
-@@ -35,6 +35,7 @@
- #undef __WIN32__
- #endif
-
-+#include <sys/types.h>
- #include <dirent.h>
- #include "extern.h"
- #include "sysintf.h"
diff --git a/devel/dmake/files/patch-ad b/devel/dmake/files/patch-ad
deleted file mode 100644
index f85ed111bdd..00000000000
--- a/devel/dmake/files/patch-ad
+++ /dev/null
@@ -1,8 +0,0 @@
---- unix/startup.h.orig Wed Jul 16 01:02:34 1997
-+++ unix/startup.h Fri Dec 17 05:36:20 1999
-@@ -24,4 +24,4 @@
- -- Use cvs log to obtain detailed change logs.
- */
-
--"MAKESTARTUP := $(ROOTDIR)/usr/local/lib/dmake/startup/startup.mk",
-+"MAKESTARTUP := $(ROOTDIR)%%PREFIX%%/share/dmake/startup/startup.mk",
diff --git a/devel/dmake/files/patch-warnings b/devel/dmake/files/patch-warnings
new file mode 100644
index 00000000000..8202e8fb6d9
--- /dev/null
+++ b/devel/dmake/files/patch-warnings
@@ -0,0 +1,143 @@
+Fix warnings to allow ``-Wall -Werror'' with gcc-3.4.2 on FreeBSD/i386.
+Most of these seemed fairly benign -- assumptions about time_t are the
+most common.
+
+ -mi
+
+--- state.c Fri Sep 22 11:33:25 2000
++++ state.c Sun Jan 2 18:13:26 2005
+@@ -123,6 +123,6 @@
+ fprintf( fp, "%s\n", sp->st_name );
+ fprintf( fp, "%d\n", sp->st_count );
+- fprintf( fp, "%lu\n", sp->st_dkey );
+- fprintf( fp, "%lu\n", sp->st_key );
++ fprintf( fp, "%lu\n", (unsigned long)sp->st_dkey );
++ fprintf( fp, "%lu\n", (unsigned long)sp->st_key );
+ }
+ }
+--- getinp.c Wed Apr 21 10:10:17 2004
++++ getinp.c Sun Jan 2 18:16:37 2005 -- remove unused variables
+@@ -481,6 +481,6 @@
+ static char ifcntl[MAX_COND_DEPTH];
+ char *lhs, *expr, *expr_end;
+- char *lop, *partstr;
+- int result, n, m;
++ const char *lop;
++ int result;
+
+ DB_ENTER( "_handle_conditional" );
+@@ -562,5 +562,7 @@
+
+ /* uncomment to turn on expression debug statements */
+-/*#define PARSE_DEBUG /* */
++#if 0
++# define PARSE_DEBUG /* */
++#endif
+ #define PARSE_SKIP_WHITE(A) while( *A && ((*A==' ') || (*A=='\t')) ) A++;
+
+--- unix/arlib.c Wed Sep 8 12:08:45 2004
++++ unix/arlib.c Sun Jan 2 18:20:44 2005
+@@ -399,5 +399,5 @@
+ fseek( f, (long) _ar.ar_size, 0 );
+ #else
+- fseek( f, arhdroffset + sizeof(arhdr) + (_ar.ar_size+1 & ~1L), 0 );
++ fseek( f, arhdroffset + sizeof(arhdr) + ((_ar.ar_size+1) & ~1L), 0 );
+ #endif
+ }
+@@ -422,5 +422,5 @@
+
+ #if ASCARCH
+- fprintf(f, "%lu", now);
++ fprintf(f, "%llu", (unsigned long long)now);
+ #else
+ fwrite((char *)now, sizeof(now), 1, f);
+--- unix/runargv.c Wed Sep 8 12:09:39 2004
++++ unix/runargv.c Sun Jan 2 18:25:02 2005
+@@ -26,4 +26,7 @@
+ */
+
++#ifdef HAVE_CONFIG_H
++# include "config.h"
++#endif
+ #include <signal.h>
+ #ifdef HAVE_WAIT_H
+--- make.c Wed Sep 8 12:06:46 2004
++++ make.c Sun Jan 2 18:26:55 2005
+@@ -336,6 +336,6 @@
+
+ if( Verbose & V_MAKE )
+- printf("%s: Time stamp of [%s] is %ld\n",Pname,tcp->CE_NAME,
+- tcp->ce_time);
++ printf("%s: Time stamp of [%s] is %llu\n",Pname,tcp->CE_NAME,
++ (unsigned long long)tcp->ce_time);
+ }
+ }
+@@ -590,6 +590,6 @@
+
+ if( Verbose & V_MAKE )
+- printf( "%s: Updating [%s], (%ld > %ld)\n", Pname,
+- cp->CE_NAME, otime, cp->ce_time );
++ printf( "%s: Updating [%s], (%llu > %llu)\n", Pname,
++ cp->CE_NAME, (unsigned long long)otime, (unsigned long long)cp->ce_time );
+
+ if( Touch ) {
+--- stat.c Fri Sep 22 11:33:25 2000
++++ stat.c Sun Jan 2 18:27:46 2005
+@@ -140,6 +140,6 @@
+
+ if( Verbose & V_MAKE )
+- printf( "%s: Checking library '%s' for member [%s], time %ld\n",
+- Pname, cp->ce_lib, name, cp->ce_time );
++ printf( "%s: Checking library '%s' for member [%s], time %llu\n",
++ Pname, cp->ce_lib, name, (unsigned long long)cp->ce_time );
+ }
+
+--- sysintf.c Thu Oct 7 18:18:47 2004 -- change the loop to make it more
++++ sysintf.c Sun Jan 2 18:30:33 2005 -- obvious, that fd *will* be set
+@@ -500,11 +500,10 @@
+ tmpdir = "/tmp";
+
+- while( --tries )
+- {
++ do {
+ if( (fd = Create_temp(tmpdir, path, suff)) != -1)
+ break;
+
+ free(*path);
+- }
++ } while( --tries );
+
+ if( fd != -1)
+@@ -739,6 +738,6 @@
+
+ if( Verbose & V_MAKE )
+- printf( "%s: <<<< Set [%s] time stamp to %lu\n",
+- Pname, tcp->CE_NAME, tcp->ce_time );
++ printf( "%s: <<<< Set [%s] time stamp to %llu\n",
++ Pname, tcp->CE_NAME, (unsigned long long)tcp->ce_time );
+
+ Unlink_temp_files( tcp );
+--- function.c Wed Sep 8 12:06:20 2004
++++ function.c Sun Jan 2 18:33:09 2005 -- unused variable
+@@ -287,5 +287,5 @@
+
+ if( file && *file ) {
+- char *newtmp;
++ /* char *newtmp; */
+
+ /* This call to Get_temp sets TMPFILE for subsequent expansion of file.
+--- configure Fri Oct 22 05:36:37 2004 -- fix warnings, so configure does
++++ configure Sun Jan 2 19:07:52 2005 -- not conclude, our utime is bad.
+@@ -6207,4 +6207,5 @@
+ /* end confdefs.h. */
+ $ac_includes_default
++#include <utime.h>
+ int
+ main ()
+@@ -6212,5 +6213,5 @@
+ struct stat s, t;
+ exit (!(stat ("conftest.data", &s) == 0
+- && utime ("conftest.data", (long *)0) == 0
++ && utime ("conftest.data", (void *)0) == 0
+ && stat ("conftest.data", &t) == 0
+ && t.st_mtime >= s.st_mtime
diff --git a/devel/dmake/pkg-descr b/devel/dmake/pkg-descr
index 0f3319a3635..c95b4fcd5cd 100644
--- a/devel/dmake/pkg-descr
+++ b/devel/dmake/pkg-descr
@@ -1,4 +1,11 @@
-dmake is different from other versions of Make in that it supports significant
-enhancements. See the WWW page for the detail.
+dmake is different from other versions of Make in that it supports
+significant enhancements.
-WWW: http://dmake.wticorp.com/
+The original author(s) were WTICorp.com, but they appear to have lost
+interest in maintaining the code.
+
+This port installs the version currently maintained by OpenOffice
+project. Unfortunately, OOo does not offer dmake as an independent
+download, but, fortunately, the folks at Debian do.
+
+WWW: http://people.debian.org/~rene/pkgs/dmake/
diff --git a/devel/dmake/pkg-plist b/devel/dmake/pkg-plist
index ff2d79f3d00..ee98edc713c 100644
--- a/devel/dmake/pkg-plist
+++ b/devel/dmake/pkg-plist
@@ -1,165 +1,10 @@
bin/dmake
-share/dmake/startup/templates/tos/template.mk
-share/dmake/startup/templates/msdos/borland/bcc30/template.mk
-share/dmake/startup/templates/msdos/borland/bcc40/template.mk
-share/dmake/startup/templates/msdos/borland/bcc45/template.mk
-share/dmake/startup/templates/msdos/borland/bcc50/template.mk
-share/dmake/startup/templates/msdos/borland/tcc20/template.mk
-share/dmake/startup/templates/msdos/microsft/msc51/template.mk
-share/dmake/startup/templates/msdos/microsft/msc60/template.mk
-share/dmake/startup/templates/os2/ibm/icc/template.mk
-share/dmake/startup/templates/qssl/template.mk
-share/dmake/startup/templates/mac/template.mk
-share/dmake/startup/templates/unix/solaris/gnu/template.mk
-share/dmake/startup/templates/unix/solaris/template.mk
-share/dmake/startup/templates/unix/bsd43/uw/template.mk
-share/dmake/startup/templates/unix/bsd43/vf/template.mk
-share/dmake/startup/templates/unix/bsd43/template.mk
-share/dmake/startup/templates/unix/coherent/ver40/template.mk
-share/dmake/startup/templates/unix/coherent/ver42/template.mk
-share/dmake/startup/templates/unix/linux/gnu/template.mk
-share/dmake/startup/templates/unix/386ix/template.mk
-share/dmake/startup/templates/unix/sysvr1/template.mk
-share/dmake/startup/templates/unix/sysvr3/pwd/template.mk
-share/dmake/startup/templates/unix/sysvr3/template.mk
-share/dmake/startup/templates/unix/sysvr4/template.mk
-share/dmake/startup/templates/unix/xenix/pwd/template.mk
-share/dmake/startup/templates/unix/xenix/template.mk
-share/dmake/startup/templates/win95/borland/bcc50/template.mk
-share/dmake/startup/templates/win95/microsft/vpp40/template.mk
-share/dmake/startup/templates/winnt/borland/bcc50/template.mk
-share/dmake/startup/templates/winnt/microsft/vpp40/template.mk
-share/dmake/startup/win95/borland/macros.mk
-share/dmake/startup/win95/microsft/macros.mk
-share/dmake/startup/win95/macros.mk
-share/dmake/startup/win95/recipes.mk
-share/dmake/startup/unix/386ix/macros.mk
-share/dmake/startup/unix/bsd43/macros.mk
-share/dmake/startup/unix/bsd43/recipes.mk
-share/dmake/startup/unix/coherent/macros.mk
-share/dmake/startup/unix/coherent/recipes.mk
-share/dmake/startup/unix/linux/gnu/macros.mk
-share/dmake/startup/unix/linux/macros.mk
-share/dmake/startup/unix/sysvr3/gnu/macros.mk
-share/dmake/startup/unix/sysvr3/macros.mk
-share/dmake/startup/unix/sysvr4/macros.mk
-share/dmake/startup/unix/solaris/macros.mk
-share/dmake/startup/unix/sysvr1/macros.mk
-share/dmake/startup/unix/xenix/macros.mk
-share/dmake/startup/unix/recipes.mk
-share/dmake/startup/unix/macros.mk
-share/dmake/startup/tos/macros.mk
-share/dmake/startup/os2/ibm/macros.mk
-share/dmake/startup/os2/macros.mk
-share/dmake/startup/winnt/borland/macros.mk
-share/dmake/startup/winnt/microsft/macros.mk
-share/dmake/startup/winnt/macros.mk
-share/dmake/startup/winnt/recipes.mk
-share/dmake/startup/mac/macros.mk
-share/dmake/startup/msdos/borland/tcc20/macros.mk
-share/dmake/startup/msdos/borland/bcc40/macros.mk
-share/dmake/startup/msdos/borland/bcc45/macros.mk
-share/dmake/startup/msdos/borland/bcc30/macros.mk
-share/dmake/startup/msdos/borland/bcc50/macros.mk
-share/dmake/startup/msdos/borland/bcc50.32/macros.mk
-share/dmake/startup/msdos/borland/macros.mk
-share/dmake/startup/msdos/microsft/macros.mk
-share/dmake/startup/msdos/zortech/macros.mk
-share/dmake/startup/msdos/macros.mk
-share/dmake/startup/msdos/recipes.mk
-share/dmake/startup/qssl/qnx/macros.mk
-share/dmake/startup/qssl/qnx/recipes.mk
-share/dmake/startup/qssl/macros.mk
-share/dmake/startup/qssl/recipes.mk
-share/dmake/startup/Windows_NT/borland/macros.mk
-share/dmake/startup/Windows_NT/microsft/macros.mk
-share/dmake/startup/Windows_NT/macros.mk
-share/dmake/startup/Windows_NT/recipes.mk
share/dmake/startup/startup.mk
-share/dmake/startup/summary
-share/dmake/startup/config.mk
share/dmake/startup/template.mk
-@dirrm share/dmake/startup/winnt/microsft
-@dirrm share/dmake/startup/winnt/borland
-@dirrm share/dmake/startup/winnt
-@dirrm share/dmake/startup/win95/microsft
-@dirrm share/dmake/startup/win95/borland
-@dirrm share/dmake/startup/win95
-@dirrm share/dmake/startup/unix/xenix
-@dirrm share/dmake/startup/unix/sysvr4
-@dirrm share/dmake/startup/unix/sysvr3/gnu
-@dirrm share/dmake/startup/unix/sysvr3
-@dirrm share/dmake/startup/unix/sysvr1
-@dirrm share/dmake/startup/unix/solaris
-@dirrm share/dmake/startup/unix/linux/gnu
+share/dmake/startup/unix/linux/macros.mk
+share/dmake/startup/unix/macros.mk
+share/dmake/startup/unix/recipes.mk
@dirrm share/dmake/startup/unix/linux
-@dirrm share/dmake/startup/unix/coherent
-@dirrm share/dmake/startup/unix/bsd43
-@dirrm share/dmake/startup/unix/386ix
@dirrm share/dmake/startup/unix
-@dirrm share/dmake/startup/tos
-@dirrm share/dmake/startup/templates/winnt/microsft/vpp40
-@dirrm share/dmake/startup/templates/winnt/microsft
-@dirrm share/dmake/startup/templates/winnt/borland/bcc50
-@dirrm share/dmake/startup/templates/winnt/borland
-@dirrm share/dmake/startup/templates/winnt
-@dirrm share/dmake/startup/templates/win95/microsft/vpp40
-@dirrm share/dmake/startup/templates/win95/microsft
-@dirrm share/dmake/startup/templates/win95/borland/bcc50
-@dirrm share/dmake/startup/templates/win95/borland
-@dirrm share/dmake/startup/templates/win95
-@dirrm share/dmake/startup/templates/unix/xenix/pwd
-@dirrm share/dmake/startup/templates/unix/xenix
-@dirrm share/dmake/startup/templates/unix/sysvr4
-@dirrm share/dmake/startup/templates/unix/sysvr3/pwd
-@dirrm share/dmake/startup/templates/unix/sysvr3
-@dirrm share/dmake/startup/templates/unix/sysvr1
-@dirrm share/dmake/startup/templates/unix/solaris/gnu
-@dirrm share/dmake/startup/templates/unix/solaris
-@dirrm share/dmake/startup/templates/unix/linux/gnu
-@dirrm share/dmake/startup/templates/unix/linux
-@dirrm share/dmake/startup/templates/unix/coherent/ver42
-@dirrm share/dmake/startup/templates/unix/coherent/ver40
-@dirrm share/dmake/startup/templates/unix/coherent
-@dirrm share/dmake/startup/templates/unix/bsd43/vf
-@dirrm share/dmake/startup/templates/unix/bsd43/uw
-@dirrm share/dmake/startup/templates/unix/bsd43
-@dirrm share/dmake/startup/templates/unix/386ix
-@dirrm share/dmake/startup/templates/unix
-@dirrm share/dmake/startup/templates/tos
-@dirrm share/dmake/startup/templates/qssl
-@dirrm share/dmake/startup/templates/os2/ibm/icc
-@dirrm share/dmake/startup/templates/os2/ibm
-@dirrm share/dmake/startup/templates/os2
-@dirrm share/dmake/startup/templates/msdos/microsft/msc60
-@dirrm share/dmake/startup/templates/msdos/microsft/msc51
-@dirrm share/dmake/startup/templates/msdos/microsft
-@dirrm share/dmake/startup/templates/msdos/borland/tcc20
-@dirrm share/dmake/startup/templates/msdos/borland/bcc50
-@dirrm share/dmake/startup/templates/msdos/borland/bcc45
-@dirrm share/dmake/startup/templates/msdos/borland/bcc40
-@dirrm share/dmake/startup/templates/msdos/borland/bcc30
-@dirrm share/dmake/startup/templates/msdos/borland
-@dirrm share/dmake/startup/templates/msdos
-@dirrm share/dmake/startup/templates/mac
-@dirrm share/dmake/startup/templates
-@dirrm share/dmake/startup/qssl/qnx
-@dirrm share/dmake/startup/qssl
-@dirrm share/dmake/startup/os2/ibm
-@dirrm share/dmake/startup/os2
-@dirrm share/dmake/startup/msdos/zortech
-@dirrm share/dmake/startup/msdos/microsft
-@dirrm share/dmake/startup/msdos/borland/tcc20
-@dirrm share/dmake/startup/msdos/borland/bcc50.32
-@dirrm share/dmake/startup/msdos/borland/bcc50
-@dirrm share/dmake/startup/msdos/borland/bcc45
-@dirrm share/dmake/startup/msdos/borland/bcc40
-@dirrm share/dmake/startup/msdos/borland/bcc30
-@dirrm share/dmake/startup/msdos/borland
-@dirrm share/dmake/startup/msdos
-@dirrm share/dmake/startup/mac
-@dirrm share/dmake/startup/Windows_NT/microsft
-@dirrm share/dmake/startup/Windows_NT/borland
-@dirrm share/dmake/startup/Windows_NT
@dirrm share/dmake/startup
@dirrm share/dmake