aboutsummaryrefslogtreecommitdiffstats
path: root/dns
diff options
context:
space:
mode:
Diffstat (limited to 'dns')
-rw-r--r--dns/mydns/Makefile2
-rw-r--r--dns/mydns/files/patch-src_mydns_listen.c20
2 files changed, 21 insertions, 1 deletions
diff --git a/dns/mydns/Makefile b/dns/mydns/Makefile
index 15978472475..565c27ad5ec 100644
--- a/dns/mydns/Makefile
+++ b/dns/mydns/Makefile
@@ -7,7 +7,7 @@
PORTNAME= mydns
PORTVERSION= 1.1.0
-PORTREVISION= 5
+PORTREVISION= 6
CATEGORIES= dns databases
MASTER_SITES= http://mydns.bboy.net/download/
diff --git a/dns/mydns/files/patch-src_mydns_listen.c b/dns/mydns/files/patch-src_mydns_listen.c
new file mode 100644
index 00000000000..247bc04c7fd
--- /dev/null
+++ b/dns/mydns/files/patch-src_mydns_listen.c
@@ -0,0 +1,20 @@
+--- src/mydns/listen.c.orig 2011-09-05 14:11:54.000000000 +0200
++++ src/mydns/listen.c 2011-09-05 14:13:17.000000000 +0200
+@@ -310,7 +310,7 @@
+ #if HAVE_IPV6
+ case AF_INET6:
+ memcpy(&addr6, &((struct sockaddr_in6 *)&ifr->ifr_addr)->sin6_addr, sizeof(struct in6_addr));
+- addrlist_add(AF_INET, &addr4, port);
++ addrlist_add(AF_INET, &addr6, port);
+ break;
+ #endif
+ default:
+@@ -454,7 +454,7 @@
+ if (inet_pton(AF_INET6, addr, &addr6) <= 0)
+ Warnx("%s: `%s' %s: %s", addr, desc, _("address"), _("invalid IPv6 address format"));
+ else
+- addrlist_add(AF_INET6, &addr4, port);
++ addrlist_add(AF_INET6, &addr6, port);
+ }
+ #endif
+ }