aboutsummaryrefslogtreecommitdiffstats
path: root/editors/hnb/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'editors/hnb/Makefile')
-rw-r--r--editors/hnb/Makefile13
1 files changed, 12 insertions, 1 deletions
diff --git a/editors/hnb/Makefile b/editors/hnb/Makefile
index 31a82dad101..0f38c7d9191 100644
--- a/editors/hnb/Makefile
+++ b/editors/hnb/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= hnb
-PORTVERSION= 1.9.8
+PORTVERSION= 1.9.17
CATEGORIES= editors
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -15,13 +15,24 @@ MAINTAINER= pat@FreeBSD.org
COMMENT= Hierarchical NoteBook a data organizer
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}/src
+USE_REINPLACE= yes
USE_GMAKE= yes
ALL_TARGET=
MAN1= hnb.1
+post-patch:
+ @${REINPLACE_CMD} -e 's|^CFLAGS=|CFLAGS+=|' ${WRKSRC}/Makefile
+ @${REINPLACE_CMD} -e '/^CFLAGS/d' ${WRKSRC}/libcli/Makefile
+
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/hnb ${PREFIX}/bin
${INSTALL_MAN} ${WRKSRC}/../doc/hnb.1 ${MANPREFIX}/man/man1
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+.for FILE in Documentation.hnb Documentation.html hnbrc
+ ${INSTALL_DATA} ${WRKSRC}/../doc/${FILE} ${DOCSDIR}
+.endfor
+.endif
.include <bsd.port.mk>