aboutsummaryrefslogtreecommitdiffstats
path: root/editors/openoffice.org-1.0/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'editors/openoffice.org-1.0/Makefile')
-rw-r--r--editors/openoffice.org-1.0/Makefile6
1 files changed, 5 insertions, 1 deletions
diff --git a/editors/openoffice.org-1.0/Makefile b/editors/openoffice.org-1.0/Makefile
index 393128b9808..284eaaa6ed7 100644
--- a/editors/openoffice.org-1.0/Makefile
+++ b/editors/openoffice.org-1.0/Makefile
@@ -330,7 +330,11 @@ mozilla:
-e 's|--enable-strip||' \
< ${WRKDIR}/mozilla/Makefile.new > ${WRKDIR}/mozilla/Makefile
.endif
- @cd ${WRKDIR}/mozilla && ${MAKE} build
+.if defined(USE_GCC)
+ cd ${WRKDIR}/mozilla && ${MAKE} CFLAGS="${CFLAGS}" USE_GCC=${USE_GCC} build
+.else
+ cd ${WRKDIR}/mozilla && ${MAKE} CFLAGS="${CFLAGS}" build
+.endif
@${CP} ${FILESDIR}/zipmoz.sh ${WRKDIR}
@${CHMOD} 755 ${WRKDIR}/zipmoz.sh
@${WRKDIR}/zipmoz.sh ${WRKDIR}/mozilla/work/mozilla/dist FREEBSDGCCI ${WRKDIR}