aboutsummaryrefslogtreecommitdiffstats
path: root/editors/xemacs-devel/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'editors/xemacs-devel/Makefile')
-rw-r--r--editors/xemacs-devel/Makefile157
1 files changed, 0 insertions, 157 deletions
diff --git a/editors/xemacs-devel/Makefile b/editors/xemacs-devel/Makefile
deleted file mode 100644
index f8ee76b00e3..00000000000
--- a/editors/xemacs-devel/Makefile
+++ /dev/null
@@ -1,157 +0,0 @@
-# Created by: Gary Jennejohn <gj@FreeBSD.org>
-# $FreeBSD$
-
-PORTNAME= xemacs-devel
-PORTVERSION= ${XEMACS_VER:S/-/./}
-PORTREVISION= 10
-PORTEPOCH= 1
-CATEGORIES+= editors
-MASTER_SITES= ${MASTER_SITE_XEMACS}
-MASTER_SITE_SUBDIR= xemacs-${XEMACS_REL}
-DISTNAME= xemacs-${XEMACS_VER:S/-b/./}
-#DISTFILES= ${DISTNAME}.11${EXTRACT_SUFX}
-DIST_SUBDIR= xemacs
-
-MAINTAINER= ports@FreeBSD.org
-COMMENT= This port tracks the development (GAMMA) version of the XEmacs text editor
-
-CONFLICTS= emacs-19.* emacs-21.* emacs-22.* \
- xemacs-[0-9]* \
- xemacs-mule-[0-9]* xemacs-devel-mule-[0-9]*
-
-RUN_DEPENDS+= ${LOCALBASE}/lib/xemacs/xemacs-packages/etc/enriched.doc:${PORTSDIR}/editors/xemacs-packages
-.if !defined(WITHOUT_X11)
-LIB_DEPENDS+= jpeg.11:${PORTSDIR}/graphics/jpeg \
- png15:${PORTSDIR}/graphics/png \
- tiff.4:${PORTSDIR}/graphics/tiff \
- compface.1:${PORTSDIR}/mail/faces
-USE_XORG+= xbitmaps x11 ice xext xaw xt xmu
-CFLAGS+= -I${LOCALBASE}/include/libpng15
-.endif
-
-XEMACS_MAJOR_VER?= 21
-XEMACS_REL= ${XEMACS_MAJOR_VER}.5
-XEMACS_VER= ${XEMACS_MAJOR_VER}.5-b28
-XEMACS_ARCH= ${CONFIGURE_TARGET}
-
-WRKSRC= ${WRKDIR}/xemacs-${XEMACS_VER:S/-b/./}
-STRIP=
-USE_AUTOTOOLS= autoconf
-CONFIGURE_TARGET=${MACHINE_ARCH}--freebsd
-
-CONFIGURE_ARGS?=--enable-clash-detection \
- --enable-sound=native,nonas,noesd \
- --with-site-includes=${LOCALBASE}/include \
- --with-site-libraries=${LOCALBASE}/lib \
- --with-ldap=no \
- --with-postgresql=no \
- --with-site-lisp \
- --enable-database=berkdb \
- --disable-debug \
- --disable-error-checking \
- --disable-kkcc \
- --disable-newgc \
- ${WITH_XFACE} ${WITH_DIALOGS} ${WITH_OFFIX} ${WITH_GTK}
-MAKE_ARGS= prefix=${PREFIX}
-MAN1= ctags.1 etags.1 gnuattach.1 gnuclient.1 gnudoit.1 \
- gnuserv.1 xemacs.1
-INFO= xemacs-${XEMACS_VER}/beta \
- xemacs-${XEMACS_VER}/cl \
- xemacs-${XEMACS_VER}/custom \
- xemacs-${XEMACS_VER}/emodules \
- xemacs-${XEMACS_VER}/external-widget \
- xemacs-${XEMACS_VER}/info \
- xemacs-${XEMACS_VER}/internals \
- xemacs-${XEMACS_VER}/lispref \
- xemacs-${XEMACS_VER}/new-users-guide \
- xemacs-${XEMACS_VER}/standards \
- xemacs-${XEMACS_VER}/term \
- xemacs-${XEMACS_VER}/termcap \
- xemacs-${XEMACS_VER}/texinfo \
- xemacs-${XEMACS_VER}/widget \
- xemacs-${XEMACS_VER}/xemacs-faq \
- xemacs-${XEMACS_VER}/xemacs
-ALL_TARGET= all dist
-
-PLIST_SUB= XEMACS_VER=${XEMACS_VER} XEMACS_ARCH=${XEMACS_ARCH}
-
-NO_STAGE= yes
-.include <bsd.port.options.mk>
-
-.if exists(${LOCALBASE}/lib/libXm.so)
-USES+= motif
-HAVE_MOTIF= yes
-.endif
-
-pre-fetch:
-#.if !defined(WANT_GTK)
-# @${ECHO_MSG} "If you want to use GTK, please set the environment variable WANT_GTK "
-# @${ECHO_MSG} "and recompile."
-#.endif
-.if defined(HAVE_MOTIF)
-.if !defined(MOTIF_STATIC)
- @${ECHO_MSG} ""
- @${ECHO_MSG} "If your MOTIF library is actually lesstif, you might occasionally"
- @${ECHO_MSG} "experience locked-up frames."
- @${ECHO_MSG} "In this case, set the environment variable MOTIF_STATIC and recompile, "
- @${ECHO_MSG} "which will force the use of athena widgets for dialogs."
-.endif
-.if !defined(WITHOUT_X11)
- @${ECHO_MSG} ""
- @${ECHO_MSG} "Set the environment variable WITHOUT_X11 if you "
- @${ECHO_MSG} "do not want to use X11."
-CONFIG_ARGS+= --with-png=yes --with-tiff=yes
-.endif
-.if defined(WITHOUT_X11)
-CONFIGURE_ARGS+= --with-x11=no
-.endif
-
-# hack to avoid shipping binaries linked with Motif
-.if defined(MOTIF_STATIC)
-WITH_DIALOGS= --enable-dialogs=athena
-.endif
-
-.if defined(WITH_XAW3D)
-LIB_DEPENDS+= Xaw3d:${PORTSDIR}/x11-toolkits/Xaw3d
-CONFIGURE_ARGS+= --with-athena=3d
-.endif
-
-#.if defined(WANT_GTK)
-#WITH_GTK= --with-gtk=yes \
-# --with-xpm=no
-# doesn't work with gtk12?
-#USE_GNOME= gtk20
-#USE_XORG+= xpm
-#.endif
-
-# Drop faces (libcompface) and offix (libDnd) if building package,
-# autodetect otherwise
-.if defined(PACKAGE_BUILDING)
-WITH_XFACE?= --with-xface=no
-WITH_OFFIX?= --with-offix=no
-.endif
-.endif
-
-# fix .so references in a few man pages
-pre-configure::
-.for file in etc/ctags.1 etc/gnuattach.1 etc/gnuclient.1 etc/gnudoit.1
- @${SED} -e 's/\.1/&.gz/' ${WRKSRC}/${file} > ${WRKDIR}/tmp_zot
- @${MV} ${WRKDIR}/tmp_zot ${WRKSRC}/${file}
-.endfor
-
-post-install::
-.for file in b2m ctags ellcc etags gnuclient ootags xemacs-${XEMACS_VER}
- ${STRIP_CMD} ${PREFIX}/bin/${file}
-.endfor
- ${FIND} ${PREFIX}/lib/xemacs-${XEMACS_VER} -name \*.orig \
- -exec ${RM} -f \{} \;
- ${RM} -f ${PREFIX}/bin/send-pr \
- ${PREFIX}/lib/xemacs-${XEMACS_VER}/${XEMACS_ARCH}/modules/auto-autoloads.el~
-#.if defined(WANT_GTK)
-# @${ECHO_MSG} "Please be aware that GTK support is buggy. Do not report bugs to"
-# @${ECHO_MSG} "the maintainer."
-# @${ECHO_MSG} "Please also be aware that the package's name was automagically changed"
-# @${ECHO_MSG} "to ${PORTNAME}${PKGNAMESUFFIX}-${XEMACS_VER}."
-#.endif
-
-.include <bsd.port.mk>