aboutsummaryrefslogtreecommitdiffstats
path: root/emulators/qemu/files/patch-bg
diff options
context:
space:
mode:
Diffstat (limited to 'emulators/qemu/files/patch-bg')
-rw-r--r--emulators/qemu/files/patch-bg25
1 files changed, 12 insertions, 13 deletions
diff --git a/emulators/qemu/files/patch-bg b/emulators/qemu/files/patch-bg
index 57a9ef32df9..52ac1562802 100644
--- a/emulators/qemu/files/patch-bg
+++ b/emulators/qemu/files/patch-bg
@@ -4,22 +4,21 @@ Index: qemu/Makefile.target
#########################################################
-DEFINES+=-D_GNU_SOURCE -D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE
-+DEFINES+=-D_GNU_SOURCE -D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE -DSMBD=\"${LOCALBASE}/sbin/smbd\"
++DEFINES+=-D_GNU_SOURCE -D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE -DSMBD_COMMAND=\"${LOCALBASE}/sbin/smbd\"
LIBS+=-lm
ifndef CONFIG_USER_ONLY
LIBS+=-lz
Index: qemu/vl.c
-@@ -1560,8 +1560,13 @@
- fclose(f);
- atexit(smb_exit);
+@@ -89,10 +89,12 @@
+ #include "exec-all.h"
-+#ifdef __FreeBSD__
-+ snprintf(smb_cmdline, sizeof(smb_cmdline), SMBD " -s %s",
-+ smb_conf);
-+#else
- snprintf(smb_cmdline, sizeof(smb_cmdline), "/usr/sbin/smbd -s %s",
- smb_conf);
+ #define DEFAULT_NETWORK_SCRIPT "/etc/qemu-ifup"
++#ifndef SMBD_COMMAND
+ #ifdef __sun__
+ #define SMBD_COMMAND "/usr/sfw/sbin/smbd"
+ #else
+ #define SMBD_COMMAND "/usr/sbin/smbd"
+#endif
-
- slirp_add_exec(0, smb_cmdline, 4, 139);
- }
+ #endif
+
+ //#define DEBUG_UNUSED_IOPORT