aboutsummaryrefslogtreecommitdiffstats
path: root/emulators/yabause/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'emulators/yabause/Makefile')
-rw-r--r--emulators/yabause/Makefile54
1 files changed, 18 insertions, 36 deletions
diff --git a/emulators/yabause/Makefile b/emulators/yabause/Makefile
index 0a16e284f5d..7e74bb78e3c 100644
--- a/emulators/yabause/Makefile
+++ b/emulators/yabause/Makefile
@@ -2,52 +2,34 @@
# $FreeBSD$
PORTNAME= yabause
-PORTVERSION= 0.9.11.1
-PORTREVISION= 4
+PORTVERSION= 0.9.13.1
CATEGORIES= emulators
-MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTVERSION:S/1.1/1/g}/
+MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTVERSION:R}
MAINTAINER= ports@FreeBSD.org
COMMENT= Sega Saturn system emulator
-LIB_DEPENDS= gtkglext-x11-1.0.0:${PORTSDIR}/x11-toolkits/gtkglext
+LICENSE= GPLv2 # (or later)
-USE_AUTOTOOLS= automake:env autoconf:env aclocal:env
-GNU_CONFIGURE= yes
-USES= gmake openal:soft
+USES= cmake openal:soft pkgconfig
+USE_XORG= xmu xrandr
USE_GL= gl glu glut
-USE_GNOME= #
-USE_SDL= yes
+USE_SDL= sdl
+
+CFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
SUB_FILES= pkg-message
-MAN1= yabause.1
-OPTIONS_DEFINE= QT4
+OPTIONS_SINGLE= GUI
+OPTIONS_SINGLE_GUI= GTK2 QT4
OPTIONS_DEFAULT= QT4
-QT4_DESC= Build wit qt4 interface instead of gtk2 one
-
-NO_STAGE= yes
-.include <bsd.port.options.mk>
-
-.if ${PORT_OPTIONS:MQT4}
-USE_QT4= corelib gui opengl
-CONFIGURE_ARGS+= --with-port=qt
-.else
-USE_GNOME= gtk20
-CONFIGURE_ARGS+= --with-port=gtk
-.endif
-
-.include <bsd.port.pre.mk>
-
-post-patch:
- @${REINPLACE_CMD} -e "s|%%ACLOCAL%%|${ACLOCAL}|g" -e "s|%%AUTOCONF%%|${AUTOCONF}|g" \
- -e "s|%%AUTOMAKE%%|${AUTOMAKE}|g" ${WRKSRC}/autogen.sh
- @${REINPLACE_CMD} -e "s|0.9.10|${PORTVERSION}|g" ${WRKSRC}/configure.in
-
-pre-configure:
- @cd ${WRKSRC} && ${SH} autogen.sh
-post-install:
- @${ECHO_CMD}; ${CAT} ${PKGMESSAGE}; ${ECHO_CMD}
+GTK2_LIB_DEPENDS= libgtkglext-x11-1.0.so:${PORTSDIR}/x11-toolkits/gtkglext
+GTK2_USE= gnome=gtk20
+GTK2_CMAKE_ON= -DYAB_PORTS:STRING=gtk
+QT4_USE= qt4=corelib,gui,opengl \
+ qt4=moc_build,qmake_build,rcc_build,uic_build
+QT4_CMAKE_ON= -DYAB_PORTS:STRING=qt
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>