aboutsummaryrefslogtreecommitdiffstats
path: root/games/ggz-gtk-client/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'games/ggz-gtk-client/Makefile')
-rw-r--r--games/ggz-gtk-client/Makefile20
1 files changed, 4 insertions, 16 deletions
diff --git a/games/ggz-gtk-client/Makefile b/games/ggz-gtk-client/Makefile
index 8ebc4ee9295..33e856e59d5 100644
--- a/games/ggz-gtk-client/Makefile
+++ b/games/ggz-gtk-client/Makefile
@@ -7,26 +7,19 @@
#
PORTNAME= ggz-gtk-client
-PORTVERSION= 0.0.13
+PORTVERSION= ${GGZ_VERSION}
CATEGORIES= games
-MASTER_SITES= http://mirrors.dotsrc.org/ggzgamingzone/ggz/%SUBDIR%/ \
- http://ftp.ggzgamingzone.org/pub/ggz/%SUBDIR%/
-MASTER_SITE_SUBDIR= ${PORTVERSION}
-DIST_SUBDIR= ggz
MAINTAINER= yinjieh@csie.nctu.edu.tw
COMMENT= The GGZ Gaming Zone - GTK+ Frontend
-LIB_DEPENDS= ggzcore.8:${PORTSDIR}/games/ggz-client-libs
-
USE_AUTOTOOLS= libtool:15
-USE_GCC= 3.3+
USE_GNOME= gnometarget gtk20
USE_GETOPT_LONG= yes
-USE_GETTEXT= yes
GNU_CONFIGURE= yes
CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
-CONFIGURE_ARGS= --disable-debug
+CONFIGURE_ARGS= --disable-debug --mandir="${MANPREFIX}/man"
+USE_GGZ= client
MAN6= ggz-gtk.6
@@ -42,10 +35,5 @@ PLIST_SUB+= NLS=""
.endif
.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} < 500000
-IGNORE= depends on libggz which does not build on 4.x
-.endif
-
+.include "${PORTSDIR}/games/libggz/bsd.ggz.mk"
.include <bsd.port.post.mk>
-