aboutsummaryrefslogtreecommitdiffstats
path: root/games/glife/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'games/glife/Makefile')
-rw-r--r--games/glife/Makefile26
1 files changed, 26 insertions, 0 deletions
diff --git a/games/glife/Makefile b/games/glife/Makefile
new file mode 100644
index 00000000000..714fa80341f
--- /dev/null
+++ b/games/glife/Makefile
@@ -0,0 +1,26 @@
+# New ports collection makefile for: glife
+# Date created: 18th May 2000
+# Whom: Ade Lovett <ade@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= glife
+PORTVERSION= 0.2.1
+CATEGORIES= games gnome
+MASTER_SITES= http://download.sourceforge.net/glife/
+DISTNAME= gLife-${PORTVERSION}
+
+MAINTAINER= ade@FreeBSD.org
+
+LIB_DEPENDS= gnome.3:${PORTSDIR}/x11/gnomelibs \
+ glade.3:${PORTSDIR}/devel/libglade
+
+USE_X_PREFIX= yes
+USE_LIBTOOL= yes
+CONFIGURE_ARGS= --localstatedir=${PREFIX}/share/gnome \
+ --datadir=${PREFIX}/share/gnome
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ LIBS="-L${LOCALBASE}/lib"
+
+.include <bsd.port.mk>