aboutsummaryrefslogtreecommitdiffstats
path: root/games/heretic/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'games/heretic/Makefile')
-rw-r--r--games/heretic/Makefile3
1 files changed, 3 insertions, 0 deletions
diff --git a/games/heretic/Makefile b/games/heretic/Makefile
index 6c5439eaaad..0dee74e5164 100644
--- a/games/heretic/Makefile
+++ b/games/heretic/Makefile
@@ -33,7 +33,10 @@ BINARY= xaheretic
.if defined(WITH_SDL)
ALL_TARGET= sdl
BINARY= sdlheretic
+SDL_CONFIG= ${LOCALBASE}/bin/sdl11-config
LIB_DEPENDS= SDL-1.0.2:${PORTSDIR}/devel/sdl10
+MAKE_ENV+= SDL_CONFIG="${SDL_CONFIG}"
+CFLAGS+= `${SDL_CONFIG} --cflags`
.endif
.if defined(WITHOUT_WAD)