aboutsummaryrefslogtreecommitdiffstats
path: root/games/kuklomenos/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'games/kuklomenos/Makefile')
-rw-r--r--games/kuklomenos/Makefile25
1 files changed, 25 insertions, 0 deletions
diff --git a/games/kuklomenos/Makefile b/games/kuklomenos/Makefile
new file mode 100644
index 00000000000..1e67997f735
--- /dev/null
+++ b/games/kuklomenos/Makefile
@@ -0,0 +1,25 @@
+# New ports collection makefile for: kuklomenos
+# Date created: 2008/08/31
+# Whom: chinsan
+#
+# $FreeBSD$
+#
+
+PORTNAME= kuklomenos
+PORTVERSION= 0.2
+CATEGORIES= games
+MASTER_SITES= http://mbays.freeshell.org/kuklomenos/src/ LOCAL/chinsan/games
+
+MAINTAINER= chinsan@FreeBSD.org
+COMMENT= Simple but challenging abstract shoot-em-up game
+
+USE_SDL= sdl gfx
+
+GNU_CONFIGURE= yes
+CONFIGURE_ENV= CPPFLAGS="`${SDL_CONFIG} --cflags` `freetype-config --cflags` -I${LOCALBASE}/include " \
+ LDFLAGS="`${SDL_CONFIG} --libs` -L${LOCALBASE}/lib"
+
+PLIST_FILES= bin/kuklomenos %%DATADIR%%/10x20.fnt %%DATADIR%%/7x13.fnt
+PLIST_DIRS= %%DATADIR%%
+
+.include <bsd.port.mk>