aboutsummaryrefslogtreecommitdiffstats
path: root/games/ltris/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'games/ltris/Makefile')
-rw-r--r--games/ltris/Makefile13
1 files changed, 6 insertions, 7 deletions
diff --git a/games/ltris/Makefile b/games/ltris/Makefile
index d556e01259c..1f0193dc669 100644
--- a/games/ltris/Makefile
+++ b/games/ltris/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= ltris
-PORTVERSION= 1.0.18
+PORTVERSION= 1.0.19
PORTEPOCH= 1
CATEGORIES= games
MASTER_SITES= SF/lgames/${PORTNAME}
@@ -11,13 +11,12 @@ MAINTAINER= johans@FreeBSD.org
COMMENT= Tetris clone but a good one with bunch of cool features
USE_SDL= mixer sdl
-USE_GMAKE= yes
GNU_CONFIGURE= yes
+USES= gmake
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
CONFIGURE_ARGS= --localstatedir=${DATADIR}
-NO_STAGE= yes
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MNLS}
@@ -36,9 +35,9 @@ post-patch:
${WRKSRC}/src/sdl.h ${WRKSRC}/src/tools.h
post-install:
- @${CHMOD} 2755 ${PREFIX}/bin/${PORTNAME}
- @${CHOWN} root:games ${PREFIX}/bin/${PORTNAME}
- @${CHMOD} 0664 ${DATADIR}/${PORTNAME}.hscr
- @${CHOWN} root:games ${DATADIR}/${PORTNAME}.hscr
+ @${CHMOD} 2755 ${STAGEDIR}${PREFIX}/bin/${PORTNAME}
+ @${CHOWN} root:games ${STAGEDIR}${PREFIX}/bin/${PORTNAME}
+ @${CHMOD} 0664 ${STAGEDIR}${DATADIR}/${PORTNAME}.hscr
+ @${CHOWN} root:games ${STAGEDIR}${DATADIR}/${PORTNAME}.hscr
.include <bsd.port.mk>