aboutsummaryrefslogtreecommitdiffstats
path: root/games/quakeforge/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'games/quakeforge/Makefile')
-rw-r--r--games/quakeforge/Makefile8
1 files changed, 5 insertions, 3 deletions
diff --git a/games/quakeforge/Makefile b/games/quakeforge/Makefile
index 6858a33eb7f..2aa727ad954 100644
--- a/games/quakeforge/Makefile
+++ b/games/quakeforge/Makefile
@@ -22,6 +22,8 @@ BUILD_DEPENDS= aclocal:${PORTSDIR}/devel/automake
LIB_DEPENDS= SDL-1.0.2:${PORTSDIR}/devel/sdl \
${GL_DEPENDS}
+SDL_CONFIG?= ${LOCALBASE}/bin/sdl-config
+
WADFILE= quakesw-1.0.6.tar.gz
USE_BZIP2= yes
USE_GMAKE= yes
@@ -32,9 +34,9 @@ AUTOCONF= ${WRKSRC}/bootstrap
BINARIES= quake-x11 quake-sdl qw-client-x11 qw-client-sdl qw-server
-CONFIGURE_ARGS= "--with-sdl=${LOCALBASE}"
-CONFIGURE_ENV= "SDL_LIBS=`sdl-config --libs`" \
- "SDL_CFLAGS=`sdl-config --cflags`"
+CONFIGURE_ARGS= "--with-sdl=${LOCALBASE}"
+CONFIGURE_ENV= "SDL_LIBS=`${SDL_CONFIG} --libs`" \
+ "SDL_CFLAGS=`${SDL_CONFIG} --cflags`"
.if defined(WITH_GLX)
GL_DEPENDS= GL.1:${PORTSDIR}/graphics/utah-glx