aboutsummaryrefslogtreecommitdiffstats
path: root/games/secretmaryochronicles/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'games/secretmaryochronicles/Makefile')
-rw-r--r--games/secretmaryochronicles/Makefile8
1 files changed, 6 insertions, 2 deletions
diff --git a/games/secretmaryochronicles/Makefile b/games/secretmaryochronicles/Makefile
index 74e1c510e9d..c9bc882597a 100644
--- a/games/secretmaryochronicles/Makefile
+++ b/games/secretmaryochronicles/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= secretmaryochronicles
-PORTVERSION= 1.5
-PORTREVISION= 2
+PORTVERSION= 1.6
CATEGORIES= games
MASTER_SITES= SF
MASTER_SITE_SUBDIR= smclone
@@ -25,12 +24,17 @@ GNU_CONFIGURE= yes
USE_GMAKE= yes
USE_SDL= sdl image mixer ttf
USE_GL= gl glu
+USE_GETTEXT= yes
CONFIGURE_ENV= LDFLAGS="-L${LOCALBASE}/lib" \
CPPFLAGS="-I${LOCALBASE}/include"
DATADIR= ${PREFIX}/share/smc
+post-patch:
+ @${REINPLACE_CMD} -e '/^LIBS =/ s|$$|$$(INTLLIBS)|' \
+ ${WRKSRC}/src/Makefile.in
+
.if !defined(NOPORTDOCS)
PORTDOCS= controls.html style.css