aboutsummaryrefslogtreecommitdiffstats
path: root/games/tuxpaint-config/files/patch-Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'games/tuxpaint-config/files/patch-Makefile')
-rw-r--r--games/tuxpaint-config/files/patch-Makefile38
1 files changed, 19 insertions, 19 deletions
diff --git a/games/tuxpaint-config/files/patch-Makefile b/games/tuxpaint-config/files/patch-Makefile
index 1c78b5d8243..47e3b319eaf 100644
--- a/games/tuxpaint-config/files/patch-Makefile
+++ b/games/tuxpaint-config/files/patch-Makefile
@@ -1,6 +1,6 @@
---- ./Makefile.orig Thu Oct 19 04:42:09 2006
-+++ ./Makefile Mon Nov 6 16:05:08 2006
-@@ -19,7 +19,6 @@
+--- Makefile.orig Sun Jul 1 12:06:18 2007
++++ Makefile Fri Jul 20 12:07:40 2007
+@@ -20,7 +20,6 @@
# Where to install things:
@@ -8,7 +8,7 @@
# Program:
-@@ -36,7 +35,7 @@
+@@ -37,7 +36,7 @@
# Docs and man page:
DOC_PREFIX=$(PREFIX)/share/doc/tuxpaint-config/
@@ -17,8 +17,8 @@
# Tux Paint's 'System-wide' Config file:
-@@ -74,7 +73,7 @@
- FLTK_LIBS=`fltk-config --ldstaticflags`
+@@ -77,7 +76,7 @@
+ PAPER_LIB=-lpaper
# Default CFLAGS:
-CFLAGS=-O2 -Wall
@@ -26,7 +26,7 @@
# The entire set of CFLAGS:
ALL_CFLAGS=$(CFLAGS) $(FLTK_CFLAGS) -DDATA_PREFIX=\"$(DATA_PREFIX)\" \
-@@ -143,8 +142,7 @@
+@@ -147,8 +146,7 @@
# to do this as superuser ("root"))
install: install-bin install-data install-man install-doc \
@@ -36,22 +36,22 @@
@echo
@echo "All done! Now (preferably NOT as 'root' superuser),"
@echo "you can type the command 'tuxpaint-config' to run the"
-@@ -233,9 +231,6 @@
- install -d $(ICON_PREFIX)
- cp data/images/icon.png $(ICON_PREFIX)tuxpaint-config.png
- chmod 644 $(ICON_PREFIX)tuxpaint-config.png
-- install -d $(X11_ICON_PREFIX)
-- cp data/images/icon32x32.xpm $(X11_ICON_PREFIX)tuxpaint-config.xpm
-- chmod 644 $(X11_ICON_PREFIX)tuxpaint-config.xpm
+@@ -238,9 +236,6 @@
+ @install -d $(ICON_PREFIX)
+ @cp data/images/icon.png $(ICON_PREFIX)tuxpaint-config.png
+ @chmod 644 $(ICON_PREFIX)tuxpaint-config.png
+- @install -d $(X11_ICON_PREFIX)
+- @cp data/images/icon32x32.xpm $(X11_ICON_PREFIX)tuxpaint-config.xpm
+- @chmod 644 $(X11_ICON_PREFIX)tuxpaint-config.xpm
# Install the program:
-@@ -299,7 +294,7 @@
- obj/defaults.o $(ARCH_LIBS)
- $(CXX) $(ALL_CFLAGS) -o tuxpaint-config obj/tuxpaint-config.o \
+@@ -307,7 +302,7 @@
+ @echo Linking
+ @$(CXX) $(ALL_CFLAGS) -o tuxpaint-config obj/tuxpaint-config.o \
obj/tuxpaint-config2.o obj/defaults.o $(ARCH_LIBS) \
-- $(FLTK_LIBS) $(ARCH_LINKS)
-+ $(FLTK_LIBS) $(ARCH_LINKS) -lintl
+- $(FLTK_LIBS) $(ARCH_LINKS) $(PAPER_LIB)
++ $(FLTK_LIBS) $(ARCH_LINKS) $(PAPER_LIB) -lintl
# Build the object for the program!