aboutsummaryrefslogtreecommitdiffstats
path: root/games/tuxpaint-fonts/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'games/tuxpaint-fonts/Makefile')
-rw-r--r--games/tuxpaint-fonts/Makefile39
1 files changed, 25 insertions, 14 deletions
diff --git a/games/tuxpaint-fonts/Makefile b/games/tuxpaint-fonts/Makefile
index 79ae91dcd10..8b042f47395 100644
--- a/games/tuxpaint-fonts/Makefile
+++ b/games/tuxpaint-fonts/Makefile
@@ -6,49 +6,56 @@
#
PORTNAME= tuxpaint
-PORTVERSION= 1
-PORTREVISION= 4
+PORTVERSION= 2004.06.05
CATEGORIES= games
-MASTER_SITES= SF/${PORTNAME}/${PORTNAME}-fonts/chinese-2003.0${PORTVERSION}.05
+MASTER_SITES= #
PKGNAMESUFFIX= -fonts
DISTFILES= #
MAINTAINER= ports@FreeBSD.org
COMMENT= TuxPaint Localized Fonts
-RUN_DEPENDS= tuxpaint:${PORTSDIR}/games/tuxpaint
+RUN_DEPENDS= tuxpaint>=0.9.21:${PORTSDIR}/games/tuxpaint
NO_BUILD= yes
NO_WRKSUBDIR= yes
# Available font languages.
-LANGS= Chinese Chinese_Simplified Korean
+LANGS= Chinese_Simplified Korean Vietnamese
# Define distfiles for all languages.
-CHINESE_DISTFILES= ${PORTNAME}-ttf-chinese-2003.01.05
-CHINESE_SIMPLIFIED_DISTFILES= ${PORTNAME}-ttf-chinese-simplified-2004.06.05
-KOREAN_DISTFILES= ${PORTNAME}-ttf-korean-2002.12.05
+CHINESE_SIMPLIFIED_DISTNAME= chinese-simplified-2004.06.05
+KOREAN_DISTNAME= korean-2002.12.05
+VIETNAMESE_DISTNAME= vietnamese-2004.04.15
# Define language codes.
-CHINESE_CODE= zh
CHINESE_SIMPLIFIED_CODE= zh_cn
KOREAN_CODE= ko
+VIETNAMESE_CODE= vi
# Generate options menu.
.for l in ${LANGS}
OPTIONS+= ${l:U} "${l:S/_/ /} fonts" on
.endfor
+# Set MASTER_SITES
+.for l in ${LANGS}
+MASTER_SITES+= SF/${PORTNAME}/${PORTNAME}-fonts/${${l:U}_DISTNAME}:${l:U}
+.endfor
+
# Do not use the same OPTIONS directory as "games/tuxpaint".
LATEST_LINK= ${PORTNAME}${PKGNAMESUFFIX}
.include <bsd.port.pre.mk>
# Set DISTFILES and PLIST_FILES according to OPTIONS.
-.for l in ${LANGS:U}
-. if !defined(WITHOUT_${l})
-DISTFILES+= ${${l}_DISTFILES}${EXTRACT_SUFX}
-PLIST_FILES+= %%DATADIR%%/fonts/locale/${${l}_CODE}.ttf
+.for l in ${LANGS}
+. if !defined(WITHOUT_${l:U})
+DISTFILES+= ${PORTNAME}-ttf-${${l:U}_DISTNAME}${EXTRACT_SUFX}:${l:U}
+PLIST_FILES+= %%DATADIR%%/fonts/locale/${${l:U}_CODE}.ttf
+PLIST_FILES+= %%DATADIR%%/fonts/locale/${${l:U}_CODE}_docs/COPYING.txt
+PLIST_FILES+= %%DATADIR%%/fonts/locale/${${l:U}_CODE}_docs/README.txt
+PLIST_DIRS+= %%DATADIR%%/fonts/locale/${${l:U}_CODE}_docs
. endif
.endfor
@@ -58,8 +65,12 @@ do-install:
.for l in ${LANGS}
. if defined(WITH_${l:U})
${INSTALL_DATA} \
- ${WRKSRC}/${${l:U}_DISTFILES}/${${l:U}_CODE}.ttf \
+ ${WRKSRC}/${PORTNAME}-ttf-${${l:U}_DISTNAME}/${${l:U}_CODE}.ttf \
${DATADIR}/fonts/locale
+ ${MKDIR} ${DATADIR}/fonts/locale/${${l:U}_CODE}_docs
+ ${INSTALL_DATA} \
+ ${WRKSRC}/${PORTNAME}-ttf-${${l:U}_DISTNAME}/*.txt \
+ ${DATADIR}/fonts/locale/${${l:U}_CODE}_docs
. endif
.endfor
d> * security/libgcrypt: 1.5.3_3 -> 1.6.1pi2014-07-301-1/+1 * - Make tinderbox happy, rely on threaded library from libssh package to avoidfluffy2014-02-121-1/+1 * - Update FreeRDP to 1.1.0.2013070101 beta releasefluffy2014-01-155-156/+28708 * - Remove manual creation and removal of share/applications, as it's now in th...amdmi32013-10-222-2/+0 * Add NO_STAGE all over the place in preparation for the staging support (cat: ...bapt2013-09-211-0/+1 * Add an explicit dependency on pkgconfbapt2013-09-031-2/+1 * Fix another fallout from ld(1) behaviour change in headbapt2013-08-271-0/+1 * Fix build with newer binutilsbapt2013-08-021-1/+2 * - Fix typo in libssh option handlefluffy2013-06-221-1/+1 * - Update net/remmina and its plugins to 1.0.0 releasefluffy2013-06-205-65/+185 * Convert from WITHOUT_NLS to PORT_OPTIONS:MNLSbapt2013-05-061-14/+15 * Chase security/libgcrypt updateehaupt2013-05-041-7/+3 * - Convert USE_GETTEXT to USES (part 3)ak2013-04-251-1/+1 * - Adopt ports from avl@ to myself by his requestfluffy2013-02-191-1/+1 * - update png to 1.5.10dinoex2012-06-011-1/+1 * - Add LDFLAGS to CONFIGURE_ENV and MAKE_ENV (as it was done with LDFLAGS)amdmi32011-09-241-2/+1 * - Chase the libgcrypt shared lib versionswills2011-07-031-1/+2 * - Update to 0.9.3avl2011-01-272-3/+3 * - Update to 0.9.2avl2010-12-272-3/+3 * - Update to 0.9.1avl2010-12-153-11/+12 * - Update to 0.8.3avl2010-10-123-4/+6 * - Update to 0.8.2avl2010-08-313-4/+5 * - Update to 0.8.1avl2010-08-105-65/+46 * Chase security/libgcrypt shlib bump.wxs2010-07-271-2/+2 * Bounce PORTREVISION for gettext-related ports. Have fun, ya'll.ade2010-05-311-0/+1 * - Update to 0.7.5avl2010-05-033-5/+5 * - update to 1.4.1dinoex2010-03-281-0/+1 * - Update to 0.7.4avl2010-02-245-35/+5 * - update to jpeg-8dinoex2010-02-051-1/+2 * - Update to 0.7.3avl2010-01-315-4/+37 * - Update to 0.7.2avl2010-01-092-4/+4 * - Update to 0.7.1avl2009-12-244-26/+4 * - Fix compilation issue when libvncserver is installedavl2009-12-173-0/+22 * - Fix plistavl2009-12-141-1/+0 * - Update remmina to 0.7.0avl2009-12-144-38/+114 * - Update to 0.6.0avl2009-07-134-9/+31 * Change MAINTAINER on my ports to my FreeBSD email addressavl2009-05-291-1/+1 * - Update to 0.5.1miwi2009-05-012-4/+4