aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/cimg/files/patch-examples::Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'graphics/cimg/files/patch-examples::Makefile')
-rw-r--r--graphics/cimg/files/patch-examples::Makefile14
1 files changed, 8 insertions, 6 deletions
diff --git a/graphics/cimg/files/patch-examples::Makefile b/graphics/cimg/files/patch-examples::Makefile
index aeada6f928c..cd7b78eed3c 100644
--- a/graphics/cimg/files/patch-examples::Makefile
+++ b/graphics/cimg/files/patch-examples::Makefile
@@ -1,27 +1,29 @@
---- examples/Makefile.orig Thu Jun 2 08:51:07 2005
-+++ examples/Makefile Thu Jun 2 22:49:16 2005
-@@ -7,16 +7,16 @@
+--- examples/Makefile.orig Fri Nov 18 16:10:03 2005
++++ examples/Makefile Fri Nov 18 21:32:47 2005
+@@ -7,17 +7,17 @@
# -----------------------------------------------------------------------------------
# Set correct variables and paths
-CC = g++
-X11PATH = /usr/X11R6
-CFLAGS = -Wall -ansi -pedantic -ffast-math -I$(X11PATH)/include
+-LDFLAGS = -lm -lpthread -lX11 -L$(X11PATH)/lib
+CC = $(CXX)
+#X11PATH = /usr/X11R6
+#CFLAGS = -Wall -ansi -pedantic -ffast-math -I$(X11PATH)/include
++#LDFLAGS = -lm -lpthread -lX11 -L$(X11PATH)/lib
# Compilation rules
.cpp:
@echo
@echo "** Compiling '$*' with '`$(CC) -v 2>&1 | grep version`'"
@echo
-- $(CC) -o $* $< $(CFLAGS) $(LDFLAGS)
+- $(CC) -o $* $< $(CFLAGS) $(LDFLAGS) $(ARCHFLAGS)
+ $(CC) -o $* $< $(CPPFLAGS) -Wall -ansi -pedantic -ffast-math -I$(X11PATH)/include -lX11 -L$(X11PATH)/lib $(LDFLAGS)
linux:
- make "LDFLAGS=-lm -lpthread -lX11 -L$(X11PATH)/lib" all
+ make all
solaris:
-@@ -41,6 +41,7 @@
+@@ -42,6 +42,7 @@
clean:
rm -f *.exe *~ \