aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/l2p/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'graphics/l2p/Makefile')
-rw-r--r--graphics/l2p/Makefile44
1 files changed, 44 insertions, 0 deletions
diff --git a/graphics/l2p/Makefile b/graphics/l2p/Makefile
new file mode 100644
index 00000000000..0815981120e
--- /dev/null
+++ b/graphics/l2p/Makefile
@@ -0,0 +1,44 @@
+# New ports collection makefile for: l2p
+# Date created: 2006-03-22
+# Whom: Nicola Vitale <nivit@email.it>
+#
+# $FreeBSD$
+#
+
+PORTNAME= l2p
+PORTVERSION= 1.0
+CATEGORIES= graphics print perl5
+MASTER_SITES= http://www.redsymbol.net/software/l2p/dist/ \
+ http://nivi.interfree.it/distfiles/${PORTNAME}/${PORTVERSION}/
+DISTNAME= ${PORTNAME}-latest
+EXTRACT_SUFX= .tgz
+DIST_SUBDIR= ${PORTNAME}/${PORTVERSION}
+
+MAINTAINER= nivit@email.it
+COMMENT= Create PNG images from LaTeX math expressions
+
+RUN_DEPENDS= convert:${PORTSDIR}/graphics/ImageMagick \
+ dvips:${PORTSDIR}/print/dvipsk-tetex \
+ latex:${PORTSDIR}/print/teTeX
+
+USE_PERL5_RUN= yes
+NO_BUILD= yes
+
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
+
+PLIST_FILES= bin/l2p
+PORTDOCS= l2p.txt l2p.html
+
+post-patch:
+ @${REINPLACE_CMD} -e '1s|.*|#!${PERL} -w|' ${WRKSRC}/${PORTNAME}
+
+do-install:
+ @${INSTALL_SCRIPT} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+.for f in ${PORTDOCS}
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${DOCSDIR}
+.endfor
+.endif
+
+.include <bsd.port.mk>