aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/osg-devel/pkg-plist
diff options
context:
space:
mode:
Diffstat (limited to 'graphics/osg-devel/pkg-plist')
-rw-r--r--graphics/osg-devel/pkg-plist60
1 files changed, 39 insertions, 21 deletions
diff --git a/graphics/osg-devel/pkg-plist b/graphics/osg-devel/pkg-plist
index 347b83a741d..86e27b69757 100644
--- a/graphics/osg-devel/pkg-plist
+++ b/graphics/osg-devel/pkg-plist
@@ -11,26 +11,6 @@ include/OpenThreads/Condition
include/OpenThreads/Config
include/OpenThreads/Exports
include/OpenThreads/Mutex
-include/osg/Callback
-include/osgGA/Event
-include/osgGA/EventHandler
-include/osgGA/Widget
-include/osgPresentation/PresentationInterface
-include/osgUI/AlignmentSettings
-include/osgUI/ColorPalette
-include/osgUI/ComboBox
-include/osgUI/Dialog
-include/osgUI/Export
-include/osgUI/FrameSettings
-include/osgUI/Label
-include/osgUI/LineEdit
-include/osgUI/Popup
-include/osgUI/PushButton
-include/osgUI/Style
-include/osgUI/TextSettings
-include/osgUI/Widget
-include/osgVolume/MultipassTechnique
-include/osgVolume/VolumeScene
include/OpenThreads/ReadWriteMutex
include/OpenThreads/ReentrantMutex
include/OpenThreads/ScopedLock
@@ -47,14 +27,19 @@ include/osg/AutoTransform
include/osg/Billboard
include/osg/BlendColor
include/osg/BlendEquation
+include/osg/BlendEquationi
include/osg/BlendFunc
+include/osg/BlendFunci
include/osg/BoundingBox
include/osg/BoundingSphere
include/osg/BoundsChecking
include/osg/BufferIndexBinding
include/osg/BufferObject
+include/osg/BufferTemplate
+include/osg/Callback
include/osg/Camera
include/osg/CameraView
+include/osg/Capability
include/osg/ClampColor
include/osg/ClearNode
include/osg/ClipNode
@@ -62,6 +47,7 @@ include/osg/ClipPlane
include/osg/ClusterCullingCallback
include/osg/CollectOccludersVisitor
include/osg/ColorMask
+include/osg/ColorMaski
include/osg/ColorMatrix
include/osg/ComputeBoundsVisitor
include/osg/Config
@@ -88,6 +74,7 @@ include/osg/FrontFace
include/osg/GL
include/osg/GL2Extensions
include/osg/GLBeginEndAdapter
+include/osg/GLDefines
include/osg/GLExtensions
include/osg/GLObjects
include/osg/GLU
@@ -219,6 +206,7 @@ include/osg/Vec4ub
include/osg/Vec4ui
include/osg/Vec4us
include/osg/Version
+include/osg/VertexAttribDivisor
include/osg/VertexProgram
include/osg/View
include/osg/Viewport
@@ -275,6 +263,7 @@ include/osgAnimation/VertexInfluence
include/osgDB/Archive
include/osgDB/AuthenticationMap
include/osgDB/Callbacks
+include/osgDB/ClassInterface
include/osgDB/ConvertUTF
include/osgDB/DataTypes
include/osgDB/DatabasePager
@@ -291,6 +280,7 @@ include/osgDB/ImagePager
include/osgDB/ImageProcessor
include/osgDB/Input
include/osgDB/InputStream
+include/osgDB/ObjectCache
include/osgDB/ObjectWrapper
include/osgDB/Options
include/osgDB/Output
@@ -325,6 +315,8 @@ include/osgGA/CameraManipulator
include/osgGA/CameraViewSwitchManipulator
include/osgGA/Device
include/osgGA/DriveManipulator
+include/osgGA/Event
+include/osgGA/EventHandler
include/osgGA/EventQueue
include/osgGA/EventVisitor
include/osgGA/Export
@@ -344,6 +336,7 @@ include/osgGA/TerrainManipulator
include/osgGA/TrackballManipulator
include/osgGA/UFOManipulator
include/osgGA/Version
+include/osgGA/Widget
include/osgManipulator/AntiSquish
include/osgManipulator/Command
include/osgManipulator/CommandManager
@@ -430,6 +423,7 @@ include/osgPresentation/Model
include/osgPresentation/Movie
include/osgPresentation/PickEventHandler
include/osgPresentation/Presentation
+include/osgPresentation/PresentationInterface
include/osgPresentation/PropertyManager
include/osgPresentation/Section
include/osgPresentation/Slide
@@ -444,7 +438,6 @@ include/osgPresentation/Volume
%%QT4%%include/osgQt/QGraphicsViewAdapter
%%QT4%%include/osgQt/QWebViewImage
%%QT4%%include/osgQt/QWidgetImage
-include/osgDB/PropertyInterface
include/osgShadow/ConvexPolyhedron
include/osgShadow/DebugShadowMap
include/osgShadow/Export
@@ -490,7 +483,9 @@ include/osgSim/ShapeAttribute
include/osgSim/SphereSegment
include/osgSim/Version
include/osgSim/VisibilityGroup
+include/osgTerrain/DisplacementMappingTechnique
include/osgTerrain/Export
+include/osgTerrain/GeometryPool
include/osgTerrain/GeometryTechnique
include/osgTerrain/Layer
include/osgTerrain/Locator
@@ -511,6 +506,22 @@ include/osgText/Text
include/osgText/Text3D
include/osgText/TextBase
include/osgText/Version
+include/osgUI/AlignmentSettings
+include/osgUI/Callbacks
+include/osgUI/ColorPalette
+include/osgUI/ComboBox
+include/osgUI/Dialog
+include/osgUI/Export
+include/osgUI/FrameSettings
+include/osgUI/Label
+include/osgUI/LineEdit
+include/osgUI/Popup
+include/osgUI/PushButton
+include/osgUI/Style
+include/osgUI/TabWidget
+include/osgUI/TextSettings
+include/osgUI/Validator
+include/osgUI/Widget
include/osgUtil/ConvertVec
include/osgUtil/CubeMapGenerator
include/osgUtil/CullVisitor
@@ -572,10 +583,13 @@ include/osgVolume/Export
include/osgVolume/FixedFunctionTechnique
include/osgVolume/Layer
include/osgVolume/Locator
+include/osgVolume/MultipassTechnique
include/osgVolume/Property
include/osgVolume/RayTracedTechnique
include/osgVolume/Version
include/osgVolume/Volume
+include/osgVolume/VolumeScene
+include/osgVolume/VolumeSettings
include/osgVolume/VolumeTechnique
include/osgVolume/VolumeTile
include/osgWidget/Box
@@ -685,6 +699,7 @@ lib/osgPlugins-%%OSG_VERSION%%/osgdb_dxf.so
%%GDAL%%lib/osgPlugins-%%OSG_VERSION%%/osgdb_gdal.so
%%GIF%%lib/osgPlugins-%%OSG_VERSION%%/osgdb_gif.so
lib/osgPlugins-%%OSG_VERSION%%/osgdb_glsl.so
+%%GSTREAMER%%lib/osgPlugins-%%OSG_VERSION%%/osgdb_gstreamer.so
%%GTA%%lib/osgPlugins-%%OSG_VERSION%%/osgdb_gta.so
lib/osgPlugins-%%OSG_VERSION%%/osgdb_gz.so
lib/osgPlugins-%%OSG_VERSION%%/osgdb_hdr.so
@@ -694,6 +709,7 @@ lib/osgPlugins-%%OSG_VERSION%%/osgdb_jpeg.so
%%JASPER%%lib/osgPlugins-%%OSG_VERSION%%/osgdb_jp2.so
lib/osgPlugins-%%OSG_VERSION%%/osgdb_ktx.so
lib/osgPlugins-%%OSG_VERSION%%/osgdb_logo.so
+%%LIBLAS%%lib/osgPlugins-%%OSG_VERSION%%/osgdb_las.so
%%LUA%%lib/osgPlugins-%%OSG_VERSION%%/osgdb_lua.so
lib/osgPlugins-%%OSG_VERSION%%/osgdb_lwo.so
lib/osgPlugins-%%OSG_VERSION%%/osgdb_lws.so
@@ -737,12 +753,14 @@ lib/osgPlugins-%%OSG_VERSION%%/osgdb_serializers_osgsim.so
lib/osgPlugins-%%OSG_VERSION%%/osgdb_serializers_osgterrain.so
lib/osgPlugins-%%OSG_VERSION%%/osgdb_serializers_osgtext.so
lib/osgPlugins-%%OSG_VERSION%%/osgdb_serializers_osgui.so
+lib/osgPlugins-%%OSG_VERSION%%/osgdb_serializers_osgutil.so
lib/osgPlugins-%%OSG_VERSION%%/osgdb_serializers_osgviewer.so
lib/osgPlugins-%%OSG_VERSION%%/osgdb_serializers_osgvolume.so
%%SDL%%lib/osgPlugins-%%OSG_VERSION%%/osgdb_sdl.so
lib/osgPlugins-%%OSG_VERSION%%/osgdb_shp.so
lib/osgPlugins-%%OSG_VERSION%%/osgdb_stl.so
%%SVG%%lib/osgPlugins-%%OSG_VERSION%%/osgdb_svg.so
+lib/osgPlugins-%%OSG_VERSION%%/osgdb_tf.so
lib/osgPlugins-%%OSG_VERSION%%/osgdb_tga.so
lib/osgPlugins-%%OSG_VERSION%%/osgdb_tgz.so
lib/osgPlugins-%%OSG_VERSION%%/osgdb_tiff.so