aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/p5-Imager-Graph/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'graphics/p5-Imager-Graph/Makefile')
-rw-r--r--graphics/p5-Imager-Graph/Makefile21
1 files changed, 13 insertions, 8 deletions
diff --git a/graphics/p5-Imager-Graph/Makefile b/graphics/p5-Imager-Graph/Makefile
index bffd576d4e8..1857bfd15a2 100644
--- a/graphics/p5-Imager-Graph/Makefile
+++ b/graphics/p5-Imager-Graph/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= Imager-Graph
-PORTVERSION= 0.07
-PORTREVISION= 3
+PORTVERSION= 0.09
CATEGORIES= graphics perl5
MASTER_SITES= CPAN
PKGNAMEPREFIX= p5-
@@ -15,14 +14,20 @@ PKGNAMEPREFIX= p5-
MAINTAINER= ychsiao@ychsiao.org
COMMENT= Perl extension for producing Graphs using the Imager library
-BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Imager.pm:${PORTSDIR}/graphics/p5-Imager
-RUN_DEPENDS= ${BUILD_DEPENDS}
+BUILD_DEPENDS= p5-Imager>=0.75:${PORTSDIR}/graphics/p5-Imager
+RUN_DEPENDS= p5-Imager>=0.75:${PORTSDIR}/graphics/p5-Imager
PERL_CONFIGURE= yes
-MAN3= Imager::Graph.3 Imager::Graph::Bar.3 Imager::Graph::Column.3 \
- Imager::Graph::Horizontal.3 Imager::Graph::Line.3 \
- Imager::Graph::Pie.3 Imager::Graph::StackedColumn.3 \
- Imager::Graph::Util.3 Imager::Graph::Vertical.3
+MAN3= Imager::Graph.3 \
+ Imager::Graph::Area.3 \
+ Imager::Graph::Bar.3 \
+ Imager::Graph::Column.3 \
+ Imager::Graph::Horizontal.3 \
+ Imager::Graph::Line.3 \
+ Imager::Graph::Pie.3 \
+ Imager::Graph::StackedColumn.3 \
+ Imager::Graph::Util.3 \
+ Imager::Graph::Vertical.3
.include <bsd.port.mk>