aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
Diffstat (limited to 'graphics')
-rw-r--r--graphics/Makefile1
-rw-r--r--graphics/fpc-svgalib/Makefile19
2 files changed, 20 insertions, 0 deletions
diff --git a/graphics/Makefile b/graphics/Makefile
index 8b3d2d52205..ecc31e16fc0 100644
--- a/graphics/Makefile
+++ b/graphics/Makefile
@@ -133,6 +133,7 @@
SUBDIR += fpc-ncurses
SUBDIR += fpc-opengl
SUBDIR += fpc-pasjpeg
+ SUBDIR += fpc-svgalib
SUBDIR += fracplanet
SUBDIR += fractorama
SUBDIR += fraqtive
diff --git a/graphics/fpc-svgalib/Makefile b/graphics/fpc-svgalib/Makefile
new file mode 100644
index 00000000000..3bb7a7e29bf
--- /dev/null
+++ b/graphics/fpc-svgalib/Makefile
@@ -0,0 +1,19 @@
+# New ports collection makefile for: fpc-svgalib
+# Date created: 2006-06-05
+# Whom: Jose Alonso Cardenas Marquez <acardenas@bsd.org.pe>
+#
+# $FreeBSD$
+#
+
+CATEGORIES= graphics lang
+PKGNAMESUFFIX= -svgalib
+
+MAINTAINER= acardenas@bsd.org.pe
+COMMENT= Free Pascal interface to the SVGA graphics library
+
+RUN_DEPENDS= ppc386:${PORTSDIR}/lang/fpc
+LIB_DEPENDS= vga.1:${PORTSDIR}/graphics/svgalib
+
+MASTERDIR= ${.CURDIR}/../../lang/fpc
+
+.include "${MASTERDIR}/Makefile"