aboutsummaryrefslogtreecommitdiffstats
path: root/irc/weechat-devel/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'irc/weechat-devel/Makefile')
-rw-r--r--irc/weechat-devel/Makefile12
1 files changed, 9 insertions, 3 deletions
diff --git a/irc/weechat-devel/Makefile b/irc/weechat-devel/Makefile
index 09e83d6d69e..1bccbf81eed 100644
--- a/irc/weechat-devel/Makefile
+++ b/irc/weechat-devel/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= weechat
-PORTVERSION= 0.2.1
-PORTREVISION= 1
+PORTVERSION= 0.2.3
CATEGORIES= irc
MASTER_SITES= http://flashcode.free.fr/flashtux/weechat/ \
http://weechat.flashtux.org/download/
@@ -21,7 +20,7 @@ USE_AUTOTOOLS= autoconf:259
USE_LDCONFIG= yes
GNU_CONFIGURE= yes
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
-CONFIGURE_ARGS= --disable-lua
+CONFIGURE_ARGS= --disable-lua --disable-aspell
MAN1= weechat-curses.1
@@ -31,6 +30,13 @@ CONFIGURE_ARGS+= --with-debug=2
CONFIGURE_ARGS+= --with-debug=0
.endif
+.if defined(WITHOUT_CHARSET)
+CONFIGURE_ARGS+= --disable-charset
+PLIST_SUBS+= CHARSET="@comment"
+.else
+PLIST_SUB+= CHARSET=""
+.endif
+
.if defined(WITHOUT_NLS)
CONFIGURE_ARGS+= --disable-nls
PLIST_SUB+= NLS="@comment "