aboutsummaryrefslogtreecommitdiffstats
path: root/japanese/epwutil/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'japanese/epwutil/Makefile')
-rw-r--r--japanese/epwutil/Makefile37
1 files changed, 37 insertions, 0 deletions
diff --git a/japanese/epwutil/Makefile b/japanese/epwutil/Makefile
new file mode 100644
index 00000000000..237bf9ef709
--- /dev/null
+++ b/japanese/epwutil/Makefile
@@ -0,0 +1,37 @@
+# New ports collection makefile for: epwutil
+# Version required: 1.0
+# Date created: 22 January 1999
+# Whom: Kazutoki TAKAMUNE <takamune@avrl.mei.co.jp>
+#
+# $Id$
+#
+
+DISTNAME= epwutil-1.0
+PKGNAME= ja-epwutil-1.0
+CATEGORIES= japanese
+MASTER_SITES= ftp://ftp.nerimadors.or.jp/pub/epwutil/ \
+ ftp://ring.aist.go.jp/openlab/lookup/edict/
+
+MAINTAINER= takamune@avrl.mei.co.jp
+
+NO_WRKSUBDIR= yes
+MAKEFILE= makefile.unx
+MANLANG= ja
+
+EPWPROGS= bookinfo catdump squeeze
+EPWDOCS= epwutil.doc
+EPWDOCDIR= ${PREFIX}/share/doc/epwutil
+
+do-install:
+ cd ${WRKSRC}; ${INSTALL_PROGRAM} ${EPWPROGS} ${PREFIX}/bin
+.for file in ${EPWPROGS}
+ cd ${WRKSRC};\
+ ${INSTALL_MAN} ${file}.man ${MANPREFIX}/man/${MANLANG}/cat1/${file}.1
+.if !defined(NOMANCOMPRESS)
+ ${GZIP_CMD} -9nf ${MANPREFIX}/man/${MANLANG}/cat1/${file}.1
+.endif
+.endfor
+ @${MKDIR} ${EPWDOCDIR}
+ cd ${WRKSRC}; ${INSTALL_DATA} ${EPWDOCS} ${EPWDOCDIR}
+
+.include <bsd.port.mk>