aboutsummaryrefslogtreecommitdiffstats
path: root/java/jamvm/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'java/jamvm/Makefile')
-rw-r--r--java/jamvm/Makefile46
1 files changed, 46 insertions, 0 deletions
diff --git a/java/jamvm/Makefile b/java/jamvm/Makefile
new file mode 100644
index 00000000000..7abd90bfc3c
--- /dev/null
+++ b/java/jamvm/Makefile
@@ -0,0 +1,46 @@
+# New ports collection makefile for: jamvm
+# Date created: 31 March 2008
+# Whom: Bjoern Koenig
+#
+# $FreeBSD$
+
+PORTNAME= jamvm
+PORTVERSION= 1.5.1
+CATEGORIES= java devel
+MASTER_SITES= SF
+
+MAINTAINER= bkoenig@alpha-tierchen.de
+COMMENT= A compact Java virtual machine
+
+RUN_DEPENDS= ${LOCALBASE}/share/classpath/glibj.zip:${PORTSDIR}/java/classpath
+
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --with-classpath-install-dir=${LOCALBASE}
+USE_GMAKE= yes
+
+OPTIONS= FFI "use libffi to call native methods" ON \
+ ZIP "turn-on zip support in the bootstrap loader" ON
+
+.include <bsd.port.pre.mk>
+
+.if defined(WITH_FFI)
+LIB_DEPENDS+= ffi:${PORTSDIR}/devel/libffi
+CONFIGURE_ARGS+= --enable-ffi
+CONFIGURE_ENV+= CFLAGS="${CFLAGS} `pkg-config libffi --cflags`" LDFLAGS="${LDFLAGS} -L${LOCALBASE}/lib"
+.endif
+
+.if defined(WITH_ZIP)
+BUILD_DEPENDS+= zip:${PORTSDIR}/archivers/zip
+PLIST_SUB+= WITH_ZIP="" WITHOUT_ZIP="@comment "
+.else
+CONFIGURE_ARGS+= --disable-zip
+PLIST_SUB+= WITH_ZIP="@comment " WITHOUT_ZIP=""
+.endif
+
+post-extract:
+ @${MV} ${WRKSRC}/src/arch/x86_64.h ${WRKSRC}/src/arch/amd64.h
+
+post-configure:
+ @${MV} ${WRKSRC}/src/os/bsd/x86_64 ${WRKSRC}/src/os/bsd/amd64
+
+.include <bsd.port.post.mk>