aboutsummaryrefslogtreecommitdiffstats
path: root/java/jdk15
diff options
context:
space:
mode:
Diffstat (limited to 'java/jdk15')
-rw-r--r--java/jdk15/Makefile9
1 files changed, 9 insertions, 0 deletions
diff --git a/java/jdk15/Makefile b/java/jdk15/Makefile
index c9cf50626a3..d66e332faf9 100644
--- a/java/jdk15/Makefile
+++ b/java/jdk15/Makefile
@@ -132,6 +132,15 @@ pre-build:
echo "This is known to cause problems during bootstrapping."; \
exit 1; \
fi
+ @if [ `sysctl -n compat.linux.osname` != "Linux" ]; \
+ then \
+ echo "Please set the value of the sysctl compat.linux.osname"; \
+ echo "to 'Linux' with the command:"; \
+ echo " sysctl compat.linux.osname=Linux"; \
+ echo "Having it set to other values, such as 'FreeBSD',"; \
+ echo "is known to cause problems during bootstrapping."; \
+ exit 1; \
+ fi
.endif
post-build: