aboutsummaryrefslogtreecommitdiffstats
path: root/java
diff options
context:
space:
mode:
Diffstat (limited to 'java')
-rw-r--r--java/avis/Makefile2
-rw-r--r--java/cacao/Makefile2
-rw-r--r--java/commonclipse/Makefile2
-rw-r--r--java/cos/Makefile2
-rw-r--r--java/cryptix-jce/Makefile2
-rw-r--r--java/eclipse-EPIC/Makefile2
-rw-r--r--java/eclipse-RDT/Makefile2
-rw-r--r--java/eclipse-aptana-radrails/Makefile2
-rw-r--r--java/eclipse-aptana/Makefile2
-rw-r--r--java/eclipse-aptana2/Makefile2
-rw-r--r--java/eclipse-cdt/Makefile2
-rw-r--r--java/eclipse-checkstyle/Makefile2
-rw-r--r--java/eclipse-datatools/Makefile2
-rw-r--r--java/eclipse-drjava/Makefile2
-rw-r--r--java/eclipse-emf/Makefile2
-rw-r--r--java/eclipse-examples/Makefile2
-rw-r--r--java/eclipse-findbugs/Makefile2
-rw-r--r--java/eclipse-gef-examples/Makefile2
-rw-r--r--java/eclipse-gef/Makefile2
-rw-r--r--java/eclipse-hibernatetools/Makefile2
-rw-r--r--java/eclipse-langpack/Makefile2
-rw-r--r--java/eclipse-log4e/Makefile3
-rw-r--r--java/eclipse-lomboz/Makefile2
-rw-r--r--java/eclipse-ocl/Makefile2
-rw-r--r--java/eclipse-pmd/Makefile2
-rw-r--r--java/eclipse-propedit/Makefile2
-rw-r--r--java/eclipse-pydev/Makefile3
-rw-r--r--java/eclipse-quantum/Makefile2
-rw-r--r--java/eclipse-shelled/Makefile2
-rw-r--r--java/eclipse-sqlexplorer/Makefile3
-rw-r--r--java/eclipse-sysdeo-tomcat/Makefile2
-rw-r--r--java/eclipse-uml/Makefile2
-rw-r--r--java/eclipse-vep-examples/Makefile2
-rw-r--r--java/eclipse-vep/Makefile2
-rw-r--r--java/eclipse-viplugin/Makefile2
-rw-r--r--java/eclipse-webtools/Makefile2
-rw-r--r--java/infobus/Makefile2
-rw-r--r--java/jad/Makefile2
-rw-r--r--java/jaf/Makefile2
-rw-r--r--java/jai/Makefile2
-rw-r--r--java/jakarta-struts/Makefile2
-rw-r--r--java/jasmin/Makefile3
-rw-r--r--java/javahelp/Makefile2
-rw-r--r--java/javamail/Makefile2
-rw-r--r--java/jcalendar/Makefile2
-rw-r--r--java/jcckit/Makefile2
-rw-r--r--java/jdk16-doc/Makefile2
-rw-r--r--java/jdk7-doc/Makefile2
-rw-r--r--java/jgraph/Makefile2
-rw-r--r--java/jgrapht/Makefile2
-rw-r--r--java/jmf/Makefile2
-rw-r--r--java/jrosetta/Makefile2
-rw-r--r--java/jta/Makefile2
-rw-r--r--java/langspec/Makefile1
-rw-r--r--java/netbeans-devel/Makefile2
-rw-r--r--java/netbeans/Makefile2
-rw-r--r--java/netcomponents/Makefile2
-rw-r--r--java/netrexx/Makefile2
-rw-r--r--java/openjdk7/Makefile3
-rw-r--r--java/phpeclipse/Makefile2
-rw-r--r--java/poseidon/Makefile2
-rw-r--r--java/servingxml/Makefile2
-rw-r--r--java/springframework/Makefile2
-rw-r--r--java/springframework31/Makefile2
-rw-r--r--java/visualvm/Makefile2
-rw-r--r--java/xdoclet/Makefile2
66 files changed, 67 insertions, 69 deletions
diff --git a/java/avis/Makefile b/java/avis/Makefile
index 3200778232d..ea2f1ca6b90 100644
--- a/java/avis/Makefile
+++ b/java/avis/Makefile
@@ -12,7 +12,7 @@ MAINTAINER= benjsc@FreeBSD.org
COMMENT= Elvin Publish/Subscribe Message Bus server based on the Elvin protocol
USE_RC_SUBR= yes
-USE_ZIP= yes
+USES= zip
USE_JAVA= yes
JAVA_VERSION= 1.6+
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
diff --git a/java/cacao/Makefile b/java/cacao/Makefile
index aded86e9d12..6584a980caa 100644
--- a/java/cacao/Makefile
+++ b/java/cacao/Makefile
@@ -14,8 +14,8 @@ LICENSE= GPLv2
BUILD_DEPENDS= ${LOCALBASE}/share/classpath/glibj.zip:${PORTSDIR}/java/classpath
RUN_DEPENDS= ${LOCALBASE}/share/classpath/glibj.zip:${PORTSDIR}/java/classpath
+USES= gmake
GNU_CONFIGURE= yes
-USE_GMAKE= yes
USE_XZ= yes
MAN1= cacao.1
diff --git a/java/commonclipse/Makefile b/java/commonclipse/Makefile
index 678ec7ce5e9..8970d113030 100644
--- a/java/commonclipse/Makefile
+++ b/java/commonclipse/Makefile
@@ -7,7 +7,6 @@ PORTREVISION= 4
CATEGORIES= java devel
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTNAME}-${PORTVERSION}%20for%20eclipse%203.1M6%20and%20up
DISTNAME= net.sf.commonclipse_${PORTVERSION}
-EXTRACT_SUFX= .zip
DIST_SUBDIR= eclipse
MAINTAINER= zhoushuqun@gmail.com
@@ -15,6 +14,7 @@ COMMENT= Commonclipse is an eclipse plugin for jakarta commons-lang users
RUN_DEPENDS= eclipse:${PORTSDIR}/java/eclipse
+USES= zip
NO_BUILD= yes
NO_WRKSUBDIR= yes
USE_JAVA= yes
diff --git a/java/cos/Makefile b/java/cos/Makefile
index 7bac5e3d712..9fff98c15dd 100644
--- a/java/cos/Makefile
+++ b/java/cos/Makefile
@@ -9,12 +9,12 @@ CATEGORIES= java devel
MASTER_SITES= http://www.servlets.com/cos/ \
http://www.oreilly.com.tw/bookcode/
DISTNAME= ${PORTNAME}-05Nov2002
-EXTRACT_SUFX= .zip
MAINTAINER= java@FreeBSD.org
COMMENT= The O'Reilly package of utility classes for servlet developers
NO_WRKSUBDIR= yes
+USES= zip
USE_JAVA= yes
NO_BUILD= yes
RESTRICTED= Special conditions apply for commercial use, see licence
diff --git a/java/cryptix-jce/Makefile b/java/cryptix-jce/Makefile
index 4fd18d44126..83ae733e934 100644
--- a/java/cryptix-jce/Makefile
+++ b/java/cryptix-jce/Makefile
@@ -6,11 +6,11 @@ PORTREVISION= 2
CATEGORIES= java security
MASTER_SITES= http://www.cryptix.org/
DISTNAME= ${PORTNAME}-${PORTVERSION}-snap
-EXTRACT_SUFX= .zip
MAINTAINER= ports@FreeBSD.org
COMMENT= JCE (Java Cryptography Extension) by Cryptix
+USES= zip
USE_JAVA= yes
JAVA_VERSION= 1.6+
NO_BUILD= yes
diff --git a/java/eclipse-EPIC/Makefile b/java/eclipse-EPIC/Makefile
index 234895f2252..1b2061769a1 100644
--- a/java/eclipse-EPIC/Makefile
+++ b/java/eclipse-EPIC/Makefile
@@ -15,7 +15,7 @@ COMMENT= EPIC adds Perl support to the Eclipse IDE Framework
RUN_DEPENDS= ${LOCALBASE}/bin/eclipse:${PORTSDIR}/java/eclipse
NO_BUILD= yes
-USE_ZIP= yes
+USES= zip:infozip
WRKSRC= ${WRKDIR}/${EPIC}
EPIC= org.epic.updatesite
diff --git a/java/eclipse-RDT/Makefile b/java/eclipse-RDT/Makefile
index 55a48830c56..37876cdbffe 100644
--- a/java/eclipse-RDT/Makefile
+++ b/java/eclipse-RDT/Makefile
@@ -15,7 +15,7 @@ COMMENT= RDT adds Ruby support to the Eclipse IDE Framework
RUN_DEPENDS= ${LOCALBASE}/bin/eclipse:${PORTSDIR}/java/eclipse
NO_BUILD= yes
-USE_ZIP= yes
+USES= zip:infozip
USE_RUBY= yes
USE_JAVA= yes
WRKSRC= ${WRKDIR}/${RDT}
diff --git a/java/eclipse-aptana-radrails/Makefile b/java/eclipse-aptana-radrails/Makefile
index 17517278368..7863a50388b 100644
--- a/java/eclipse-aptana-radrails/Makefile
+++ b/java/eclipse-aptana-radrails/Makefile
@@ -10,13 +10,13 @@ MASTER_SITES= http://update1.aptana.org/rails/${PORTVERSION}/ \
PKGNAMEPREFIX= eclipse-
PKGNAMESUFFIX= -radrails
DISTNAME= org.radrails.rails_feature-${PORTVERSION}-278787EUNvWohWG-fz0019H9P9Y9
-EXTRACT_SUFX= .zip
MAINTAINER= ports@FreeBSD.org
COMMENT= IDE for Ruby and the Ruby on Rails framework (Eclipse plugin)
RUN_DEPENDS= ${LOCALBASE}/lib/eclipse/features/com.aptana.ide.feature_1.2.7.024747.jar:${PORTSDIR}/java/eclipse-aptana
+USES= zip
JAVA_VERSION= 1.6+
NO_BUILD= yes
diff --git a/java/eclipse-aptana/Makefile b/java/eclipse-aptana/Makefile
index 87684e9abac..eb234d327b8 100644
--- a/java/eclipse-aptana/Makefile
+++ b/java/eclipse-aptana/Makefile
@@ -9,7 +9,6 @@ CATEGORIES= java devel
MASTER_SITES= http://update1.aptana.org/studio/3.2/024747/
PKGNAMEPREFIX= eclipse-
DISTNAME= aptana_update_${PORTVERSION:E}
-EXTRACT_SUFX= .zip
MAINTAINER= nivit@FreeBSD.org
COMMENT= Aptana Web Development Tools (Eclipse plugin)
@@ -18,6 +17,7 @@ RUN_DEPENDS= ${LOCALBASE}/bin/eclipse:${PORTSDIR}/java/eclipse
CONFLICTS_INSTALL= eclipse-aptana-[2-9]*
+USES= zip
JAVA_VERSION= 1.6+
NO_BUILD= yes
diff --git a/java/eclipse-aptana2/Makefile b/java/eclipse-aptana2/Makefile
index 17f7b619238..964b25c8f38 100644
--- a/java/eclipse-aptana2/Makefile
+++ b/java/eclipse-aptana2/Makefile
@@ -9,7 +9,6 @@ MASTER_SITES= http://nivi.interfree.it/distfiles/eclipse-aptana2/
PKGNAMEPREFIX= eclipse-
PKGNAMESUFFIX= 2
DISTNAME= com.aptana.ide.feature.studio-${PORTVERSION}-5-7857HJ97CFF61HN1HZHtem5tN7
-EXTRACT_SUFX= .zip
MAINTAINER= nivit@FreeBSD.org
COMMENT= Aptana Studio 2 Web Development Tools (Eclipse plugin)
@@ -18,6 +17,7 @@ RUN_DEPENDS= ${LOCALBASE}/bin/eclipse:${PORTSDIR}/java/eclipse
CONFLICTS_INSTALL= eclipse-aptana-1*
+USES= zip
JAVA_VERSION= 1.6+
NO_BUILD= yes
diff --git a/java/eclipse-cdt/Makefile b/java/eclipse-cdt/Makefile
index 5f3131a5204..fbe6faf4146 100644
--- a/java/eclipse-cdt/Makefile
+++ b/java/eclipse-cdt/Makefile
@@ -9,13 +9,13 @@ MASTER_SITES= ${MASTER_SITE_ECLIPSE}
MASTER_SITE_SUBDIR=tools/${PLUGIN}/releases/${ECLIPSE_CODENAME}/dist
PKGNAMEPREFIX= eclipse-
DISTNAME= ${PLUGIN}-master-${PORTVERSION}
-EXTRACT_SUFX= .zip
MAINTAINER= ports@FreeBSD.org
COMMENT= C/C++ plugin for Eclipse IDE
RUN_DEPENDS= eclipse:${PORTSDIR}/java/eclipse
+USES= zip
USE_JAVA= YES
JAVA_OS= native
JAVA_RUN= YES
diff --git a/java/eclipse-checkstyle/Makefile b/java/eclipse-checkstyle/Makefile
index e82824a0819..86bac3e1413 100644
--- a/java/eclipse-checkstyle/Makefile
+++ b/java/eclipse-checkstyle/Makefile
@@ -8,7 +8,6 @@ CATEGORIES= java devel
MASTER_SITES= SF/eclipse-cs/Eclipse%20Checkstyle%20Plug-in/v3.4.1
PKGNAMEPREFIX= eclipse-
DISTNAME= com.atlassw.tools.eclipse.checkstyle_${PORTVERSION}
-EXTRACT_SUFX= .zip
DIST_SUBDIR= eclipse
MAINTAINER= freebsd-eclipse@FreeBSD.org
@@ -16,6 +15,7 @@ COMMENT= Integrates the Checkstyle Java code auditor into Eclipse
RUN_DEPENDS= eclipse:${PORTSDIR}/java/eclipse
+USES= zip
NO_WRKSUBDIR= yes
NO_BUILD= yes
USE_JAVA= yes
diff --git a/java/eclipse-datatools/Makefile b/java/eclipse-datatools/Makefile
index dfbf0fa6286..7929ed21f69 100644
--- a/java/eclipse-datatools/Makefile
+++ b/java/eclipse-datatools/Makefile
@@ -8,7 +8,6 @@ MASTER_SITES= ${MASTER_SITE_ECLIPSE:S,/eclipse/downloads/drops/,/datatools/downl
MASTER_SITE_SUBDIR= ${PORTVERSION}
PKGNAMEPREFIX= eclipse-
DISTNAME= dtp-sdk_${PORTVERSION}
-EXTRACT_SUFX= .zip
DIST_SUBDIR= eclipse
MAINTAINER= ports@FreeBSD.org
@@ -21,6 +20,7 @@ RUN_DEPENDS= eclipse:${PORTSDIR}/java/eclipse \
LICENSE= EPL
WRKSRC= ${WRKDIR}/eclipse
+USES= zip
.include "${.CURDIR}/../eclipse/Makefile.plugins"
diff --git a/java/eclipse-drjava/Makefile b/java/eclipse-drjava/Makefile
index 9701b10920f..918c13a419f 100644
--- a/java/eclipse-drjava/Makefile
+++ b/java/eclipse-drjava/Makefile
@@ -8,13 +8,13 @@ CATEGORIES= java devel
MASTER_SITES= SF/${PORTNAME}/3.%20DrJava%20Eclipse%20Plug-in/${PORTNAME}-eclipse-${PORTVERSION}
PKGNAMEPREFIX= eclipse-
DISTNAME= drjava-eclipse-${PORTVERSION}
-EXTRACT_SUFX= .zip
MAINTAINER= nivit@FreeBSD.org
COMMENT= DrJava plugin for Eclipse
RUN_DEPENDS= ${LOCALBASE}/bin/eclipse:${PORTSDIR}/java/eclipse
+USES= zip
NO_BUILD= yes
NO_WRKSUBDIR= yes
USE_JAVA= yes
diff --git a/java/eclipse-emf/Makefile b/java/eclipse-emf/Makefile
index 68fc1536191..66d9e4fd45e 100644
--- a/java/eclipse-emf/Makefile
+++ b/java/eclipse-emf/Makefile
@@ -8,7 +8,6 @@ MASTER_SITES= ${MASTER_SITE_ECLIPSE:S,/eclipse/downloads/drops/,/modeling/emf/em
MASTER_SITE_SUBDIR=${PORTVERSION}/R201201300943
PKGNAMEPREFIX= eclipse-
DISTNAME= emf-xsd-SDK-${PORTVERSION}
-EXTRACT_SUFX= .zip
DIST_SUBDIR= eclipse
MAINTAINER= kamikaze@bsdforen.de
@@ -16,6 +15,7 @@ COMMENT= Eclipse Modeling Framework
RUN_DEPENDS= eclipse:${PORTSDIR}/java/eclipse
+USES= zip
WRKSRC= ${WRKDIR}/eclipse
.include "${.CURDIR}/../eclipse/Makefile.plugins"
diff --git a/java/eclipse-examples/Makefile b/java/eclipse-examples/Makefile
index 069df60a063..5298ff2a554 100644
--- a/java/eclipse-examples/Makefile
+++ b/java/eclipse-examples/Makefile
@@ -9,7 +9,6 @@ MASTER_SITES= ${MASTER_SITE_ECLIPSE}
MASTER_SITE_SUBDIR= R-3.0-200406251208
PKGNAMEPREFIX= eclipse-
DISTNAME= ${PKGNAMEPREFIX}${PORTNAME}-${PORTVERSION}
-EXTRACT_SUFX= .zip
DIST_SUBDIR= eclipse
MAINTAINER= freebsd-eclipse@FreeBSD.org
@@ -17,6 +16,7 @@ COMMENT= Examples for the Eclipse IDE
RUN_DEPENDS= ${LOCALBASE}/bin/eclipse:${PORTSDIR}/java/eclipse
+USES= zip
NO_BUILD= yes
NO_WRKSUBDIR= yes
diff --git a/java/eclipse-findbugs/Makefile b/java/eclipse-findbugs/Makefile
index d91f9f7aa75..2148f3a66ec 100644
--- a/java/eclipse-findbugs/Makefile
+++ b/java/eclipse-findbugs/Makefile
@@ -8,7 +8,6 @@ CATEGORIES= java devel
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}%20eclipse%20plugin/1.3.2
PKGNAMEPREFIX= eclipse-
DISTNAME= edu.umd.cs.findbugs.plugin.eclipse_${DISTVERSION}
-EXTRACT_SUFX= .zip
DIST_SUBDIR= eclipse
MAINTAINER= ports@FreeBSD.org
@@ -16,6 +15,7 @@ COMMENT= Eclipse plug-in that provides FindBugs support
RUN_DEPENDS= eclipse:${PORTSDIR}/java/eclipse
+USES= zip
NO_BUILD= yes
USE_JAVA= yes
JAVA_VERSION= 1.6+
diff --git a/java/eclipse-gef-examples/Makefile b/java/eclipse-gef-examples/Makefile
index becf48df86a..046307a6d8e 100644
--- a/java/eclipse-gef-examples/Makefile
+++ b/java/eclipse-gef-examples/Makefile
@@ -9,7 +9,6 @@ MASTER_SITES= http://download.eclipse.org/tools/gef/downloads/drops/R-3.0-200406
PKGNAMEPREFIX= eclipse-
PKGNAMESUFFIX= -examples
DISTNAME= GEF-examples-${PORTVERSION}
-EXTRACT_SUFX= .zip
DIST_SUBDIR= eclipse
MAINTAINER= freebsd-eclipse@FreeBSD.org
@@ -17,6 +16,7 @@ COMMENT= Graphical Editing Framework for the Eclipse IDE (examples)
RUN_DEPENDS= ${LOCALBASE}/bin/eclipse:${PORTSDIR}/java/eclipse
+USES= zip
NO_BUILD= yes
NO_WRKSUBDIR= yes
diff --git a/java/eclipse-gef/Makefile b/java/eclipse-gef/Makefile
index 2b7e78b62a4..778c91e679a 100644
--- a/java/eclipse-gef/Makefile
+++ b/java/eclipse-gef/Makefile
@@ -16,7 +16,7 @@ COMMENT= Graphical Editing Framework for the Eclipse IDE
RUN_DEPENDS= eclipse:${PORTSDIR}/java/eclipse
WRKSRC= ${WRKDIR}/eclipse
-USE_ZIP= yes
+USES= zip
.include "${.CURDIR}/../eclipse/Makefile.plugins"
diff --git a/java/eclipse-hibernatetools/Makefile b/java/eclipse-hibernatetools/Makefile
index 256fd0720ac..5c27939317d 100644
--- a/java/eclipse-hibernatetools/Makefile
+++ b/java/eclipse-hibernatetools/Makefile
@@ -8,7 +8,6 @@ CATEGORIES= java devel databases
MASTER_SITES= SF/jboss/JBossTools/JBossTools%202.1.2.GA
PKGNAMEPREFIX= eclipse-
DISTNAME= HibernateTools-${DISTVERSION}
-EXTRACT_SUFX= .zip
DIST_SUBDIR= eclipse
MAINTAINER= ports@FreeBSD.org
@@ -23,6 +22,7 @@ RUN_DEPENDS= eclipse:${PORTSDIR}/java/eclipse \
${LOCALBASE}/share/eclipse/dropins/gef:${PORTSDIR}/java/eclipse-gef \
${LOCALBASE}/share/eclipse/dropins/webtools:${PORTSDIR}/java/eclipse-webtools
+USES= zip
NO_BUILD= yes
NO_WRKSUBDIR= yes
USE_JAVA= yes
diff --git a/java/eclipse-langpack/Makefile b/java/eclipse-langpack/Makefile
index db2a5f26da0..f5c4c12a92d 100644
--- a/java/eclipse-langpack/Makefile
+++ b/java/eclipse-langpack/Makefile
@@ -19,8 +19,8 @@ COMMENT= Eclipse Language Pack Feature
RUN_DEPENDS= ${LOCALBASE}/bin/eclipse:${PORTSDIR}/java/eclipse
+USES= zip
NO_WRKSUBDIR= yes
-USE_ZIP= yes
PLIST= ${WRKDIR}/pkg-plist
NO_STAGE= yes
diff --git a/java/eclipse-log4e/Makefile b/java/eclipse-log4e/Makefile
index 8855ed206ba..9e14889c96b 100644
--- a/java/eclipse-log4e/Makefile
+++ b/java/eclipse-log4e/Makefile
@@ -8,7 +8,6 @@ CATEGORIES= java
MASTER_SITES= http://log4e.jayefem.de/download/eclipse3/
PKGNAMEPREFIX= eclipse-
DISTNAME= de.jayefem.${PORTNAME}_free_${PORTVERSION}
-EXTRACT_SUFX= .zip
DIST_SUBDIR= eclipse
MAINTAINER= freebsd-eclipse@FreeBSD.org
@@ -16,9 +15,9 @@ COMMENT= Eclipse plugin to use logger easily in Java projects
RUN_DEPENDS= ${LOCALBASE}/bin/eclipse:${PORTSDIR}/java/eclipse
+USES= zip
NO_BUILD= yes
NO_WRKSUBDIR= yes
-USE_ZIP= yes
NO_STAGE= yes
do-install:
diff --git a/java/eclipse-lomboz/Makefile b/java/eclipse-lomboz/Makefile
index 9fecf10e764..679f0bc736e 100644
--- a/java/eclipse-lomboz/Makefile
+++ b/java/eclipse-lomboz/Makefile
@@ -19,9 +19,9 @@ RUN_DEPENDS= ${LOCALBASE}/bin/eclipse:${PORTSDIR}/java/eclipse
CONFLICTS= eclipse-webtools-0.7*
+USES= zip
NO_BUILD= yes
NO_WRKSUBDIR= yes
-USE_ZIP= yes
USE_JAVA= yes
JAVA_VERSION= 1.6+
JAVA_OS= native
diff --git a/java/eclipse-ocl/Makefile b/java/eclipse-ocl/Makefile
index fe6ff88eb7e..988e9d6d8b1 100644
--- a/java/eclipse-ocl/Makefile
+++ b/java/eclipse-ocl/Makefile
@@ -17,9 +17,9 @@ COMMENT= Implementation of the OCL OMG standard for EMF-based models
RUN_DEPENDS= eclipse:${PORTSDIR}/java/eclipse \
${LOCALBASE}/share/eclipse/dropins/emf:${PORTSDIR}/java/eclipse-emf
+USES= zip
NO_BUILD= yes
NO_WRKSUBDIR= yes
-USE_ZIP= yes
USE_JAVA= yes
JAVA_VERSION= 1.6+
JAVA_OS= native
diff --git a/java/eclipse-pmd/Makefile b/java/eclipse-pmd/Makefile
index a223d204406..e18af752555 100644
--- a/java/eclipse-pmd/Makefile
+++ b/java/eclipse-pmd/Makefile
@@ -15,9 +15,9 @@ COMMENT= Scan Java source code and look for potential problems
RUN_DEPENDS= ${LOCALBASE}/bin/eclipse:${PORTSDIR}/java/eclipse
+USES= zip
NO_BUILD= yes
NO_WRKSUBDIR= yes
-USE_ZIP= yes
USE_JAVA= yes
JAVA_EXTRACT= jre
diff --git a/java/eclipse-propedit/Makefile b/java/eclipse-propedit/Makefile
index 01ccc2df737..9d6997b6877 100644
--- a/java/eclipse-propedit/Makefile
+++ b/java/eclipse-propedit/Makefile
@@ -16,9 +16,9 @@ COMMENT= Properties editor for eclipse
RUN_DEPENDS= eclipse:${PORTSDIR}/java/eclipse
+USES= zip
NO_BUILD= yes
NO_WRKSUBDIR= yes
-USE_ZIP= yes
USE_JAVA= yes
JAVA_VERSION= 1.6+
JAVA_OS= native
diff --git a/java/eclipse-pydev/Makefile b/java/eclipse-pydev/Makefile
index 05a45da79c3..5e65e15299c 100644
--- a/java/eclipse-pydev/Makefile
+++ b/java/eclipse-pydev/Makefile
@@ -21,6 +21,8 @@ NO_WRKSUBDIR= yes
OPTIONS_DEFINE= JYTHON
JYTHON_DESC= Use Jython as Python interpreter
+USES= zip
+
NO_STAGE= yes
.include <bsd.port.options.mk>
@@ -29,7 +31,6 @@ RUN_DEPENDS+= jython:${PORTSDIR}/lang/jython
.endif
USE_PYTHON= yes
-USE_ZIP= yes
DISTDATE= 2013072611
diff --git a/java/eclipse-quantum/Makefile b/java/eclipse-quantum/Makefile
index 00b72158183..27780fac872 100644
--- a/java/eclipse-quantum/Makefile
+++ b/java/eclipse-quantum/Makefile
@@ -16,12 +16,12 @@ COMMENT= Database access and SQL editor for the Eclipse IDE
RUN_DEPENDS= eclipse:${PORTSDIR}/java/eclipse \
${LOCALBASE}/share/eclipse/dropins/gef:${PORTSDIR}/java/eclipse-gef
+USES= zip
NO_WRKSUBDIR= yes
NO_BUILD= yes
NO_EXTRACT= yes
USE_JAVA= yes
JAVA_VERSION= 1.6+
-USE_ZIP= yes
PLIST_SUB+= VERSION=${PORTVERSION}
NO_STAGE= yes
diff --git a/java/eclipse-shelled/Makefile b/java/eclipse-shelled/Makefile
index 98e3c4af068..054bc5c75f3 100644
--- a/java/eclipse-shelled/Makefile
+++ b/java/eclipse-shelled/Makefile
@@ -15,9 +15,9 @@ COMMENT= ShellEd is a superb shell script editor for Eclipse
RUN_DEPENDS= eclipse:${PORTSDIR}/java/eclipse
+USES= zip
NO_BUILD= yes
NO_WRKSUBDIR= yes
-USE_ZIP= yes
USE_JAVA= yes
JAVA_VERSION= 1.6+
JAVA_OS= native
diff --git a/java/eclipse-sqlexplorer/Makefile b/java/eclipse-sqlexplorer/Makefile
index 1c02860b8e3..df62ab7195b 100644
--- a/java/eclipse-sqlexplorer/Makefile
+++ b/java/eclipse-sqlexplorer/Makefile
@@ -8,7 +8,6 @@ CATEGORIES= java
MASTER_SITES= SF/eclipsesql/SQL%20Explorer%20Plugin/${PORTVERSION}
PKGNAMEPREFIX= eclipse-
DISTNAME= net.sourceforge.${PORTNAME}_${PORTVERSION}
-EXTRACT_SUFX= .zip
DIST_SUBDIR= eclipse
MAINTAINER= freebsd-eclipse@FreeBSD.org
@@ -17,9 +16,9 @@ COMMENT= A visual database query tool for Eclipse
RUN_DEPENDS= eclipse:${PORTSDIR}/java/eclipse \
${LOCALBASE}/share/eclipse/dropins/gef:${PORTSDIR}/java/eclipse-gef
+USES= zip
NO_BUILD= yes
NO_WRKSUBDIR= yes
-USE_ZIP= yes
NO_STAGE= yes
do-install:
diff --git a/java/eclipse-sysdeo-tomcat/Makefile b/java/eclipse-sysdeo-tomcat/Makefile
index 311facc4886..0e3302a0835 100644
--- a/java/eclipse-sysdeo-tomcat/Makefile
+++ b/java/eclipse-sysdeo-tomcat/Makefile
@@ -16,9 +16,9 @@ COMMENT= Sysdeo Tomcat Launcher plugin for Eclipse
RUN_DEPENDS+= ${LOCALBASE}/bin/eclipse:${PORTSDIR}/java/eclipse
+USES= zip
NO_BUILD= yes
NO_WRKSUBDIR= yes
-USE_ZIP= yes
NO_STAGE= yes
do-install:
diff --git a/java/eclipse-uml/Makefile b/java/eclipse-uml/Makefile
index 447b63116c7..c6c322e938d 100644
--- a/java/eclipse-uml/Makefile
+++ b/java/eclipse-uml/Makefile
@@ -16,9 +16,9 @@ COMMENT= A framework creating UML diagrams in Eclipse
RUN_DEPENDS= eclipse:${PORTSDIR}/java/eclipse \
${LOCALBASE}/share/eclipse/dropins/emf:${PORTSDIR}/java/eclipse-emf
+USES= zip
NO_BUILD= yes
NO_WRKSUBDIR= yes
-USE_ZIP= yes
USE_JAVA= yes
JAVA_VERSION= 1.6+
JAVA_OS= native
diff --git a/java/eclipse-vep-examples/Makefile b/java/eclipse-vep-examples/Makefile
index 973c52220bc..8b4b8c77fd7 100644
--- a/java/eclipse-vep-examples/Makefile
+++ b/java/eclipse-vep-examples/Makefile
@@ -16,9 +16,9 @@ COMMENT= Visual Editor Project for the Eclipse IDE (examples)
RUN_DEPENDS= ${LOCALBASE}/bin/eclipse:${PORTSDIR}/java/eclipse
+USES= zip
NO_BUILD= yes
NO_WRKSUBDIR= yes
-USE_ZIP= yes
PLIST_SUB= RELEASEVERSION=1.1.0.1
NO_STAGE= yes
diff --git a/java/eclipse-vep/Makefile b/java/eclipse-vep/Makefile
index c11eaabd1ab..841cb9a770d 100644
--- a/java/eclipse-vep/Makefile
+++ b/java/eclipse-vep/Makefile
@@ -19,9 +19,9 @@ RUN_DEPENDS= eclipse:${PORTSDIR}/java/eclipse \
${LOCALBASE}/share/eclipse/dropins/emf:${PORTSDIR}/java/eclipse-emf \
${LOCALBASE}/share/eclipse/dropins/gef:${PORTSDIR}/java/eclipse-gef
+USES= zip
NO_BUILD= yes
NO_WRKSUBDIR= yes
-USE_ZIP= yes
USE_JAVA= yes
JAVA_VERSION= 1.6+
JAVA_OS= native
diff --git a/java/eclipse-viplugin/Makefile b/java/eclipse-viplugin/Makefile
index db3fbb6136a..960348d458a 100644
--- a/java/eclipse-viplugin/Makefile
+++ b/java/eclipse-viplugin/Makefile
@@ -15,9 +15,9 @@ COMMENT= Vi like keybinding Eclipse plugin FREETRIAL Version
RUN_DEPENDS= ${LOCALBASE}/bin/eclipse:${PORTSDIR}/java/eclipse
+USES= zip
NO_WRKSUBDIR= yes
NO_BUILD= yes
-USE_ZIP= yes
USE_JAVA= yes
JAVA_VERSION= 1.6+
JAVA_OS= native
diff --git a/java/eclipse-webtools/Makefile b/java/eclipse-webtools/Makefile
index 82f42bc61a2..e4ff27a6ed1 100644
--- a/java/eclipse-webtools/Makefile
+++ b/java/eclipse-webtools/Makefile
@@ -19,7 +19,7 @@ RUN_DEPENDS= eclipse:${PORTSDIR}/java/eclipse \
${LOCALBASE}/share/eclipse/dropins/datatools:${PORTSDIR}/java/eclipse-datatools
WRKSRC= ${WRKDIR}/eclipse
-USE_ZIP= yes
+USES= zip
NO_STAGE= yes
.include "${.CURDIR}/../eclipse/Makefile.plugins"
diff --git a/java/infobus/Makefile b/java/infobus/Makefile
index 4d7a9c4de03..55b497c37b6 100644
--- a/java/infobus/Makefile
+++ b/java/infobus/Makefile
@@ -10,7 +10,7 @@ DISTNAME= ib12
MAINTAINER= java@FreeBSD.org
COMMENT= Enables dynamic exchange of data between JavaBeans(TM)
-USE_ZIP= YES
+USES= zip
USE_JAVA= YES
JAVA_VERSION= 1.6+
diff --git a/java/jad/Makefile b/java/jad/Makefile
index db849cf898d..45724334f6e 100644
--- a/java/jad/Makefile
+++ b/java/jad/Makefile
@@ -6,11 +6,11 @@ PORTVERSION= 1.5.8c
CATEGORIES= java devel
MASTER_SITES= http://www.varaneckas.com/sites/default/files/jad/
DISTNAME= jad158c.freebsd
-EXTRACT_SUFX= .zip
MAINTAINER= ale@FreeBSD.org
COMMENT= Java Decompiler
+USES= zip
NO_WRKSUBDIR= yes
NO_BUILD= yes
diff --git a/java/jaf/Makefile b/java/jaf/Makefile
index 1fa1fa7a5f1..c480bbfeb59 100644
--- a/java/jaf/Makefile
+++ b/java/jaf/Makefile
@@ -10,7 +10,7 @@ DISTNAME= ${PORTNAME}-${PORTVERSION:S,.,_,g}
MAINTAINER= ports@FreeBSD.org
COMMENT= JavaBeansTM Activation Framework
-USE_ZIP= YES
+USES= zip
USE_JAVA= YES
JAVA_VERSION= 1.6+
diff --git a/java/jai/Makefile b/java/jai/Makefile
index 049f4efcf97..1259a6c07c0 100644
--- a/java/jai/Makefile
+++ b/java/jai/Makefile
@@ -7,11 +7,11 @@ PORTREVISION= 1
CATEGORIES= java graphics
MASTER_SITES= http://download.java.net/media/${PORTNAME}/builds/release/${PORTVERSION:S/./_/g}/
DISTNAME= ${PORTNAME}-${PORTVERSION:S/./_/g}-lib
-EXTRACT_SUFX= .zip
MAINTAINER= java@FreeBSD.org
COMMENT= High performance image processing libraries for Java
+USES= zip
USE_JAVA= yes
JAVA_VERSION= 1.6+
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION:S/./_/g}
diff --git a/java/jakarta-struts/Makefile b/java/jakarta-struts/Makefile
index 396f0049604..6abaeb95987 100644
--- a/java/jakarta-struts/Makefile
+++ b/java/jakarta-struts/Makefile
@@ -15,7 +15,7 @@ COMMENT= Struts framework
USE_JAVA= yes
JAVA_VERSION= 1.6+
NO_BUILD= YES
-USE_ZIP= YES
+USES= zip
JAVASHAREDIR= share/java
TDIR= ${JAVASHAREDIR}/${PKGNAME}
diff --git a/java/jasmin/Makefile b/java/jasmin/Makefile
index 65d1014502a..dd8e7e648d6 100644
--- a/java/jasmin/Makefile
+++ b/java/jasmin/Makefile
@@ -10,8 +10,7 @@ MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTNAME}-${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
COMMENT= Java Assembler Interface
-USES= dos2unix
-USE_ZIP= yes
+USES= dos2unix zip
USE_ANT= yes
ALL_TARGET= jasmin
USE_JAVA= yes
diff --git a/java/javahelp/Makefile b/java/javahelp/Makefile
index 06526a512b9..e0018e670f4 100644
--- a/java/javahelp/Makefile
+++ b/java/javahelp/Makefile
@@ -8,11 +8,11 @@ CATEGORIES= java devel
MASTER_SITES= http://download.java.net/javadesktop/javahelp/ \
http://www.predatorlabs.net/dl/
DISTNAME= ${PORTNAME}2_0_05
-EXTRACT_SUFX= .zip
MAINTAINER= ports@FreeBSD.org
COMMENT= A system to add online help to Java applications
+USES= zip
USE_JAVA= yes
JAVA_VERSION= 1.6+
JAVA_RUN= yes
diff --git a/java/javamail/Makefile b/java/javamail/Makefile
index 977e3780b63..252e066d0d4 100644
--- a/java/javamail/Makefile
+++ b/java/javamail/Makefile
@@ -15,7 +15,7 @@ LICENSE_COMB= dual
OPTIONS_DEFINE= DOCS EXAMPLES
-USE_ZIP= YES
+USES= zip
USE_JAVA= YES
JAVA_VERSION= 1.6+
USE_ANT= YES
diff --git a/java/jcalendar/Makefile b/java/jcalendar/Makefile
index 89106d18f26..3283c08232f 100644
--- a/java/jcalendar/Makefile
+++ b/java/jcalendar/Makefile
@@ -9,7 +9,7 @@ MASTER_SITES= http://www.toedter.com/download/
MAINTAINER= ports@FreeBSD.org
COMMENT= Java Date Chooser
-USE_ZIP= yes
+USES= zip
USE_JAVA= yes
JAVA_VERSION= 1.6+
USE_ANT= yes
diff --git a/java/jcckit/Makefile b/java/jcckit/Makefile
index 1c58175e546..7daa4a94edc 100644
--- a/java/jcckit/Makefile
+++ b/java/jcckit/Makefile
@@ -11,7 +11,7 @@ DISTNAME= ${PORTNAME}
MAINTAINER= ports@FreeBSD.org
COMMENT= Java Chart Construction Kit
-USE_ZIP= yes
+USES= zip
USE_JAVA= yes
WRKSRC= ${WRKDIR}/JCCKit
NO_BUILD= yes
diff --git a/java/jdk16-doc/Makefile b/java/jdk16-doc/Makefile
index 1503d3a646d..b8cf2981322 100644
--- a/java/jdk16-doc/Makefile
+++ b/java/jdk16-doc/Makefile
@@ -26,7 +26,7 @@ JDK_UPDATE_VER= 30
DOWNLOAD_URL= http://www.oracle.com/technetwork/java/javase/downloads/index.html
NO_BUILD= yes
-USE_ZIP= yes
+USES= zip
PORTDOCS= *
NO_STAGE= yes
diff --git a/java/jdk7-doc/Makefile b/java/jdk7-doc/Makefile
index cd528e30545..6dd8d9fa33e 100644
--- a/java/jdk7-doc/Makefile
+++ b/java/jdk7-doc/Makefile
@@ -23,7 +23,7 @@ JDK_UPDATE_VER= 45
DOWNLOAD_URL= http://www.oracle.com/technetwork/java/javase/downloads/index.html
NO_BUILD= yes
-USE_ZIP= yes
+USES= zip
PORTDOCS= *
NO_STAGE= yes
diff --git a/java/jgraph/Makefile b/java/jgraph/Makefile
index a026eeeb896..2255625b7d3 100644
--- a/java/jgraph/Makefile
+++ b/java/jgraph/Makefile
@@ -19,7 +19,7 @@ OPTIONS_DEFINE= COMPILE DOCS
COMPILE_DESC= Compile from source instead of using prebuilt binaries
-USE_ZIP= yes
+USES= zip
NO_WRKSUBDIR= yes
USE_JAVA= yes
JAVA_VERSION= 1.6+
diff --git a/java/jgrapht/Makefile b/java/jgrapht/Makefile
index 823dc95dba8..bc2ae75447e 100644
--- a/java/jgrapht/Makefile
+++ b/java/jgrapht/Makefile
@@ -10,7 +10,7 @@ MASTER_SITES= SF/${PORTNAME}/JGraphT/Version%20${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
COMMENT= Java package for mathematical graph-theory objects and algorithms
-USE_ZIP= yes
+USES= zip
USE_JAVA= yes
JAVA_VERSION= 1.6+
diff --git a/java/jmf/Makefile b/java/jmf/Makefile
index 9f49a75547f..28263e6c320 100644
--- a/java/jmf/Makefile
+++ b/java/jmf/Makefile
@@ -11,9 +11,9 @@ DISTNAME= ${PORTNAME}-${PORTVERSION:S/./_/g}-alljava
MAINTAINER= ports@FreeBSD.org
COMMENT= Java Media Framework
+USES= zip
USE_JAVA= yes
JAVA_VERSION= 1.6+
-USE_ZIP= YES
NO_BUILD= YES
WRKSRC= ${WRKDIR}/JMF-${PORTVERSION}
diff --git a/java/jrosetta/Makefile b/java/jrosetta/Makefile
index 7d2ebac3a01..4bc99a68c7d 100644
--- a/java/jrosetta/Makefile
+++ b/java/jrosetta/Makefile
@@ -12,6 +12,7 @@ MASTER_SITES= http://maven.artenum.com/content/groups/public/com/artenum/${PORTN
MAINTAINER= ports@FreeBSD.org
COMMENT= API for building a graphical console in Swing
+USES= zip
USE_JAVA= yes
JAVA_VERSION= 1.6+
JAVA_RUN= yes
@@ -30,7 +31,6 @@ DISTFILES= ${PORTNAME}-${PORTVERSION}-sources.jar:source
BUILD_DEPENDS= mvn:${PORTSDIR}/devel/maven3
JAVA_BUILD= yes
-USE_ZIP= yes
MANUAL_PACKAGE_BUILD= maven fetches files during build target
diff --git a/java/jta/Makefile b/java/jta/Makefile
index 7cbc414bd80..6de4f1b4496 100644
--- a/java/jta/Makefile
+++ b/java/jta/Makefile
@@ -10,7 +10,7 @@ DISTNAME= ${PORTNAME}-spec${PORTVERSION:S/./_/g}
MAINTAINER= ports@FreeBSD.org
COMMENT= Java Transaction API (JTA)
-USE_ZIP= yes
+USES= zip
USE_JAVA= yes
JAVA_VERSION= 1.6+
diff --git a/java/langspec/Makefile b/java/langspec/Makefile
index f82ada24f02..ab187f6ada7 100644
--- a/java/langspec/Makefile
+++ b/java/langspec/Makefile
@@ -9,6 +9,7 @@ MASTER_SITES= http://java.sun.com/docs/books/jls/download/
MAINTAINER= ale@FreeBSD.org
COMMENT= The Java Language Specification
+USES= zip
USE_ZIP= yes
NO_BUILD= yes
WRKSRC= ${WRKDIR}
diff --git a/java/netbeans-devel/Makefile b/java/netbeans-devel/Makefile
index 805ea217f4c..18588e31311 100644
--- a/java/netbeans-devel/Makefile
+++ b/java/netbeans-devel/Makefile
@@ -14,7 +14,7 @@ COMMENT= Full-featured integrated environment for Java
LICENSE= CDDL GPLv2
LICENSE_COMB= dual
-USE_ZIP= yes
+USES= zip
USE_JAVA= yes
JAVA_VERSION= 1.7+
NO_BUILD= yes
diff --git a/java/netbeans/Makefile b/java/netbeans/Makefile
index 1f3e29691ec..4f75106af13 100644
--- a/java/netbeans/Makefile
+++ b/java/netbeans/Makefile
@@ -14,7 +14,7 @@ COMMENT= A full-featured integrated environment for Java
LICENSE= CDDL GPLv2
LICENSE_COMB= multi
-USE_ZIP= yes
+USES= zip
USE_JAVA= yes
JAVA_VERSION= 1.7+
NO_BUILD= yes
diff --git a/java/netcomponents/Makefile b/java/netcomponents/Makefile
index ac9f56568da..c89f1ce211c 100644
--- a/java/netcomponents/Makefile
+++ b/java/netcomponents/Makefile
@@ -14,8 +14,8 @@ COMMENT= Java library with common network protocol implementations
RESTRICTED= May not redistribute except as part of a new software product
PLIST_FILES= %%JAVAJARDIR%%/${JARFILE}
+USES= zip
USE_JAVA= yes
-USE_ZIP= yes
WRKSRC= ${WRKDIR}/NetComponents-1.3.8a
NO_BUILD= yes
diff --git a/java/netrexx/Makefile b/java/netrexx/Makefile
index 8bbe6317f64..5b0f827915e 100644
--- a/java/netrexx/Makefile
+++ b/java/netrexx/Makefile
@@ -12,7 +12,7 @@ MAINTAINER= ports@FreeBSD.org
COMMENT= Human-oriented programming language for writing/using Java classes
NO_BUILD= yes
-USE_ZIP= yes
+USES= zip
USE_JAVA= yes
NO_STAGE= yes
diff --git a/java/openjdk7/Makefile b/java/openjdk7/Makefile
index 234b01a31d8..23d27511557 100644
--- a/java/openjdk7/Makefile
+++ b/java/openjdk7/Makefile
@@ -26,8 +26,7 @@ LICENSE= GPLv2
WRKSRC= ${WRKDIR}/${PORTNAME}
-USE_ZIP= yes
-USES= iconv gmake
+USES= iconv gmake zip
USE_XORG+= x11 xext xi xrender xt xtst
MAKE_ARGS= CC=${CC} CXX=${CXX} HOST_CC=${CC}
MAKE_JOBS_UNSAFE= yes
diff --git a/java/phpeclipse/Makefile b/java/phpeclipse/Makefile
index b8c729333f6..c4ccdf740d0 100644
--- a/java/phpeclipse/Makefile
+++ b/java/phpeclipse/Makefile
@@ -17,9 +17,9 @@ RUN_DEPENDS= eclipse:${PORTSDIR}/java/eclipse
PLUGIN_PATHS= features plugins
PATCH_TASKS= eclipse.versionReplacer eclipse.idReplacer
+USES= zip
USE_JAVA= yes
USE_ANT= yes
-USE_ZIP= yes
WRKSRC= ${WRKDIR}/dist
ECLIPSE= lib/eclipse
diff --git a/java/poseidon/Makefile b/java/poseidon/Makefile
index 3c2896cc60d..1459a947e77 100644
--- a/java/poseidon/Makefile
+++ b/java/poseidon/Makefile
@@ -11,7 +11,7 @@ DISTNAME= ${PORTNAME}${EDITION}-${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
COMMENT= A popular UML CASE tool
-USE_ZIP= yes
+USES= zip
USE_JAVA= yes
JAVA_VERSION= 1.6+
JAVA_VENDOR= openjdk # the port is broken with Sun JDKs
diff --git a/java/servingxml/Makefile b/java/servingxml/Makefile
index 07385903ab8..731820c402b 100644
--- a/java/servingxml/Makefile
+++ b/java/servingxml/Makefile
@@ -5,13 +5,13 @@ PORTNAME= servingxml
PORTVERSION= 1.1.2
CATEGORIES= java devel
MASTER_SITES= SF
-EXTRACT_SUFX= .zip
MAINTAINER= jpbeconne@free.fr
COMMENT= Framework for flat/XML data transformations
BUILD_DEPENDS= ${ANT_CMD}:${PORTSDIR}/devel/apache-ant
+USES= zip
USE_JAVA= yes
JAVA_VERSION= 1.6+
ANT_CMD?= ${LOCALBASE}/bin/ant
diff --git a/java/springframework/Makefile b/java/springframework/Makefile
index d3d0778134f..73c671f199a 100644
--- a/java/springframework/Makefile
+++ b/java/springframework/Makefile
@@ -16,7 +16,7 @@ CONFLICTS= springframework-3.1.*
NO_BUILD= yes
USE_JAVA= yes
-USE_ZIP= yes
+USES= zip
JAVA_VERSION= 1.6+
OPTIONS_DEFINE= DOCS RESRCS
diff --git a/java/springframework31/Makefile b/java/springframework31/Makefile
index a20cf44ead2..ffa772e5c46 100644
--- a/java/springframework31/Makefile
+++ b/java/springframework31/Makefile
@@ -19,7 +19,7 @@ CONFLICTS= springframework-3.2.*
NO_BUILD= yes
USE_JAVA= yes
-USE_ZIP= yes
+USES= zip
JAVA_VERSION= 1.6+
OPTIONS_DEFINE= DOCS RESRCS
diff --git a/java/visualvm/Makefile b/java/visualvm/Makefile
index 490afcf1fd4..4ce56e346a9 100644
--- a/java/visualvm/Makefile
+++ b/java/visualvm/Makefile
@@ -15,7 +15,7 @@ LICENSE_NAME= VISUALVM with ClassPath Exception
LICENSE_FILE= ${WRKSRC}/LICENSE.txt
LICENSE_PERMS= ${_LICENSE_PERMS_DEFAULT}
-USE_ZIP= yes
+USES= zip:infozip
NO_BUILD= yes
USE_JAVA= yes
JAVA_VERSION= 1.6+
diff --git a/java/xdoclet/Makefile b/java/xdoclet/Makefile
index 232d74cd23e..5f6bd8618ac 100644
--- a/java/xdoclet/Makefile
+++ b/java/xdoclet/Makefile
@@ -8,7 +8,6 @@ PORTEPOCH= 1
CATEGORIES= java devel
MASTER_SITES= SF
DISTNAME= ${PORTNAME}-bin-${PORTVERSION}
-EXTRACT_SUFX= .zip
DISTFILES= ${DISTNAME}.zip xjavadoc-${XJAVADOC_VER}.zip
MAINTAINER= lxv@omut.org
@@ -16,6 +15,7 @@ COMMENT= Java attribute-oriented code generation engine
RUN_DEPENDS= ${LOCALBASE}/bin/ant:${PORTSDIR}/devel/apache-ant
+USES= zip
USE_JAVA= yes
JAVA_VERSION= 1.6+
NO_WRKSUBDIR= yes