aboutsummaryrefslogtreecommitdiffstats
path: root/lang/pike72/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'lang/pike72/Makefile')
-rw-r--r--lang/pike72/Makefile36
1 files changed, 36 insertions, 0 deletions
diff --git a/lang/pike72/Makefile b/lang/pike72/Makefile
new file mode 100644
index 00000000000..74ca0d72f13
--- /dev/null
+++ b/lang/pike72/Makefile
@@ -0,0 +1,36 @@
+# New ports collection makefile for: pike
+# Version required: 0.6
+# Date created: 16 Jan 1999
+# Whom: vns@delta.odessa.ua
+#
+# $Id:$
+#
+
+DISTNAME= Pike-v0.6.110
+PKGNAME= pike-0.6
+CATEGORIES= lang
+MASTER_SITES= http://pike.idonex.se/download/
+
+MAINTAINER= vns@delta.odessa.ua
+
+pre-fetch:
+.if !defined(BATCH)
+ @${SETENV} ${SCRIPTS_ENV} ${SH} ${SCRIPTDIR}/configure.pike
+.endif
+
+WRKSRC= ${WRKDIR}/${DISTNAME}/src/
+
+IS_INTERACTIVE= yes
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS?= \
+ --without-ttflib \
+ --without-gdbm \
+ --without-mysql \
+ --without-postgresql \
+ --without-msql \
+ --without-jpeg
+
+pre-configure:
+ @${ECHO} ${CONFIGURE_ARGS}
+
+.include <bsd.port.mk>