aboutsummaryrefslogtreecommitdiffstats
path: root/lang/python/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'lang/python/Makefile')
-rw-r--r--lang/python/Makefile7
1 files changed, 6 insertions, 1 deletions
diff --git a/lang/python/Makefile b/lang/python/Makefile
index 9452e873bea..31dfb94e9e8 100644
--- a/lang/python/Makefile
+++ b/lang/python/Makefile
@@ -7,7 +7,7 @@
PORTNAME= python
PORTVERSION= 2.2.3
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= lang python ipv6
MASTER_SITES= ${MASTER_SITE_PYTHON}
MASTER_SITE_SUBDIR= ftp/python/${PORTVERSION}
@@ -35,6 +35,11 @@ PYTHON_NO_DEPENDS= yes
.if !defined(WITHOUT_THREADS)
CONFIGURE_ARGS+= --with-threads
CFLAGS+= ${PTHREAD_CFLAGS}
+.if !defined(WANT_HUGE_STACK_SIZE)
+CFLAGS+= -DTHREAD_STACK_SIZE=0x20000
+.else
+CFLAGS+= -DTHREAD_STACK_SIZE=0x100000
+.endif
CONFIGURE_ENV+= LDFLAGS="${PTHREAD_LIBS} ${LDFLAGS}"
.else
CONFIGURE_ARGS+= --without-threads