aboutsummaryrefslogtreecommitdiffstats
path: root/mail/elmo/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'mail/elmo/Makefile')
-rw-r--r--mail/elmo/Makefile10
1 files changed, 9 insertions, 1 deletions
diff --git a/mail/elmo/Makefile b/mail/elmo/Makefile
index 5e99a4f6db5..376e90be9a3 100644
--- a/mail/elmo/Makefile
+++ b/mail/elmo/Makefile
@@ -17,7 +17,6 @@ COMMENT= Receive, filter, read, compose and send mail at the text console
CONFLICTS= elmo-devel-*
GNU_CONFIGURE= yes
-USE_GETTEXT= yes
USE_ICONV= yes
USE_OPENSSL= yes
USE_PERL5_RUN= yes
@@ -26,6 +25,15 @@ CONFIGURE_ENV+= CPPFLAGS="-I${LOCALBASE}/include" \
MAN1= elmo.1 elmoconf.pl.1
+.if defined(WITHOUT_NLS)
+CONFIGURE_ARGS+=--disable-nls
+PLIST_SUB+= NLS="@comment "
+.else
+CONFIGURE_ARGS+=--with-libintl-prefix="${LOCALBASE}"
+PLIST_SUB+= NLS=""
+USE_GETTEXT= yes
+.endif
+
.include <bsd.port.pre.mk>
.if exists(${LOCALBASE}/lib/libgpgme03.so) || defined(WITH_GPGME)