aboutsummaryrefslogtreecommitdiffstats
path: root/mail/ftrack/files
diff options
context:
space:
mode:
Diffstat (limited to 'mail/ftrack/files')
-rw-r--r--mail/ftrack/files/patch-MakeFiles-FreeBSD-Makefile66
-rw-r--r--mail/ftrack/files/patch-hpp-a_list.hpp33
-rw-r--r--mail/ftrack/files/patch-hpp-pktbase.hpp11
-rw-r--r--mail/ftrack/files/patch-hpp-ustr.hpp20
-rw-r--r--mail/ftrack/files/patch-hpp__constant.hpp11
-rw-r--r--mail/ftrack/files/patch-hpp__ufmtypes.h11
-rw-r--r--mail/ftrack/files/patch-src-help.cpp13
-rw-r--r--mail/ftrack/files/patch-src-parsetpl.cpp11
-rw-r--r--mail/ftrack/files/patch-src-scd_do.cpp18
-rw-r--r--mail/ftrack/files/patch-src__ftrack.cpp22
-rw-r--r--mail/ftrack/files/patch-src__ustr.cpp11
-rw-r--r--mail/ftrack/files/patch-src__utils.cpp19
12 files changed, 0 insertions, 246 deletions
diff --git a/mail/ftrack/files/patch-MakeFiles-FreeBSD-Makefile b/mail/ftrack/files/patch-MakeFiles-FreeBSD-Makefile
deleted file mode 100644
index 81d1fc31a87..00000000000
--- a/mail/ftrack/files/patch-MakeFiles-FreeBSD-Makefile
+++ /dev/null
@@ -1,66 +0,0 @@
---- MakeFiles/FreeBSD/Makefile.orig Fri Aug 19 17:20:22 2005
-+++ MakeFiles/FreeBSD/Makefile Fri Aug 19 17:20:23 2005
-@@ -1,5 +1,5 @@
--CC= cc
-+CC= g++
--CFLAGS= -Wall -W -fno-rtti `perl -MExtUtils::Embed -e ccopts`
-+CFLAGS+=-Wall -W -fno-rtti `perl -MExtUtils::Embed -e ccopts`
- CDEFS= -DUNIX
- COPT= -Ihpp -I/usr/local/include -O -pipe
- LFLAGS= -s
-@@ -34,20 +33,50 @@
- utils.o \
- mask.o \
- script.o \
-- wildmat.o
-+ wildmat.o \
-+ ustr.o \
-+ ficl.o \
-+ words.o \
-+ dict.o \
-+ sysdep.o \
-+ math64.o \
-+ vm.o \
-+ stack.o \
-+ softcore.o
-
--%.o: %.c
-+ficl.o: $(SRCDIR)ficl.c
- $(CC) $(CFLAGS) $(CDEFS) $(COPT) -c $<
-
--%.o: $(SRCDIR)%.cpp
-+words.o: $(SRCDIR)words.c
-+ $(CC) $(CFLAGS) $(CDEFS) $(COPT) -c $<
-+
-+dict.o: $(SRCDIR)dict.c
-+ $(CC) $(CFLAGS) $(CDEFS) $(COPT) -c $<
-+
-+sysdep.o: $(SRCDIR)sysdep.c
-+ $(CC) $(CFLAGS) $(CDEFS) $(COPT) -c $<
-+
-+math64.o: $(SRCDIR)math64.c
- $(CC) $(CFLAGS) $(CDEFS) $(COPT) -c $<
-
--$(SRCDIR)cfg.cpp: $(SRCDIR)cfg.y
-- bison -l -d $< -o $(SRCDIR)cfg.tab
-- mv $(SRCDIR)cfg.tab $(SRCDIR)cfg.cpp
-+vm.o: $(SRCDIR)vm.c
-+ $(CC) $(CFLAGS) $(CDEFS) $(COPT) -c $<
-+
-+stack.o: $(SRCDIR)stack.c
-+ $(CC) $(CFLAGS) $(CDEFS) $(COPT) -c $<
-+
-+softcore.o: $(SRCDIR)softcore.c
-+ $(CC) $(CFLAGS) $(CDEFS) $(COPT) -c $<
-+
-+%.o: $(SRCDIR)%.cpp
-+ $(CXX) $(CFLAGS) $(CDEFS) $(COPT) -c $<
-+
-+#$(SRCDIR)cfg.cpp: $(SRCDIR)cfg.y
-+# bison -l -d $< -o $(SRCDIR)cfg.tab
-+# mv $(SRCDIR)cfg.tab $(SRCDIR)cfg.cpp
-
- # Thunderbirds are go!
-
-
- ftrack: $(OBJS)
diff --git a/mail/ftrack/files/patch-hpp-a_list.hpp b/mail/ftrack/files/patch-hpp-a_list.hpp
deleted file mode 100644
index d6aaead1791..00000000000
--- a/mail/ftrack/files/patch-hpp-a_list.hpp
+++ /dev/null
@@ -1,33 +0,0 @@
---- hpp/a_list.hpp.orig Fri Aug 19 17:20:23 2005
-+++ hpp/a_list.hpp Fri Aug 19 17:47:38 2005
-@@ -173,8 +173,8 @@
- protected:
-
- class Elem : public AbstractElem {
-- friend BiList<T>;
-- friend ElemPtr;
-+ friend class BiList<T>;
-+ friend class ElemPtr;
- public:
- T data;
- operator T&() { return data; }
-@@ -199,7 +199,7 @@
- public:
-
- class ElemPtr {
-- friend BiList<T>;
-+ friend class BiList<T>;
- Elem *p;
- ElemPtr(Elem *e) { p = e; }
- protected:
-@@ -294,8 +294,8 @@
- public:
- class ElemPtr : public BiList<T>::ElemPtr {
- public:
-- ElemPtr(BiList<T>::ElemPtr &e) : BiList<T>::ElemPtr(e){}
-- T* operator->() { return operator T*(); }
-+ ElemPtr(typename BiList<T>::ElemPtr &e) : BiList<T>::ElemPtr(e){}
-+ T* operator->() { return BiList<T>::ElemPtr::operator T*(); }
- };
- ElemPtr AddToBegin( T &t ) {
- return (ElemPtr)BiList<T>::AddToBegin(t);
diff --git a/mail/ftrack/files/patch-hpp-pktbase.hpp b/mail/ftrack/files/patch-hpp-pktbase.hpp
deleted file mode 100644
index cfecc022b29..00000000000
--- a/mail/ftrack/files/patch-hpp-pktbase.hpp
+++ /dev/null
@@ -1,11 +0,0 @@
---- hpp/pktbase.hpp.orig 2007-11-05 16:01:21.000000000 +0600
-+++ hpp/pktbase.hpp 2007-11-05 16:01:27.000000000 +0600
-@@ -30,7 +30,7 @@
- int CopyTail(FILE *tf);
- int CopyMessages(FILE *tf);
- int CopyOneMessage(FILE *tf);
-- int PKTBASE::ReadHeader(FILE *tf, char *Buff);
-+ int ReadHeader(FILE *tf, char *Buff);
- public:
- int WriteOneMsg(unsigned int Num, cMSG &m);
- PKTBASE();
diff --git a/mail/ftrack/files/patch-hpp-ustr.hpp b/mail/ftrack/files/patch-hpp-ustr.hpp
deleted file mode 100644
index b189a97f2b7..00000000000
--- a/mail/ftrack/files/patch-hpp-ustr.hpp
+++ /dev/null
@@ -1,20 +0,0 @@
---- hpp/ustr.hpp.orig Fri Aug 19 17:22:08 2005
-+++ hpp/ustr.hpp Fri Aug 19 17:22:52 2005
-@@ -24,7 +24,9 @@
-
- #include <stddef.h>
- #include <ctype.h>
--#include <iostream.h>
-+#include <iostream>
-+
-+using namespace std;
-
- class Str {
- private:
-@@ -81,4 +83,4 @@
-
-
-
--#endif
-\ No newline at end of file
-+#endif
diff --git a/mail/ftrack/files/patch-hpp__constant.hpp b/mail/ftrack/files/patch-hpp__constant.hpp
deleted file mode 100644
index 1c225217a58..00000000000
--- a/mail/ftrack/files/patch-hpp__constant.hpp
+++ /dev/null
@@ -1,11 +0,0 @@
---- hpp/constant.hpp.orig Fri Jan 7 21:15:51 2005
-+++ hpp/constant.hpp Fri Jan 7 21:17:02 2005
-@@ -21,7 +21,7 @@
- # ifdef __LINUX__
- # define OsType "/LNX"
- # elif defined(__FreeBSD__)
--# define OsType "/FBSD"
-+# define OsType "/BSD"
- # elif defined(sun)
- # define OsType "/SUN"
- # elif defined(_AIX)
diff --git a/mail/ftrack/files/patch-hpp__ufmtypes.h b/mail/ftrack/files/patch-hpp__ufmtypes.h
deleted file mode 100644
index 1885dbbc641..00000000000
--- a/mail/ftrack/files/patch-hpp__ufmtypes.h
+++ /dev/null
@@ -1,11 +0,0 @@
---- hpp/ufmtypes.h.orig Fri Apr 14 19:13:02 2000
-+++ hpp/ufmtypes.h Sun May 21 17:07:16 2000
-@@ -1,7 +1,7 @@
- #ifndef _UFMTYPES_H_
- #define _UFMTYPES_H
-
--#include "smapi/typedefs.h"
-+#include <smapi/typedefs.h>
-
- typedef unsigned int uint;
- typedef unsigned char uchar;
diff --git a/mail/ftrack/files/patch-src-help.cpp b/mail/ftrack/files/patch-src-help.cpp
deleted file mode 100644
index 3de99b7b6bf..00000000000
--- a/mail/ftrack/files/patch-src-help.cpp
+++ /dev/null
@@ -1,13 +0,0 @@
---- src/help.cpp.orig Fri Aug 19 17:58:00 2005
-+++ src/help.cpp Fri Aug 19 17:59:15 2005
-@@ -1,7 +1,9 @@
- #include <stdio.h>
- #include "constant.hpp"
- #include "help.hpp"
--#include <iostream.h>
-+#include <iostream>
-+
-+using namespace std;
-
- void Hello(void) {
- cout << "\nFTrack " << FVersion << " " << Copyright << "\n";
diff --git a/mail/ftrack/files/patch-src-parsetpl.cpp b/mail/ftrack/files/patch-src-parsetpl.cpp
deleted file mode 100644
index 052f2623c60..00000000000
--- a/mail/ftrack/files/patch-src-parsetpl.cpp
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/parsetpl.cpp.orig Fri Aug 19 17:49:03 2005
-+++ src/parsetpl.cpp Fri Aug 19 17:50:18 2005
-@@ -880,7 +880,7 @@
-
- // First - replace all \r to \n
-
-- while ((tmt = strchr(Body,'\r')) != NULL) {
-+ while ((tmt = strchr((char *) Body,'\r')) != NULL) {
- *tmt = '\n';
- }
-
diff --git a/mail/ftrack/files/patch-src-scd_do.cpp b/mail/ftrack/files/patch-src-scd_do.cpp
deleted file mode 100644
index 7464b0a0ded..00000000000
--- a/mail/ftrack/files/patch-src-scd_do.cpp
+++ /dev/null
@@ -1,18 +0,0 @@
---- src/scd_do.cpp.orig Fri Aug 19 17:50:40 2005
-+++ src/scd_do.cpp Fri Aug 19 17:51:06 2005
-@@ -472,7 +472,7 @@
- return FALSE;
- }
- CHP = 16101;
-- while ((tmt = strchr(_Tpl->Body,'\n')) != NULL) *tmt = '\r';
-+ while ((tmt = strchr((char *) _Tpl->Body,'\n')) != NULL) *tmt = '\r';
- tmt = m._Body;
- CHP = 16102;
- m._Body = (char *) malloc(((tmt != NULL) ? strlen(tmt) : 0) + strlen(_Tpl->Body) + 1);
-@@ -787,4 +787,4 @@
- return TRUE;
- }
-
--#endif
-\ No newline at end of file
-+#endif
diff --git a/mail/ftrack/files/patch-src__ftrack.cpp b/mail/ftrack/files/patch-src__ftrack.cpp
deleted file mode 100644
index 0177d5af32e..00000000000
--- a/mail/ftrack/files/patch-src__ftrack.cpp
+++ /dev/null
@@ -1,22 +0,0 @@
---- src/ftrack.cpp.orig Fri Aug 19 17:58:00 2005
-+++ src/ftrack.cpp Fri Aug 19 17:59:25 2005
-@@ -42,8 +42,8 @@
- #include "parsetpl.hpp"
- #include "tmstamp.hpp"
- #include "script.hpp"
--#include <iostream.h>
--#include <fstream.h>
-+#include <iostream>
-+#include <fstream>
- #include <smapi/msgapi.h>
-
- static struct utimbuf ut;
-@@ -53,7 +53,7 @@
- // Signals catch functions
- // --------------------------------------------------------------------
- void AbrtHndl(int Sign) {
--fstream fh ("FTrack.err", ios::append);
-+fstream fh ("FTrack.err", ios::app);
-
- cerr << "Internal Error!!! Please, read report.err in documentation.\n";
- cerr << "---------------------------------------\n";
diff --git a/mail/ftrack/files/patch-src__ustr.cpp b/mail/ftrack/files/patch-src__ustr.cpp
deleted file mode 100644
index 09741fdcd6f..00000000000
--- a/mail/ftrack/files/patch-src__ustr.cpp
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/ustr.cpp.orig Thu Jan 6 13:21:40 2005
-+++ src/ustr.cpp Thu Jan 6 13:20:44 2005
-@@ -297,7 +297,7 @@
- }
-
- Str &Str::Upper(void) {
-- for (int i = 0; i < Len; i++) {
-+ for (unsigned int i = 0; i < Len; i++) {
- Ptr[i] = toupper(Ptr[i]);
- }
- return *this;
diff --git a/mail/ftrack/files/patch-src__utils.cpp b/mail/ftrack/files/patch-src__utils.cpp
deleted file mode 100644
index 9f8364ebbcf..00000000000
--- a/mail/ftrack/files/patch-src__utils.cpp
+++ /dev/null
@@ -1,19 +0,0 @@
---- src/utils.cpp.orig Tue May 16 22:33:14 2000
-+++ src/utils.cpp Tue Jun 27 20:57:09 2000
-@@ -22,6 +22,7 @@
- #include <ctype.h>
- #ifdef __FreeBSD__
- # include <stdlib.h>
-+# include <sys/syslimits.h>
- #else
- # include <malloc.h>
- #endif
-@@ -144,7 +145,7 @@
- // Open file and create path if need.
- char *tmt;
- char Buff[1024];
-- umask(0);
-+ umask(022);
- strcpy(Buff,Name);
- tmt = strrchr(Buff,PATHDELIMC);
- if (tmt != NULL) {