aboutsummaryrefslogtreecommitdiffstats
path: root/mail/horde4-imp
diff options
context:
space:
mode:
Diffstat (limited to 'mail/horde4-imp')
-rw-r--r--mail/horde4-imp/files/pkg-deinstall.in10
-rw-r--r--mail/horde4-imp/files/pkg-install.in23
2 files changed, 26 insertions, 7 deletions
diff --git a/mail/horde4-imp/files/pkg-deinstall.in b/mail/horde4-imp/files/pkg-deinstall.in
index 13bb805c47d..e4787a72dfe 100644
--- a/mail/horde4-imp/files/pkg-deinstall.in
+++ b/mail/horde4-imp/files/pkg-deinstall.in
@@ -2,7 +2,6 @@
#
# $FreeBSD$
#
-# Backup IMP config files, if needed.
if [ x$2 != xDEINSTALL ]; then
exit
@@ -12,13 +11,10 @@ if [ -z "${PACKAGE_BUILDING}" ]; then
for cf in `ls %%IMPDIR%%/config/*php %%IMPDIR%%/config/*txt`; do
diff -bBqw $cf $cf.dist >/dev/null 2>&1
case $? in
- 0) # original config file, will be deleted by pkg-plist
+ 0) # original config file, delete it
+ rm -f $cf
;;
- 1) # config file has been updated, must be backuped
- cp -p $cf $cf.previous
- echo "===> Backing-up..."
- echo "---> $cf has been saved ***"
- echo "---> as $cf.previous ***"
+ 1) # config file has been updated, leave it alone
;;
*) # not found?
;;
diff --git a/mail/horde4-imp/files/pkg-install.in b/mail/horde4-imp/files/pkg-install.in
new file mode 100644
index 00000000000..7a19b9e2b9d
--- /dev/null
+++ b/mail/horde4-imp/files/pkg-install.in
@@ -0,0 +1,23 @@
+#!/bin/sh
+#
+# $FreeBSD$
+#
+
+PATH=/usr/sbin:/usr/bin:/bin ; export PATH
+
+case $2 in
+ PRE-INSTALL)
+ ;;
+
+ POST-INSTALL)
+ if [ -z "${PACKAGE_BUILDING}" ]; then
+ # Copy over sample config files unless they already exist
+
+ for cf in `ls %%IMPDIR%%/config/*.dist | sed -e 's/\.dist//g'`; do
+ if [ ! -f $cf ]; then
+ cp -p $cf.dist $cf
+ fi
+ done
+ fi
+ ;;
+esac