aboutsummaryrefslogtreecommitdiffstats
path: root/mail/horde4-ingo/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'mail/horde4-ingo/Makefile')
-rw-r--r--mail/horde4-ingo/Makefile49
1 files changed, 25 insertions, 24 deletions
diff --git a/mail/horde4-ingo/Makefile b/mail/horde4-ingo/Makefile
index 4462944fa04..f90b0cd6f68 100644
--- a/mail/horde4-ingo/Makefile
+++ b/mail/horde4-ingo/Makefile
@@ -6,31 +6,32 @@
#
PORTNAME= ingo
-PORTVERSION= 1.2.5
-DISTVERSIONSUFFIX=
-PORTREVISION= 1
-PORTEPOCH= 1
-CATEGORIES= mail www
+PORTVERSION= 2.0.3
+CATEGORIES= mail www pear
+PKGNAMEPREFIX= horde-
-MAINTAINER= beech@FreeBSD.org
-COMMENT= Email-filter management application
+MAINTAINER= mm@FreeBSD.org
+COMMENT= Horde email filter rules manager
-#-----------------------------------------------------------------------
-# You may define this option:
-#
-# - WITH_SIEVE : if you run timsieved (with Cyrus).
-#
-#-----------------------------------------------------------------------
-
-.if defined(WITH_SIEVE) || exists(${LOCALBASE}/cyrus/bin/timsieved)
-RUN_DEPENDS+= ${PEARDIR}/Net/Sieve.php:${PORTSDIR}/net/pear-Net_Sieve
-.endif
+LICENSE= ASL
+LICENSE_FILE= ${WRKSRC}/LICENSE
-BROKEN= Rewrite in progress
-USE_PHP= imap
-USE_HORDE= base pkg-message
-USE_GETTEXT= yes
-PORTDOCS= README CHANGES CREDITS INSTALL RELEASE_NOTES TODO
+USE_PHP= gettext
+USE_HORDE_BUILD= Horde_Role
+USE_HORDE_RUN= Horde_Role \
+ horde \
+ Horde_Auth \
+ Horde_Autoloader \
+ Horde_Core \
+ Horde_Exception \
+ Horde_Group \
+ Horde_Form \
+ Horde_Imap_Client \
+ Horde_Mime \
+ Horde_Perms \
+ Horde_Share \
+ Horde_Util
-.include "${.CURDIR}/../../www/horde-base/bsd.horde.mk"
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+.include "${PORTSDIR}/devel/pear-channel-horde/bsd.horde.mk"
+.include <bsd.port.post.mk>