aboutsummaryrefslogtreecommitdiffstats
path: root/mail/imap-uw/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'mail/imap-uw/Makefile')
-rw-r--r--mail/imap-uw/Makefile26
1 files changed, 3 insertions, 23 deletions
diff --git a/mail/imap-uw/Makefile b/mail/imap-uw/Makefile
index b40c83b7eae..51e2e22d1e0 100644
--- a/mail/imap-uw/Makefile
+++ b/mail/imap-uw/Makefile
@@ -3,6 +3,7 @@
PORTNAME= imap
PORTVERSION= 2007f
+PORTREVISION= 1
PORTEPOCH= 1
CATEGORIES= mail ipv6
MASTER_SITES= ftp://ftp.cac.washington.edu/imap/%SUBDIR%/ \
@@ -34,6 +35,7 @@ ALL_TARGET= bsf
OPTIONS_DEFINE= SSL SSL_AND_PLAINTEXT DRAC NETSCAPE_BRAIN_DAMAGE DOCS
OPTIONS_DEFAULT= SSL
+OPTIONS_SUB= yes
SSL_DESC= Compile with SSL support
SSL_AND_PLAINTEXT_DESC= Allow plain text passwords and SSL
DRAC_DESC= Dynamically open MTA for relaying
@@ -94,32 +96,10 @@ do-install:
${INSTALL_MAN} ${WRKSRC}/src/mailutil/mailutil.1 ${STAGEDIR}${PREFIX}/man/man1/
${INSTALL_MAN} ${WRKSRC}/src/tmail/tmail.1 ${STAGEDIR}${PREFIX}/man/man1/
-post-install:
- @${CAT} ${PKGMESSAGE}
-.if ${PORT_OPTIONS:MDRAC}
- @${ECHO} "================================================================================"
- @${ECHO} "To have DRAC working, you must create ${PREFIX}/etc/dracd.host, containing"
- @${ECHO} "the hostname of the DRAC server:"
- @${ECHO}
- @${ECHO} "localhost"
- @${ECHO} "================================================================================"
-.endif
-.if ${PORT_OPTIONS:MSSL}
- @${ECHO}
- @${ECHO} "To create and install a new SSL certificate for imapd and ipop3d, type \"make"
- @${ECHO} "cert\". Or install manually in ${PREFIX}/certs."
- @${ECHO}
- @${ECHO} "Example inetd config for SSL only services:"
- @${ECHO}
- @${ECHO} "pop3s stream tcp nowait root ${PREFIX}/libexec/ipop3d ipop3d"
- @${ECHO} "imaps stream tcp nowait root ${PREFIX}/libexec/imapd imapd"
- @${ECHO} "================================================================================"
-.endif
-.if ${PORT_OPTIONS:MDOCS}
+post-install-DOCS-on:
${MKDIR} -m 0755 -p ${STAGEDIR}${DOCSDIR}
@${TAR} -C ${WRKSRC}/docs -cf - . | \
(umask 022; ${TAR} -C ${STAGEDIR}${DOCSDIR} -xf -)
-.endif
cert:
@${INSTALL} -d -o root -g wheel -m 0755 ${PREFIX}/certs