aboutsummaryrefslogtreecommitdiffstats
path: root/mail/popd
diff options
context:
space:
mode:
Diffstat (limited to 'mail/popd')
-rw-r--r--mail/popd/files/patch-popd.c40
1 files changed, 40 insertions, 0 deletions
diff --git a/mail/popd/files/patch-popd.c b/mail/popd/files/patch-popd.c
new file mode 100644
index 00000000000..83d2fd805e4
--- /dev/null
+++ b/mail/popd/files/patch-popd.c
@@ -0,0 +1,40 @@
+--- src/popd.c.orig Wed Jun 15 15:28:13 2005
++++ src/popd.c Wed Jun 15 15:49:05 2005
+@@ -46,6 +46,7 @@
+ #include <unistd.h>
+
+ #include <poputil.h>
++#include <osreldate.h>
+ #include "config.h"
+ #include "popd.h"
+ #include "paths.h"
+@@ -280,9 +281,15 @@
+ }
+ #endif
+ if (bind(serverfd, r->ai_addr, r->ai_addrlen) < 0) {
++#if __FreeBSD_version >= 502000
++ getnameinfo(r->ai_addr, r->ai_addrlen,
++ ip, sizeof(ip), NULL, 0,
++ NI_NUMERICHOST);
++#else
+ getnameinfo(r->ai_addr, r->ai_addrlen,
+ ip, sizeof(ip), NULL, 0,
+ NI_NUMERICHOST | NI_WITHSCOPEID);
++#endif
+ syslog(facility, "Can't bind port %s on %s",
+ config.port, ip);
+ close(serverfd);
+@@ -434,8 +441,13 @@
+ facility = LOG_INFO;
+ if (config.daemonise || config.debug)
+ #ifdef USE_IPV6
++#if __FreeBSD_version >= 502000
++ getnameinfo((struct sockaddr *)&addr, addr.ss_len,
++ ip, sizeof(ip), NULL, 0, NI_NUMERICHOST);
++#else
+ getnameinfo((struct sockaddr *)&addr, addr.ss_len,
+ ip, sizeof(ip), NULL, 0, NI_NUMERICHOST | NI_WITHSCOPEID);
++#endif
+ if (config.daemonise || config.debug)
+ syslog(facility, "Connection from %s", ip);
+ #else
p;id=7ea9ad58c4d57d55897e09745b845a056cb91345'>Remove empty files.fjoe2008-09-032-0/+0 * - Update to 1.5.2fjoe2008-09-037-597/+207 * Bump portrevision due to upgrade of devel/gettext.edwin2008-06-061-1/+1 * Mark BROKEN: does not fetcherwin2008-02-031-0/+2 * - Welcome X.org 7.2 \o/.flz2007-05-201-1/+1 * NO_CDROM and NO_PACKAGE are not appropriate; use RESTRICTED here insteadkris2006-09-031-2/+1 * SHA256ifyedwin2006-01-221-0/+1 * New style bsd.java.mk.nork2005-10-231-1/+2 * . Fix incompatibilities with the new bsd.java.mk (oops).glewis2004-04-031-1/+1 * Add SIZE into distinfodaichi2004-03-181-0/+1 * Bump PORTREVISION on all ports that depend on gettext to aid with upgrading.marcus2004-02-041-0/+1 * o Print pkg-message for setting libmap.conf.nork2004-01-114-7/+62 * Add Linux Blackdown Java3D 1.3.1, provides a set of object-orientednork2003-12-30