aboutsummaryrefslogtreecommitdiffstats
path: root/mail/sentinel
diff options
context:
space:
mode:
Diffstat (limited to 'mail/sentinel')
-rw-r--r--mail/sentinel/Makefile12
1 files changed, 9 insertions, 3 deletions
diff --git a/mail/sentinel/Makefile b/mail/sentinel/Makefile
index bc0433dee51..d3c81a1baab 100644
--- a/mail/sentinel/Makefile
+++ b/mail/sentinel/Makefile
@@ -19,8 +19,14 @@ LIB_DEPENDS= pcre.0:${PORTSDIR}/devel/pcre
USE_REINPLACE= yes
-.if !exists(/usr/lib/libmilter.a)
-IGNORE= requires Sendmail 8.12; upgrade the base system
+.include <bsd.port.pre.mk>
+
+.if !exists(/usr/lib/libmilter.a) && !exists(${LOCALBASE}/lib/libmilter.a)
+IGNORE= requires Sendmail 8.12
+.endif
+.if exists(${LOCALBASE}/lib/libmilter.a)
+CFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
.endif
post-patch:
@@ -47,4 +53,4 @@ do-install:
post-install:
@${CAT} ${PKGMESSAGE}
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>