aboutsummaryrefslogtreecommitdiffstats
path: root/mail/svnmailer/files
diff options
context:
space:
mode:
Diffstat (limited to 'mail/svnmailer/files')
-rw-r--r--mail/svnmailer/files/patch-setup.py59
-rw-r--r--mail/svnmailer/files/py25-src-lib-svnmailer-notifier-_base.py26
2 files changed, 72 insertions, 13 deletions
diff --git a/mail/svnmailer/files/patch-setup.py b/mail/svnmailer/files/patch-setup.py
new file mode 100644
index 00000000000..91c6ffadf2f
--- /dev/null
+++ b/mail/svnmailer/files/patch-setup.py
@@ -0,0 +1,59 @@
+--- setup.py.orig 2005-09-25 22:47:47.000000000 +0400
++++ setup.py 2008-06-07 21:40:11.000000000 +0400
+@@ -1,4 +1,4 @@
+-#!/usr/bin/env python
++#!/usr/local/bin/python2.5
+ # -*- coding: utf-8 -*-
+ import os, sys
+
+@@ -157,7 +157,7 @@
+ moredocs.include_pattern(convre(r"docs/[^/]+"), is_regex = 1)
+ moredocs.exclude_pattern(convre(r"docs/[^/]+.\d"), is_regex = 1)
+ docs.extend(moredocs.files)
+- base = 'doc/svnmailer'
++ base = 'share/doc/svnmailer'
+ self.data_files.append((base, docs))
+
+ rre = re.escape('/') == '\\/'
+@@ -171,15 +171,15 @@
+ apidocs.include_pattern(
+ convre('%s/[^/]+' % repath), is_regex = 1
+ )
+- base = 'doc/svnmailer/%s'% path
++ base = 'share/doc/svnmailer/%s'% path
+ self.data_files.append((base, apidocs.files))
+
+ samples = fixfiles(SAMPLES)
+- base = 'doc/svnmailer/sample'
++ base = 'share/doc/svnmailer/sample'
+ self.data_files.append((base, samples))
+
+ hooks = HOOKS
+- base = 'doc/svnmailer/sample/hooks'
++ base = 'share/doc/svnmailer/sample/hooks'
+ if win32:
+ hooks = ["%s.bat" % hook for hook in hooks]
+ scriptsdefault = "C:\\path\\to"
+@@ -191,17 +191,17 @@
+ })
+ self.data_files.append((base, hooks))
+
++ # so late, because some files need to be touched in the tree
++ # anyway
++ if store.get('no-install-docs', False):
++ self.data_files = []
++
+ # man pages only on *x
+ if not win32:
+ for section, pages in MAN.items():
+ fixfiles(pages)
+ self.data_files.append(("man/man%s" % section, pages))
+
+- # so late, because some files need to be touched in the tree
+- # anyway
+- if store.get('no-install-docs', False):
+- self.data_files = []
+-
+
+ core.setup(
+ name = "svnmailer",
diff --git a/mail/svnmailer/files/py25-src-lib-svnmailer-notifier-_base.py b/mail/svnmailer/files/py25-src-lib-svnmailer-notifier-_base.py
index c0284187fa6..f74a54cf159 100644
--- a/mail/svnmailer/files/py25-src-lib-svnmailer-notifier-_base.py
+++ b/mail/svnmailer/files/py25-src-lib-svnmailer-notifier-_base.py
@@ -1,40 +1,40 @@
---- src/lib/svnmailer/notifier/_base.py.orig Mon Apr 17 14:29:06 2006
-+++ src/lib/svnmailer/notifier/_base.py Mon Oct 8 15:36:25 2007
-@@ -345,7 +345,6 @@
- @return: The two encodings
- @rtype: C{tuple} of C{str}
+--- src/lib/svnmailer/notifier/_base.py.orig 2005-09-25 14:51:23.000000000 +0000
++++ src/lib/svnmailer/notifier/_base.py 2007-08-20 17:29:23.000000000 +0000
+@@ -376,7 +376,6 @@
+ :return: The two encodings (``('enc1', 'enc2')``)
+ :rtype: ``tuple``
"""
- from encodings import exceptions
enc1 = enc2 = default
if not change.wasAdded() or change.wasCopied():
-@@ -353,7 +352,7 @@
+@@ -384,7 +383,7 @@
enc1 = self._getContentEncoding(
change.getBasePath(), change.getBaseRevision()
)
- except exceptions.LookupError:
+ except LookupError:
- # fall back
+ """ fall back """
pass
-@@ -364,7 +363,7 @@
+@@ -395,7 +394,7 @@
enc2 = self._getContentEncoding(
change.path, change.revision
)
- except exceptions.LookupError:
+ except LookupError:
- # fall back
+ """ fall back """
pass
-@@ -389,7 +388,6 @@
- @exception encodings.exception.LookupError: The specified encoding
- is not implemented or no encoding was specified
+@@ -423,7 +422,6 @@
+ The specified encoding is not implemented or no encoding
+ was specified
"""
- from encodings import exceptions
# first try the svn:mime-type
enc = self.getEncodingFromMimeType(path, revision)
-@@ -427,7 +425,7 @@
+@@ -461,7 +459,7 @@
codecs.lookup(enc)
return enc