aboutsummaryrefslogtreecommitdiffstats
path: root/mail
diff options
context:
space:
mode:
Diffstat (limited to 'mail')
-rw-r--r--mail/postfix/scripts/configure.postfix25
-rw-r--r--mail/postfix1/scripts/configure.postfix25
-rw-r--r--mail/postfix20/scripts/configure.postfix25
-rw-r--r--mail/postfix21/scripts/configure.postfix25
-rw-r--r--mail/postfix22/scripts/configure.postfix25
-rw-r--r--mail/postfix23/scripts/configure.postfix25
-rw-r--r--mail/postfix24/scripts/configure.postfix25
-rw-r--r--mail/postfix25/scripts/configure.postfix25
-rw-r--r--mail/postfix26/scripts/configure.postfix25
-rw-r--r--mail/postfix27/scripts/configure.postfix25
-rw-r--r--mail/postfix28/scripts/configure.postfix25
11 files changed, 220 insertions, 55 deletions
diff --git a/mail/postfix/scripts/configure.postfix b/mail/postfix/scripts/configure.postfix
index 825c3d21290..a2473399718 100644
--- a/mail/postfix/scripts/configure.postfix
+++ b/mail/postfix/scripts/configure.postfix
@@ -1,5 +1,5 @@
#!/bin/sh
-# $FreeBSD: /tmp/pcvs/ports/mail/postfix/scripts/Attic/configure.postfix,v 1.2 2001-03-05 22:15:24 knu Exp $
+# $FreeBSD: /tmp/pcvs/ports/mail/postfix/scripts/Attic/configure.postfix,v 1.3 2001-03-11 19:53:59 alex Exp $
if [ -f ${WRKDIRPREFIX}${CURDIR}/Makefile.inc ]; then
exit
@@ -10,18 +10,33 @@ tempfile=`mktemp -t checklist`
if [ "${BATCH}" = "yes" ]; then
set \"PCRE\"
else
- /usr/bin/dialog --title "Postfix configuration options" --clear \
- --checklist "\n\
+ # IPv6 patches are broken on alpha
+ if [ `uname -m` = "alpha" ]; then
+ /usr/bin/dialog --title "Postfix configuration options" --clear \
+ --checklist "\n\
Please select desired options:" -1 -1 16 \
-PCRE "Perl Compatible Regular Expressions" OFF \
+PCRE "Perl Compatible Regular Expressions" ON \
SASL "Cyrus SASL (Simple Authentication and Security Layer)" OFF \
DB3 "Berkeley DB3 (required if SASL also built with DB3)" OFF \
MySQL "MySQL map lookups" OFF \
OpenLDAP "OpenLDAP map lookups" OFF \
Test "SMTP/LMTP test server and generator" OFF \
TLS "Secure Sockets Layer and Transport Layer Security" OFF \
-IPv6 "IPv6 support" OFF \
2> $tempfile
+ else
+ /usr/bin/dialog --title "Postfix configuration options" --clear \
+ --checklist "\n\
+Please select desired options:" -1 -1 16 \
+PCRE "Perl Compatible Regular Expressions" ON \
+SASL "Cyrus SASL (Simple Authentication and Security Layer)" OFF \
+DB3 "Berkeley DB3 (required if SASL also built with DB3)" OFF \
+MySQL "MySQL map lookups" OFF \
+OpenLDAP "OpenLDAP map lookups" OFF \
+Test "SMTP/LMTP test server and generator" OFF \
+TLS "Secure Sockets Layer and Transport Layer Security" OFF \
+IPv6 "IPv6 support" OFF
+2> $tempfile
+ fi
retval=$?
diff --git a/mail/postfix1/scripts/configure.postfix b/mail/postfix1/scripts/configure.postfix
index c201ccdde71..07c0a567bfe 100644
--- a/mail/postfix1/scripts/configure.postfix
+++ b/mail/postfix1/scripts/configure.postfix
@@ -1,5 +1,5 @@
#!/bin/sh
-# $FreeBSD: /tmp/pcvs/ports/mail/postfix1/scripts/Attic/configure.postfix,v 1.2 2001-03-05 22:15:24 knu Exp $
+# $FreeBSD: /tmp/pcvs/ports/mail/postfix1/scripts/Attic/configure.postfix,v 1.3 2001-03-11 19:53:59 alex Exp $
if [ -f ${WRKDIRPREFIX}${CURDIR}/Makefile.inc ]; then
exit
@@ -10,18 +10,33 @@ tempfile=`mktemp -t checklist`
if [ "${BATCH}" = "yes" ]; then
set \"PCRE\"
else
- /usr/bin/dialog --title "Postfix configuration options" --clear \
- --checklist "\n\
+ # IPv6 patches are broken on alpha
+ if [ `uname -m` = "alpha" ]; then
+ /usr/bin/dialog --title "Postfix configuration options" --clear \
+ --checklist "\n\
Please select desired options:" -1 -1 16 \
-PCRE "Perl Compatible Regular Expressions" OFF \
+PCRE "Perl Compatible Regular Expressions" ON \
SASL "Cyrus SASL (Simple Authentication and Security Layer)" OFF \
DB3 "Berkeley DB3 (required if SASL also built with DB3)" OFF \
MySQL "MySQL map lookups" OFF \
OpenLDAP "OpenLDAP map lookups" OFF \
Test "SMTP/LMTP test server and generator" OFF \
TLS "Secure Sockets Layer and Transport Layer Security" OFF \
-IPv6 "IPv6 support" OFF \
2> $tempfile
+ else
+ /usr/bin/dialog --title "Postfix configuration options" --clear \
+ --checklist "\n\
+Please select desired options:" -1 -1 16 \
+PCRE "Perl Compatible Regular Expressions" ON \
+SASL "Cyrus SASL (Simple Authentication and Security Layer)" OFF \
+DB3 "Berkeley DB3 (required if SASL also built with DB3)" OFF \
+MySQL "MySQL map lookups" OFF \
+OpenLDAP "OpenLDAP map lookups" OFF \
+Test "SMTP/LMTP test server and generator" OFF \
+TLS "Secure Sockets Layer and Transport Layer Security" OFF \
+IPv6 "IPv6 support" OFF
+2> $tempfile
+ fi
retval=$?
diff --git a/mail/postfix20/scripts/configure.postfix b/mail/postfix20/scripts/configure.postfix
index 011e9cca1b1..9845ee32349 100644
--- a/mail/postfix20/scripts/configure.postfix
+++ b/mail/postfix20/scripts/configure.postfix
@@ -1,5 +1,5 @@
#!/bin/sh
-# $FreeBSD: /tmp/pcvs/ports/mail/postfix20/scripts/Attic/configure.postfix,v 1.2 2001-03-05 22:15:24 knu Exp $
+# $FreeBSD: /tmp/pcvs/ports/mail/postfix20/scripts/Attic/configure.postfix,v 1.3 2001-03-11 19:53:59 alex Exp $
if [ -f ${WRKDIRPREFIX}${CURDIR}/Makefile.inc ]; then
exit
@@ -10,18 +10,33 @@ tempfile=`mktemp -t checklist`
if [ "${BATCH}" = "yes" ]; then
set \"PCRE\"
else
- /usr/bin/dialog --title "Postfix configuration options" --clear \
- --checklist "\n\
+ # IPv6 patches are broken on alpha
+ if [ `uname -m` = "alpha" ]; then
+ /usr/bin/dialog --title "Postfix configuration options" --clear \
+ --checklist "\n\
Please select desired options:" -1 -1 16 \
-PCRE "Perl Compatible Regular Expressions" OFF \
+PCRE "Perl Compatible Regular Expressions" ON \
SASL "Cyrus SASL (Simple Authentication and Security Layer)" OFF \
DB3 "Berkeley DB3 (required if SASL also built with DB3)" OFF \
MySQL "MySQL map lookups" OFF \
OpenLDAP "OpenLDAP map lookups" OFF \
Test "SMTP/LMTP test server and generator" OFF \
TLS "Secure Sockets Layer and Transport Layer Security" OFF \
-IPv6 "IPv6 support" OFF \
2> $tempfile
+ else
+ /usr/bin/dialog --title "Postfix configuration options" --clear \
+ --checklist "\n\
+Please select desired options:" -1 -1 16 \
+PCRE "Perl Compatible Regular Expressions" ON \
+SASL "Cyrus SASL (Simple Authentication and Security Layer)" OFF \
+DB3 "Berkeley DB3 (required if SASL also built with DB3)" OFF \
+MySQL "MySQL map lookups" OFF \
+OpenLDAP "OpenLDAP map lookups" OFF \
+Test "SMTP/LMTP test server and generator" OFF \
+TLS "Secure Sockets Layer and Transport Layer Security" OFF \
+IPv6 "IPv6 support" OFF
+2> $tempfile
+ fi
retval=$?
diff --git a/mail/postfix21/scripts/configure.postfix b/mail/postfix21/scripts/configure.postfix
index 5eddb707b64..46ed8bab9a7 100644
--- a/mail/postfix21/scripts/configure.postfix
+++ b/mail/postfix21/scripts/configure.postfix
@@ -1,5 +1,5 @@
#!/bin/sh
-# $FreeBSD: /tmp/pcvs/ports/mail/postfix21/scripts/Attic/configure.postfix,v 1.2 2001-03-05 22:15:24 knu Exp $
+# $FreeBSD: /tmp/pcvs/ports/mail/postfix21/scripts/Attic/configure.postfix,v 1.3 2001-03-11 19:53:59 alex Exp $
if [ -f ${WRKDIRPREFIX}${CURDIR}/Makefile.inc ]; then
exit
@@ -10,18 +10,33 @@ tempfile=`mktemp -t checklist`
if [ "${BATCH}" = "yes" ]; then
set \"PCRE\"
else
- /usr/bin/dialog --title "Postfix configuration options" --clear \
- --checklist "\n\
+ # IPv6 patches are broken on alpha
+ if [ `uname -m` = "alpha" ]; then
+ /usr/bin/dialog --title "Postfix configuration options" --clear \
+ --checklist "\n\
Please select desired options:" -1 -1 16 \
-PCRE "Perl Compatible Regular Expressions" OFF \
+PCRE "Perl Compatible Regular Expressions" ON \
SASL "Cyrus SASL (Simple Authentication and Security Layer)" OFF \
DB3 "Berkeley DB3 (required if SASL also built with DB3)" OFF \
MySQL "MySQL map lookups" OFF \
OpenLDAP "OpenLDAP map lookups" OFF \
Test "SMTP/LMTP test server and generator" OFF \
TLS "Secure Sockets Layer and Transport Layer Security" OFF \
-IPv6 "IPv6 support" OFF \
2> $tempfile
+ else
+ /usr/bin/dialog --title "Postfix configuration options" --clear \
+ --checklist "\n\
+Please select desired options:" -1 -1 16 \
+PCRE "Perl Compatible Regular Expressions" ON \
+SASL "Cyrus SASL (Simple Authentication and Security Layer)" OFF \
+DB3 "Berkeley DB3 (required if SASL also built with DB3)" OFF \
+MySQL "MySQL map lookups" OFF \
+OpenLDAP "OpenLDAP map lookups" OFF \
+Test "SMTP/LMTP test server and generator" OFF \
+TLS "Secure Sockets Layer and Transport Layer Security" OFF \
+IPv6 "IPv6 support" OFF
+2> $tempfile
+ fi
retval=$?
diff --git a/mail/postfix22/scripts/configure.postfix b/mail/postfix22/scripts/configure.postfix
index d36faf342a7..58655da4e43 100644
--- a/mail/postfix22/scripts/configure.postfix
+++ b/mail/postfix22/scripts/configure.postfix
@@ -1,5 +1,5 @@
#!/bin/sh
-# $FreeBSD: /tmp/pcvs/ports/mail/postfix22/scripts/Attic/configure.postfix,v 1.2 2001-03-05 22:15:24 knu Exp $
+# $FreeBSD: /tmp/pcvs/ports/mail/postfix22/scripts/Attic/configure.postfix,v 1.3 2001-03-11 19:53:59 alex Exp $
if [ -f ${WRKDIRPREFIX}${CURDIR}/Makefile.inc ]; then
exit
@@ -10,18 +10,33 @@ tempfile=`mktemp -t checklist`
if [ "${BATCH}" = "yes" ]; then
set \"PCRE\"
else
- /usr/bin/dialog --title "Postfix configuration options" --clear \
- --checklist "\n\
+ # IPv6 patches are broken on alpha
+ if [ `uname -m` = "alpha" ]; then
+ /usr/bin/dialog --title "Postfix configuration options" --clear \
+ --checklist "\n\
Please select desired options:" -1 -1 16 \
-PCRE "Perl Compatible Regular Expressions" OFF \
+PCRE "Perl Compatible Regular Expressions" ON \
SASL "Cyrus SASL (Simple Authentication and Security Layer)" OFF \
DB3 "Berkeley DB3 (required if SASL also built with DB3)" OFF \
MySQL "MySQL map lookups" OFF \
OpenLDAP "OpenLDAP map lookups" OFF \
Test "SMTP/LMTP test server and generator" OFF \
TLS "Secure Sockets Layer and Transport Layer Security" OFF \
-IPv6 "IPv6 support" OFF \
2> $tempfile
+ else
+ /usr/bin/dialog --title "Postfix configuration options" --clear \
+ --checklist "\n\
+Please select desired options:" -1 -1 16 \
+PCRE "Perl Compatible Regular Expressions" ON \
+SASL "Cyrus SASL (Simple Authentication and Security Layer)" OFF \
+DB3 "Berkeley DB3 (required if SASL also built with DB3)" OFF \
+MySQL "MySQL map lookups" OFF \
+OpenLDAP "OpenLDAP map lookups" OFF \
+Test "SMTP/LMTP test server and generator" OFF \
+TLS "Secure Sockets Layer and Transport Layer Security" OFF \
+IPv6 "IPv6 support" OFF
+2> $tempfile
+ fi
retval=$?
diff --git a/mail/postfix23/scripts/configure.postfix b/mail/postfix23/scripts/configure.postfix
index a27aeca1872..b830c60f1dd 100644
--- a/mail/postfix23/scripts/configure.postfix
+++ b/mail/postfix23/scripts/configure.postfix
@@ -1,5 +1,5 @@
#!/bin/sh
-# $FreeBSD: /tmp/pcvs/ports/mail/postfix23/scripts/Attic/configure.postfix,v 1.2 2001-03-05 22:15:24 knu Exp $
+# $FreeBSD: /tmp/pcvs/ports/mail/postfix23/scripts/Attic/configure.postfix,v 1.3 2001-03-11 19:53:59 alex Exp $
if [ -f ${WRKDIRPREFIX}${CURDIR}/Makefile.inc ]; then
exit
@@ -10,18 +10,33 @@ tempfile=`mktemp -t checklist`
if [ "${BATCH}" = "yes" ]; then
set \"PCRE\"
else
- /usr/bin/dialog --title "Postfix configuration options" --clear \
- --checklist "\n\
+ # IPv6 patches are broken on alpha
+ if [ `uname -m` = "alpha" ]; then
+ /usr/bin/dialog --title "Postfix configuration options" --clear \
+ --checklist "\n\
Please select desired options:" -1 -1 16 \
-PCRE "Perl Compatible Regular Expressions" OFF \
+PCRE "Perl Compatible Regular Expressions" ON \
SASL "Cyrus SASL (Simple Authentication and Security Layer)" OFF \
DB3 "Berkeley DB3 (required if SASL also built with DB3)" OFF \
MySQL "MySQL map lookups" OFF \
OpenLDAP "OpenLDAP map lookups" OFF \
Test "SMTP/LMTP test server and generator" OFF \
TLS "Secure Sockets Layer and Transport Layer Security" OFF \
-IPv6 "IPv6 support" OFF \
2> $tempfile
+ else
+ /usr/bin/dialog --title "Postfix configuration options" --clear \
+ --checklist "\n\
+Please select desired options:" -1 -1 16 \
+PCRE "Perl Compatible Regular Expressions" ON \
+SASL "Cyrus SASL (Simple Authentication and Security Layer)" OFF \
+DB3 "Berkeley DB3 (required if SASL also built with DB3)" OFF \
+MySQL "MySQL map lookups" OFF \
+OpenLDAP "OpenLDAP map lookups" OFF \
+Test "SMTP/LMTP test server and generator" OFF \
+TLS "Secure Sockets Layer and Transport Layer Security" OFF \
+IPv6 "IPv6 support" OFF
+2> $tempfile
+ fi
retval=$?
diff --git a/mail/postfix24/scripts/configure.postfix b/mail/postfix24/scripts/configure.postfix
index a7895ca1d6d..d6a98621555 100644
--- a/mail/postfix24/scripts/configure.postfix
+++ b/mail/postfix24/scripts/configure.postfix
@@ -1,5 +1,5 @@
#!/bin/sh
-# $FreeBSD: /tmp/pcvs/ports/mail/postfix24/scripts/Attic/configure.postfix,v 1.2 2001-03-05 22:15:24 knu Exp $
+# $FreeBSD: /tmp/pcvs/ports/mail/postfix24/scripts/Attic/configure.postfix,v 1.3 2001-03-11 19:53:59 alex Exp $
if [ -f ${WRKDIRPREFIX}${CURDIR}/Makefile.inc ]; then
exit
@@ -10,18 +10,33 @@ tempfile=`mktemp -t checklist`
if [ "${BATCH}" = "yes" ]; then
set \"PCRE\"
else
- /usr/bin/dialog --title "Postfix configuration options" --clear \
- --checklist "\n\
+ # IPv6 patches are broken on alpha
+ if [ `uname -m` = "alpha" ]; then
+ /usr/bin/dialog --title "Postfix configuration options" --clear \
+ --checklist "\n\
Please select desired options:" -1 -1 16 \
-PCRE "Perl Compatible Regular Expressions" OFF \
+PCRE "Perl Compatible Regular Expressions" ON \
SASL "Cyrus SASL (Simple Authentication and Security Layer)" OFF \
DB3 "Berkeley DB3 (required if SASL also built with DB3)" OFF \
MySQL "MySQL map lookups" OFF \
OpenLDAP "OpenLDAP map lookups" OFF \
Test "SMTP/LMTP test server and generator" OFF \
TLS "Secure Sockets Layer and Transport Layer Security" OFF \
-IPv6 "IPv6 support" OFF \
2> $tempfile
+ else
+ /usr/bin/dialog --title "Postfix configuration options" --clear \
+ --checklist "\n\
+Please select desired options:" -1 -1 16 \
+PCRE "Perl Compatible Regular Expressions" ON \
+SASL "Cyrus SASL (Simple Authentication and Security Layer)" OFF \
+DB3 "Berkeley DB3 (required if SASL also built with DB3)" OFF \
+MySQL "MySQL map lookups" OFF \
+OpenLDAP "OpenLDAP map lookups" OFF \
+Test "SMTP/LMTP test server and generator" OFF \
+TLS "Secure Sockets Layer and Transport Layer Security" OFF \
+IPv6 "IPv6 support" OFF
+2> $tempfile
+ fi
retval=$?
diff --git a/mail/postfix25/scripts/configure.postfix b/mail/postfix25/scripts/configure.postfix
index 45e46e58a08..3ac92b516ab 100644
--- a/mail/postfix25/scripts/configure.postfix
+++ b/mail/postfix25/scripts/configure.postfix
@@ -1,5 +1,5 @@
#!/bin/sh
-# $FreeBSD: /tmp/pcvs/ports/mail/postfix25/scripts/Attic/configure.postfix,v 1.2 2001-03-05 22:15:24 knu Exp $
+# $FreeBSD: /tmp/pcvs/ports/mail/postfix25/scripts/Attic/configure.postfix,v 1.3 2001-03-11 19:53:59 alex Exp $
if [ -f ${WRKDIRPREFIX}${CURDIR}/Makefile.inc ]; then
exit
@@ -10,18 +10,33 @@ tempfile=`mktemp -t checklist`
if [ "${BATCH}" = "yes" ]; then
set \"PCRE\"
else
- /usr/bin/dialog --title "Postfix configuration options" --clear \
- --checklist "\n\
+ # IPv6 patches are broken on alpha
+ if [ `uname -m` = "alpha" ]; then
+ /usr/bin/dialog --title "Postfix configuration options" --clear \
+ --checklist "\n\
Please select desired options:" -1 -1 16 \
-PCRE "Perl Compatible Regular Expressions" OFF \
+PCRE "Perl Compatible Regular Expressions" ON \
SASL "Cyrus SASL (Simple Authentication and Security Layer)" OFF \
DB3 "Berkeley DB3 (required if SASL also built with DB3)" OFF \
MySQL "MySQL map lookups" OFF \
OpenLDAP "OpenLDAP map lookups" OFF \
Test "SMTP/LMTP test server and generator" OFF \
TLS "Secure Sockets Layer and Transport Layer Security" OFF \
-IPv6 "IPv6 support" OFF \
2> $tempfile
+ else
+ /usr/bin/dialog --title "Postfix configuration options" --clear \
+ --checklist "\n\
+Please select desired options:" -1 -1 16 \
+PCRE "Perl Compatible Regular Expressions" ON \
+SASL "Cyrus SASL (Simple Authentication and Security Layer)" OFF \
+DB3 "Berkeley DB3 (required if SASL also built with DB3)" OFF \
+MySQL "MySQL map lookups" OFF \
+OpenLDAP "OpenLDAP map lookups" OFF \
+Test "SMTP/LMTP test server and generator" OFF \
+TLS "Secure Sockets Layer and Transport Layer Security" OFF \
+IPv6 "IPv6 support" OFF
+2> $tempfile
+ fi
retval=$?
diff --git a/mail/postfix26/scripts/configure.postfix b/mail/postfix26/scripts/configure.postfix
index 633e23d474a..90e5b5ca404 100644
--- a/mail/postfix26/scripts/configure.postfix
+++ b/mail/postfix26/scripts/configure.postfix
@@ -1,5 +1,5 @@
#!/bin/sh
-# $FreeBSD: /tmp/pcvs/ports/mail/postfix26/scripts/Attic/configure.postfix,v 1.2 2001-03-05 22:15:24 knu Exp $
+# $FreeBSD: /tmp/pcvs/ports/mail/postfix26/scripts/Attic/configure.postfix,v 1.3 2001-03-11 19:53:59 alex Exp $
if [ -f ${WRKDIRPREFIX}${CURDIR}/Makefile.inc ]; then
exit
@@ -10,18 +10,33 @@ tempfile=`mktemp -t checklist`
if [ "${BATCH}" = "yes" ]; then
set \"PCRE\"
else
- /usr/bin/dialog --title "Postfix configuration options" --clear \
- --checklist "\n\
+ # IPv6 patches are broken on alpha
+ if [ `uname -m` = "alpha" ]; then
+ /usr/bin/dialog --title "Postfix configuration options" --clear \
+ --checklist "\n\
Please select desired options:" -1 -1 16 \
-PCRE "Perl Compatible Regular Expressions" OFF \
+PCRE "Perl Compatible Regular Expressions" ON \
SASL "Cyrus SASL (Simple Authentication and Security Layer)" OFF \
DB3 "Berkeley DB3 (required if SASL also built with DB3)" OFF \
MySQL "MySQL map lookups" OFF \
OpenLDAP "OpenLDAP map lookups" OFF \
Test "SMTP/LMTP test server and generator" OFF \
TLS "Secure Sockets Layer and Transport Layer Security" OFF \
-IPv6 "IPv6 support" OFF \
2> $tempfile
+ else
+ /usr/bin/dialog --title "Postfix configuration options" --clear \
+ --checklist "\n\
+Please select desired options:" -1 -1 16 \
+PCRE "Perl Compatible Regular Expressions" ON \
+SASL "Cyrus SASL (Simple Authentication and Security Layer)" OFF \
+DB3 "Berkeley DB3 (required if SASL also built with DB3)" OFF \
+MySQL "MySQL map lookups" OFF \
+OpenLDAP "OpenLDAP map lookups" OFF \
+Test "SMTP/LMTP test server and generator" OFF \
+TLS "Secure Sockets Layer and Transport Layer Security" OFF \
+IPv6 "IPv6 support" OFF
+2> $tempfile
+ fi
retval=$?
diff --git a/mail/postfix27/scripts/configure.postfix b/mail/postfix27/scripts/configure.postfix
index 0d13afff39e..8b1a2ea6269 100644
--- a/mail/postfix27/scripts/configure.postfix
+++ b/mail/postfix27/scripts/configure.postfix
@@ -1,5 +1,5 @@
#!/bin/sh
-# $FreeBSD: /tmp/pcvs/ports/mail/postfix27/scripts/Attic/configure.postfix,v 1.2 2001-03-05 22:15:24 knu Exp $
+# $FreeBSD: /tmp/pcvs/ports/mail/postfix27/scripts/Attic/configure.postfix,v 1.3 2001-03-11 19:53:59 alex Exp $
if [ -f ${WRKDIRPREFIX}${CURDIR}/Makefile.inc ]; then
exit
@@ -10,18 +10,33 @@ tempfile=`mktemp -t checklist`
if [ "${BATCH}" = "yes" ]; then
set \"PCRE\"
else
- /usr/bin/dialog --title "Postfix configuration options" --clear \
- --checklist "\n\
+ # IPv6 patches are broken on alpha
+ if [ `uname -m` = "alpha" ]; then
+ /usr/bin/dialog --title "Postfix configuration options" --clear \
+ --checklist "\n\
Please select desired options:" -1 -1 16 \
-PCRE "Perl Compatible Regular Expressions" OFF \
+PCRE "Perl Compatible Regular Expressions" ON \
SASL "Cyrus SASL (Simple Authentication and Security Layer)" OFF \
DB3 "Berkeley DB3 (required if SASL also built with DB3)" OFF \
MySQL "MySQL map lookups" OFF \
OpenLDAP "OpenLDAP map lookups" OFF \
Test "SMTP/LMTP test server and generator" OFF \
TLS "Secure Sockets Layer and Transport Layer Security" OFF \
-IPv6 "IPv6 support" OFF \
2> $tempfile
+ else
+ /usr/bin/dialog --title "Postfix configuration options" --clear \
+ --checklist "\n\
+Please select desired options:" -1 -1 16 \
+PCRE "Perl Compatible Regular Expressions" ON \
+SASL "Cyrus SASL (Simple Authentication and Security Layer)" OFF \
+DB3 "Berkeley DB3 (required if SASL also built with DB3)" OFF \
+MySQL "MySQL map lookups" OFF \
+OpenLDAP "OpenLDAP map lookups" OFF \
+Test "SMTP/LMTP test server and generator" OFF \
+TLS "Secure Sockets Layer and Transport Layer Security" OFF \
+IPv6 "IPv6 support" OFF
+2> $tempfile
+ fi
retval=$?
diff --git a/mail/postfix28/scripts/configure.postfix b/mail/postfix28/scripts/configure.postfix
index a08ba3496d7..f99a1d0dbb5 100644
--- a/mail/postfix28/scripts/configure.postfix
+++ b/mail/postfix28/scripts/configure.postfix
@@ -1,5 +1,5 @@
#!/bin/sh
-# $FreeBSD: /tmp/pcvs/ports/mail/postfix28/scripts/Attic/configure.postfix,v 1.2 2001-03-05 22:15:24 knu Exp $
+# $FreeBSD: /tmp/pcvs/ports/mail/postfix28/scripts/Attic/configure.postfix,v 1.3 2001-03-11 19:53:59 alex Exp $
if [ -f ${WRKDIRPREFIX}${CURDIR}/Makefile.inc ]; then
exit
@@ -10,18 +10,33 @@ tempfile=`mktemp -t checklist`
if [ "${BATCH}" = "yes" ]; then
set \"PCRE\"
else
- /usr/bin/dialog --title "Postfix configuration options" --clear \
- --checklist "\n\
+ # IPv6 patches are broken on alpha
+ if [ `uname -m` = "alpha" ]; then
+ /usr/bin/dialog --title "Postfix configuration options" --clear \
+ --checklist "\n\
Please select desired options:" -1 -1 16 \
-PCRE "Perl Compatible Regular Expressions" OFF \
+PCRE "Perl Compatible Regular Expressions" ON \
SASL "Cyrus SASL (Simple Authentication and Security Layer)" OFF \
DB3 "Berkeley DB3 (required if SASL also built with DB3)" OFF \
MySQL "MySQL map lookups" OFF \
OpenLDAP "OpenLDAP map lookups" OFF \
Test "SMTP/LMTP test server and generator" OFF \
TLS "Secure Sockets Layer and Transport Layer Security" OFF \
-IPv6 "IPv6 support" OFF \
2> $tempfile
+ else
+ /usr/bin/dialog --title "Postfix configuration options" --clear \
+ --checklist "\n\
+Please select desired options:" -1 -1 16 \
+PCRE "Perl Compatible Regular Expressions" ON \
+SASL "Cyrus SASL (Simple Authentication and Security Layer)" OFF \
+DB3 "Berkeley DB3 (required if SASL also built with DB3)" OFF \
+MySQL "MySQL map lookups" OFF \
+OpenLDAP "OpenLDAP map lookups" OFF \
+Test "SMTP/LMTP test server and generator" OFF \
+TLS "Secure Sockets Layer and Transport Layer Security" OFF \
+IPv6 "IPv6 support" OFF
+2> $tempfile
+ fi
retval=$?